aboutsummaryrefslogtreecommitdiff
path: root/chinese/autoconvert
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-03-22 08:43:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-03-22 08:43:56 +0000
commit38cde263a314d40093dc4da0595ba7dc51a40298 (patch)
tree333d4e9a1d9f2eced615c5c5f69085979d3ef60f /chinese/autoconvert
parent37c29839e65c7b8e22afcfbf0c0afb77885ffe74 (diff)
downloadports-38cde263a314d40093dc4da0595ba7dc51a40298.tar.gz
ports-38cde263a314d40093dc4da0595ba7dc51a40298.zip
Improve amd64 fix, Only build shared library with -fPIC
Notes
Notes: svn path=/head/; revision=104905
Diffstat (limited to 'chinese/autoconvert')
-rw-r--r--chinese/autoconvert/Makefile6
-rw-r--r--chinese/autoconvert/files/patch-ab11
2 files changed, 10 insertions, 7 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index dbc75180fb13..6d1895c38cf0 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -15,15 +15,13 @@ COMMENT= Intelligent Chinese encoding converter
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-CFLAGS+= ${CPPFLAGS} -fPIC
MAKE_ENV= CFLAG="${CPPFLAGS}" LIBS="${LDFLAGS}"
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
post-patch:
-.for dir in hzconvert contrib/xchat-plugins
- @${REINPLACE_CMD} -e "s|^CFLAGS|#CLFAGS|" ${WRKSRC}/${dir}/Makefile
-.endfor
+ @${REINPLACE_CMD} -e "s|^CFLAGS|#CFLAGS|" \
+ ${WRKSRC}/contrib/xchat-plugins/Makefile
pre-install:
@${MKDIR} ${DATADIR}
diff --git a/chinese/autoconvert/files/patch-ab b/chinese/autoconvert/files/patch-ab
index 4a2b37fe86a3..f1e7e8e4e3b7 100644
--- a/chinese/autoconvert/files/patch-ab
+++ b/chinese/autoconvert/files/patch-ab
@@ -1,6 +1,11 @@
---- hzconvert/Makefile.orig Mon Jan 8 18:05:51 2001
-+++ hzconvert/Makefile Tue Jan 9 02:02:33 2001
-@@ -5,14 +5,14 @@
+--- hzconvert/Makefile.orig Mon Jan 8 11:03:21 2001
++++ hzconvert/Makefile Mon Mar 22 09:39:15 2004
+@@ -1,18 +1,18 @@
+ CC=gcc -I../include
+-CFLAGS=-O2 -Wall -g
++CFLAGS+=-fPIC -Wall -g
+ SHARED_LIB=libhz.so
+ SHARED_LIB_MAJOR=$(SHARED_LIB).0
SHARED_LIB_MINOR=$(SHARED_LIB_MAJOR).0
OBJS=b2g.o b2u.o g2u.o hz2gb.o b2g_tables.o b2u_tables.o g2u_tables.o io.o unicode.o judge.o judge3.o gbpercent.o b5percent.o search.o