aboutsummaryrefslogtreecommitdiff
path: root/chinese/cnprint
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-05-18 11:02:47 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-05-18 11:02:47 +0000
commit6a058c282ddfc8debf6d1c47b2ce98b107b60897 (patch)
tree286245a78ef2487f63e890f55914185cad1da2bf /chinese/cnprint
parentdb29a7b53bddfa25029d26f4944c93f3ada1cc03 (diff)
downloadports-6a058c282ddfc8debf6d1c47b2ce98b107b60897.tar.gz
ports-6a058c282ddfc8debf6d1c47b2ce98b107b60897.zip
- Add an option to make default paper size A4
PR: ports/134638 Submitted by: Chun-Chung Yang <chunchung AT cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=234132
Diffstat (limited to 'chinese/cnprint')
-rw-r--r--chinese/cnprint/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/chinese/cnprint/Makefile b/chinese/cnprint/Makefile
index 11c7887c576c..095f11e0515c 100644
--- a/chinese/cnprint/Makefile
+++ b/chinese/cnprint/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cnprint
PORTVERSION= 3.30b
+PORTREVISION= 1
CATEGORIES= chinese print
MASTER_SITES= http://ftp.wustl.edu/pub/FreeBSD/distfiles/${PORTNAME}-${PORTVERSION}/ \
http://ftp.yz.yamagata-u.ac.jp/pub/FreeBSD/distfiles/${PORTNAME}-${PORTVERSION}/ \
@@ -23,6 +24,10 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
FILES= ${WRKSRC}/*.sym ${WRKSRC}/*.htf ${WRKSRC}/*.hbf \
${WRKSRC}/*.bin ${WRKSRC}/*.ttf
+OPTIONS= A4SIZE "Set A4 (not Letter) as a default paper size" on
+
+.include <bsd.port.pre.mk>
+
do-extract:
${MKDIR} ${WRKSRC}
.for i in ${DISTFILES}
@@ -39,6 +44,10 @@ post-patch:
@${REINPLACE_CMD} -e 's/\(DEFAULT_JIS_FONT\):.*$$/\1: kanji48.hbf/; \
s/\(DEFAULT_BIG5FONT\):.*$$/\1: ntu_kai48.hbf/; \
s/\(DEFAULT_ENCODING\):.*$$/\1: BIG5/' ${WRKSRC}/cnprint33.cmd
+.if defined(WITH_A4SIZE)
+ @${REINPLACE_CMD} -e 's/\(DEFAULT_PAPERSIZE\):.*$$/\1: 8.27 11.69/' \
+ ${WRKSRC}/cnprint33.cmd
+.endif
do-build:
cd ${WRKSRC} ; \
@@ -50,4 +59,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}33.cmd ${DATADIR}/${PORTNAME}.cmd
${INSTALL_DATA} ${FILES} ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>