aboutsummaryrefslogtreecommitdiff
path: root/chinese/docproj
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2014-05-20 00:43:07 +0000
committerXin LI <delphij@FreeBSD.org>2014-05-20 00:43:07 +0000
commit8da2472a6e16b42dfcfa6ed8578d00a65b180373 (patch)
tree28e3675a66c8ccf38dd171f21dc392581454c195 /chinese/docproj
parent89cb192015423551f59eef4787eb4f1024bdc7aa (diff)
downloadports-8da2472a6e16b42dfcfa6ed8578d00a65b180373.tar.gz
ports-8da2472a6e16b42dfcfa6ed8578d00a65b180373.zip
Make it possible to stage without privilege.
No PORTREVISION bump because this does not change results of the build. Reported by: Andrzej Tobola <ato iem pw edu pl>
Notes
Notes: svn path=/head/; revision=354588
Diffstat (limited to 'chinese/docproj')
-rw-r--r--chinese/docproj/Makefile2
-rw-r--r--chinese/docproj/src/cjktexsty/Makefile5
2 files changed, 6 insertions, 1 deletions
diff --git a/chinese/docproj/Makefile b/chinese/docproj/Makefile
index 60986292756d..de668e234439 100644
--- a/chinese/docproj/Makefile
+++ b/chinese/docproj/Makefile
@@ -23,7 +23,7 @@ USES= iconv
WRKSRC= ${WRKDIR}/src
SRC= ${.CURDIR}/src
-MAKE_ARGS+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
+MAKE_ARGS+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} INSTALL_PROGRAM="${INSTALL_PROGRAM}"
PLIST_FILES= bin/cjktexsty
diff --git a/chinese/docproj/src/cjktexsty/Makefile b/chinese/docproj/src/cjktexsty/Makefile
index 32f184e1c687..7d635bd0fbd3 100644
--- a/chinese/docproj/src/cjktexsty/Makefile
+++ b/chinese/docproj/src/cjktexsty/Makefile
@@ -11,4 +11,9 @@ LDADD= -L${LOCALBASE}/lib -liconv
NO_MAN=
NOMAN=
+.if defined(BSD_INSTALL_PROGRAM)
+install:
+ ${BSD_INSTALL_PROGRAM} ${PROG} ${DESTDIR}${BINDIR}/${PROGNAME}
+.endif
+
.include <bsd.prog.mk>