aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx-configtool
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-02-07 20:57:08 +0000
committerXin LI <delphij@FreeBSD.org>2012-02-07 20:57:08 +0000
commit3390f7060e630b0f7e13ba19350cd65380b88cfe (patch)
tree5cd4bc1e8584a97698efa13cf8b94b990f901179 /chinese/fcitx-configtool
parent86d3a677657db88b4c3b497f0e2fa33833199deb (diff)
downloadports-3390f7060e630b0f7e13ba19350cd65380b88cfe.tar.gz
ports-3390f7060e630b0f7e13ba19350cd65380b88cfe.zip
Update fcitx and friends:
- fcitx to 4.2.0, always depend on dbus - fcitx-cloudpinyin to 0.2.0 - fcitx-configtool to 0.4.0 - fcitx-googlepinyin to 0.1.4 - fcitx-sunpinyin to 0.3.3 - fcitx-ui-light to 0.1.3 - libgooglepinyin to 0.1.2 PR: ports/164820 Submitted by: maintainer (Zhihao Yuan <lichray gmail com>
Notes
Notes: svn path=/head/; revision=290612
Diffstat (limited to 'chinese/fcitx-configtool')
-rw-r--r--chinese/fcitx-configtool/Makefile33
-rw-r--r--chinese/fcitx-configtool/distinfo4
-rw-r--r--chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt10
-rw-r--r--chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt10
-rw-r--r--chinese/fcitx-configtool/pkg-plist4
5 files changed, 54 insertions, 7 deletions
diff --git a/chinese/fcitx-configtool/Makefile b/chinese/fcitx-configtool/Makefile
index 4ce8af2f2681..a6391441a6a9 100644
--- a/chinese/fcitx-configtool/Makefile
+++ b/chinese/fcitx-configtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fcitx-configtool
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4.0
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@@ -14,16 +14,39 @@ DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= Fcitx IM configure tool
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx
USE_BZIP2= yes
-USE_GNOME= gtk20 intltool gnomehack
+USE_GNOME= intltool gnomehack
USE_GETTEXT= yes
USE_CMAKE= yes
-PROJECTHOST= fcitx
+OPTIONS= GTK2 "Enable Gtk2 Version" on \
+ GTK3 "Enable Gtk3 Version" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+PLIST_SUB+= GTK2=""
+.else
+CMAKE_ARGS+= -DENABLE_GTK2=OFF
+PLIST_SUB+= GTK2="@comment "
+.endif
-PLIST_FILES= bin/fcitx-config-gtk \
- share/locale/zh_CN/LC_MESSAGES/fcitx-configtool.mo
+.if defined(WITH_GTK3)
+USE_GNOME+= gtk30
+CMAKE_ARGS+= -DENABLE_GTK3=ON
+PLIST_SUB+= GTK3=""
+.else
+PLIST_SUB+= GTK3="@comment "
+.endif
+
+.if defined(WITHOUT_GTK2) && defined(WITHOUT_GTK3)
+IGNORE= a GUI is required
+.endif
+
+PROJECTHOST= fcitx
.include <bsd.port.mk>
diff --git a/chinese/fcitx-configtool/distinfo b/chinese/fcitx-configtool/distinfo
index 514998fc8170..f498c5f72c15 100644
--- a/chinese/fcitx-configtool/distinfo
+++ b/chinese/fcitx-configtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fcitx/fcitx-configtool-0.3.1.tar.bz2) = 60a2596ca3c36d0c98398d36d4eb5f1f03992133a782ae15cb39f66131aeaa3e
-SIZE (fcitx/fcitx-configtool-0.3.1.tar.bz2) = 22323
+SHA256 (fcitx/fcitx-configtool-0.4.0.tar.bz2) = 580a531838c27a1446d1b8ad33d84e44fa729c1b178deff4b9736d316d754640
+SIZE (fcitx/fcitx-configtool-0.4.0.tar.bz2) = 32124
diff --git a/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt b/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
new file mode 100644
index 000000000000..6b48a776937a
--- /dev/null
+++ b/chinese/fcitx-configtool/files/patch-gtk3_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- gtk3/CMakeLists.txt~ 2012-01-30 04:51:25.000000000 -0600
++++ gtk3/CMakeLists.txt 2012-02-06 03:22:50.184481579 -0600
+@@ -45,6 +45,7 @@ target_link_libraries (fcitx-config-gtk3
+ ${FCITX4_FCITX_CONFIG_LIBRARIES}
+ ${FCITX4_FCITX_LIBRARIES}
+ ${GIO2_LIBRARIES}
++ -lintl
+ )
+
+ if (UNIQUE3_FOUND)
diff --git a/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
new file mode 100644
index 000000000000..8da38911f18b
--- /dev/null
+++ b/chinese/fcitx-configtool/files/patch-gtk_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- gtk/CMakeLists.txt~ 2012-01-30 04:51:25.000000000 -0600
++++ gtk/CMakeLists.txt 2012-02-06 03:19:28.808521532 -0600
+@@ -44,6 +44,7 @@ target_link_libraries (fcitx-config-gtk
+ ${FCITX4_FCITX_CONFIG_LIBRARIES}
+ ${FCITX4_FCITX_LIBRARIES}
+ ${GIO2_LIBRARIES}
++ -lintl
+ )
+
+ if (UNIQUE_FOUND)
diff --git a/chinese/fcitx-configtool/pkg-plist b/chinese/fcitx-configtool/pkg-plist
new file mode 100644
index 000000000000..66d82622282c
--- /dev/null
+++ b/chinese/fcitx-configtool/pkg-plist
@@ -0,0 +1,4 @@
+%%GTK2%%bin/fcitx-config-gtk
+%%GTK3%%bin/fcitx-config-gtk3
+share/locale/zh_CN/LC_MESSAGES/fcitx-configtool.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx-configtool.mo