aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-chinese-addons
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 17:58:42 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 17:58:42 +0000
commitf6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d (patch)
tree8091568f2e9424814d1cf7be2d55fda2e6f28aa0 /chinese/fcitx5-chinese-addons
parentbe43f10a6c1f249db56cea11bfa9090305e3f23e (diff)
downloadports-f6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d.tar.gz
ports-f6c8ff5556c080542dc1cb1b0d4c2d2208b7e30d.zip
Add extra languages and schemas supports to Fcitx IME framework
New ports added: - korean/fcitx5-hangul - chinese/libime - textproc/fcitx5-lua - chinese/fcitx5-chinese-addons - chinese/fcitx5-table-extra - chinese/fcitx5-table-other - chinese/libime-jyutping Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27796
Notes
Notes: svn path=/head/; revision=559598
Diffstat (limited to 'chinese/fcitx5-chinese-addons')
-rw-r--r--chinese/fcitx5-chinese-addons/Makefile58
-rw-r--r--chinese/fcitx5-chinese-addons/distinfo7
-rw-r--r--chinese/fcitx5-chinese-addons/pkg-descr4
-rw-r--r--chinese/fcitx5-chinese-addons/pkg-plist126
4 files changed, 195 insertions, 0 deletions
diff --git a/chinese/fcitx5-chinese-addons/Makefile b/chinese/fcitx5-chinese-addons/Makefile
new file mode 100644
index 000000000000..18589ca70e49
--- /dev/null
+++ b/chinese/fcitx5-chinese-addons/Makefile
@@ -0,0 +1,58 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-chinese-addons
+DISTVERSION= 5.0.2
+CATEGORIES= chinese textproc
+MASTER_SITES= https://download.fcitx-im.org/data/:py_stroke,py_table
+DISTFILES= ${PY_STROKE_TAR}:py_stroke \
+ ${PY_TABLE_TAR}:py_table
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Pinyin and table input method support for Fcitx5
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+
+BUILD_DEPENDS= fcitx5-lua>0:textproc/fcitx5-lua
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libfmt.so:devel/libfmt \
+ libopencc.so:chinese/opencc \
+ libboost_iostreams.so:devel/boost-libs \
+ libIMEPinyin.so:chinese/libime \
+ libFcitx5Core.so:textproc/fcitx5
+RUN_DEPENDS= fcitx5-lua>0:textproc/fcitx5-lua
+
+USES= compiler:c++17-lang gettext cmake kde:5 localbase pkgconfig
+
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT= GUI
+
+USE_LDCONFIG= yes
+
+GUI_DESC= Configuration GUI
+GUI_USES= qt:5
+GUI_USE= qt=dbus,concurrent,webkit,buildtools_build,qmake_build
+GUI_LIB_DEPENDS= libFcitx5Qt5DBusAddons.so:textproc/fcitx5-qt
+GUI_CMAKE_ON= -DUSE_WEBKIT:BOOL=true
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+CMAKE_ON= ENABLE_OPENCC
+CMAKE_OFF= ENABLE_TEST
+MAKE_ENV= FCITX5_DOWNLOAD_DISALLOWED=TRUE
+
+PY_STROKE_VER= 20121124
+PY_TABLE_VER= 20121124
+PY_STROKE_TAR= py_stroke-${PY_STROKE_VER}.tar.gz
+PY_TABLE_TAR= py_table-${PY_TABLE_VER}.tar.gz
+
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${PY_STROKE_TAR} ${WRKSRC}/modules/pinyinhelper
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${PY_TABLE_TAR} ${WRKSRC}/modules/pinyinhelper
+
+.include <bsd.port.mk>
diff --git a/chinese/fcitx5-chinese-addons/distinfo b/chinese/fcitx5-chinese-addons/distinfo
new file mode 100644
index 000000000000..f302c2564258
--- /dev/null
+++ b/chinese/fcitx5-chinese-addons/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1608618244
+SHA256 (fcitx5-chinese-addons/py_stroke-20121124.tar.gz) = 8eb128a9bfa43952e67cf2fcee1fd134c6f4cfd317bc2f6c38a615f5eb64e248
+SIZE (fcitx5-chinese-addons/py_stroke-20121124.tar.gz) = 445601
+SHA256 (fcitx5-chinese-addons/py_table-20121124.tar.gz) = 42146ac97de6c13d55f9e99ed873915f4c66739e9c11532a34556badf9792c04
+SIZE (fcitx5-chinese-addons/py_table-20121124.tar.gz) = 186822
+SHA256 (fcitx5-chinese-addons/fcitx-fcitx5-chinese-addons-5.0.2_GH0.tar.gz) = 4b3731fc790d071273fbd91beb76d23166992add060cfd89ecaa55f147036dc6
+SIZE (fcitx5-chinese-addons/fcitx-fcitx5-chinese-addons-5.0.2_GH0.tar.gz) = 259776
diff --git a/chinese/fcitx5-chinese-addons/pkg-descr b/chinese/fcitx5-chinese-addons/pkg-descr
new file mode 100644
index 000000000000..e6471f21a0dc
--- /dev/null
+++ b/chinese/fcitx5-chinese-addons/pkg-descr
@@ -0,0 +1,4 @@
+This provides Pinyin and Table input method support for
+Fcitx5 input method framework.
+
+WWW: https://github.com/fcitx/fcitx5-chinese-addons
diff --git a/chinese/fcitx5-chinese-addons/pkg-plist b/chinese/fcitx5-chinese-addons/pkg-plist
new file mode 100644
index 000000000000..439b940f12c5
--- /dev/null
+++ b/chinese/fcitx5-chinese-addons/pkg-plist
@@ -0,0 +1,126 @@
+bin/scel2org5
+include/Fcitx5/Module/fcitx-module/cloudpinyin/cloudpinyin_public.h
+include/Fcitx5/Module/fcitx-module/pinyinhelper/pinyinhelper_public.h
+include/Fcitx5/Module/fcitx-module/punctuation/punctuation_public.h
+lib/cmake/Fcitx5ModuleCloudPinyin/Fcitx5ModuleCloudPinyinConfig.cmake
+lib/cmake/Fcitx5ModuleCloudPinyin/Fcitx5ModuleCloudPinyinConfigVersion.cmake
+lib/cmake/Fcitx5ModulePinyinHelper/Fcitx5ModulePinyinHelperConfig.cmake
+lib/cmake/Fcitx5ModulePinyinHelper/Fcitx5ModulePinyinHelperConfigVersion.cmake
+lib/cmake/Fcitx5ModulePunctuation/Fcitx5ModulePunctuationConfig.cmake
+lib/cmake/Fcitx5ModulePunctuation/Fcitx5ModulePunctuationConfigVersion.cmake
+lib/fcitx5/chttrans.so
+lib/fcitx5/cloudpinyin.so
+lib/fcitx5/fullwidth.so
+lib/fcitx5/pinyin.so
+lib/fcitx5/pinyinhelper.so
+lib/fcitx5/punctuation.so
+lib/fcitx5/qt5/libpinyindictmanager.so
+lib/fcitx5/table.so
+share/fcitx5/addon/chttrans.conf
+share/fcitx5/addon/cloudpinyin.conf
+share/fcitx5/addon/fullwidth.conf
+share/fcitx5/addon/pinyin.conf
+share/fcitx5/addon/pinyinhelper.conf
+share/fcitx5/addon/punctuation.conf
+share/fcitx5/addon/table.conf
+share/fcitx5/chttrans/gbks2t.tab
+share/fcitx5/inputmethod/cangjie.conf
+share/fcitx5/inputmethod/db.conf
+share/fcitx5/inputmethod/erbi.conf
+share/fcitx5/inputmethod/pinyin.conf
+share/fcitx5/inputmethod/qxm.conf
+share/fcitx5/inputmethod/shuangpin.conf
+share/fcitx5/inputmethod/wanfeng.conf
+share/fcitx5/inputmethod/wbpy.conf
+share/fcitx5/inputmethod/wbx.conf
+share/fcitx5/inputmethod/zrm.conf
+share/fcitx5/lua/imeapi/extensions/pinyin.lua
+share/fcitx5/pinyin/chaizi.dict
+share/fcitx5/pinyin/emoji.dict
+share/fcitx5/pinyinhelper/py_stroke.mb
+share/fcitx5/pinyinhelper/py_table.mb
+share/fcitx5/punctuation/punc.mb.zh_CN
+share/fcitx5/punctuation/punc.mb.zh_HK
+share/fcitx5/punctuation/punc.mb.zh_TW
+share/icons/hicolor/16x16/apps/fcitx-fullwidth-active.png
+share/icons/hicolor/16x16/apps/fcitx-fullwidth-inactive.png
+share/icons/hicolor/16x16/apps/fcitx-punc-active.png
+share/icons/hicolor/16x16/apps/fcitx-punc-inactive.png
+share/icons/hicolor/16x16/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active.png
+share/icons/hicolor/16x16/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive.png
+share/icons/hicolor/16x16/apps/org.fcitx.Fcitx5.fcitx-punc-active.png
+share/icons/hicolor/16x16/apps/org.fcitx.Fcitx5.fcitx-punc-inactive.png
+share/icons/hicolor/22x22/apps/fcitx-fullwidth-active.png
+share/icons/hicolor/22x22/apps/fcitx-fullwidth-inactive.png
+share/icons/hicolor/22x22/apps/fcitx-punc-active.png
+share/icons/hicolor/22x22/apps/fcitx-punc-inactive.png
+share/icons/hicolor/22x22/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active.png
+share/icons/hicolor/22x22/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive.png
+share/icons/hicolor/22x22/apps/org.fcitx.Fcitx5.fcitx-punc-active.png
+share/icons/hicolor/22x22/apps/org.fcitx.Fcitx5.fcitx-punc-inactive.png
+share/icons/hicolor/24x24/apps/fcitx-fullwidth-active.png
+share/icons/hicolor/24x24/apps/fcitx-fullwidth-inactive.png
+share/icons/hicolor/24x24/apps/fcitx-punc-active.png
+share/icons/hicolor/24x24/apps/fcitx-punc-inactive.png
+share/icons/hicolor/24x24/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active.png
+share/icons/hicolor/24x24/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive.png
+share/icons/hicolor/24x24/apps/org.fcitx.Fcitx5.fcitx-punc-active.png
+share/icons/hicolor/24x24/apps/org.fcitx.Fcitx5.fcitx-punc-inactive.png
+share/icons/hicolor/48x48/apps/fcitx-cangjie.png
+share/icons/hicolor/48x48/apps/fcitx-chn.png
+share/icons/hicolor/48x48/apps/fcitx-chttrans-active.png
+share/icons/hicolor/48x48/apps/fcitx-chttrans-inactive.png
+share/icons/hicolor/48x48/apps/fcitx-erbi.png
+share/icons/hicolor/48x48/apps/fcitx-fullwidth-active.png
+share/icons/hicolor/48x48/apps/fcitx-fullwidth-inactive.png
+share/icons/hicolor/48x48/apps/fcitx-pinyin.png
+share/icons/hicolor/48x48/apps/fcitx-punc-active.png
+share/icons/hicolor/48x48/apps/fcitx-punc-inactive.png
+share/icons/hicolor/48x48/apps/fcitx-remind-active.png
+share/icons/hicolor/48x48/apps/fcitx-remind-inactive.png
+share/icons/hicolor/48x48/apps/fcitx-shuangpin.png
+share/icons/hicolor/48x48/apps/fcitx-wbpy.png
+share/icons/hicolor/48x48/apps/fcitx-wubi.png
+share/icons/hicolor/48x48/apps/fcitx-ziranma.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-cangjie.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-chn.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-chttrans-active.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-chttrans-inactive.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-erbi.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-pinyin.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-punc-active.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-punc-inactive.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-remind-active.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-remind-inactive.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-shuangpin.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-wbpy.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-wubi.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-ziranma.png
+share/icons/hicolor/scalable/apps/fcitx-fullwidth-active-symbolic.svg
+share/icons/hicolor/scalable/apps/fcitx-fullwidth-active.svg
+share/icons/hicolor/scalable/apps/fcitx-fullwidth-inactive-symbolic.svg
+share/icons/hicolor/scalable/apps/fcitx-fullwidth-inactive.svg
+share/icons/hicolor/scalable/apps/fcitx-punc-active-symbolic.svg
+share/icons/hicolor/scalable/apps/fcitx-punc-active.svg
+share/icons/hicolor/scalable/apps/fcitx-punc-inactive-symbolic.svg
+share/icons/hicolor/scalable/apps/fcitx-punc-inactive.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active-symbolic.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-fullwidth-active.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive-symbolic.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-fullwidth-inactive.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-punc-active-symbolic.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-punc-active.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-punc-inactive-symbolic.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-punc-inactive.svg
+share/locale/ca/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/da/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/de/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/he/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/ja/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/ko/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/ru/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/zh_CN/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx5-chinese-addons.mo
+share/metainfo/org.fcitx.Fcitx5.Addon.ChineseAddons.metainfo.xml