aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-rime
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
commit784693f56c9c8899036fc4aa340be19676b514c8 (patch)
tree57d3ceb2bb056eb915f7f25ff148aea78c8807cb /chinese/fcitx5-rime
parent0109871be7f4defa811d2e308db09de0ee44b2c5 (diff)
downloadports-784693f56c9c8899036fc4aa340be19676b514c8.tar.gz
ports-784693f56c9c8899036fc4aa340be19676b514c8.zip
Add Fcitx5 IME framework and related ports
The Fcitx5 IME framework is the future version of the legacy Fcitx IME framework. Main parts of Fcitx5: - x11/xcb-imdkit - textproc/fcitx5 Application supports libraries of Fcitx5: - textproc/fcitx5-qt - textproc/fcitx5-gtk GUI configuration tool of Fcitx5: - textproc/fcitx5-configtool IME addons for Fcitx5: - chinese/fcitx5-rime - japanese/fcitx5-anthy textproc/fcitx5 and chinese/fcitx cannot be installed at the same time right now, due to development environment and runtime conflicts users could possibly run into. Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27667
Notes
Notes: svn path=/head/; revision=559587
Diffstat (limited to 'chinese/fcitx5-rime')
-rw-r--r--chinese/fcitx5-rime/Makefile33
-rw-r--r--chinese/fcitx5-rime/distinfo3
-rw-r--r--chinese/fcitx5-rime/pkg-descr3
-rw-r--r--chinese/fcitx5-rime/pkg-plist39
4 files changed, 78 insertions, 0 deletions
diff --git a/chinese/fcitx5-rime/Makefile b/chinese/fcitx5-rime/Makefile
new file mode 100644
index 000000000000..3e6638031214
--- /dev/null
+++ b/chinese/fcitx5-rime/Makefile
@@ -0,0 +1,33 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-rime
+DISTVERSION= 5.0.2
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= RIME support for Fcitx5
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+
+BUILD_DEPENDS= ${_SCHEMA_DEPENDS}
+LIB_DEPENDS= librime.so:chinese/librime \
+ libFcitx5Core.so:textproc/fcitx5
+RUN_DEPENDS= ${_SCHEMA_DEPENDS}
+
+USES= compiler:c++17-lang gettext-tools cmake kde:5 localbase \
+ pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+_SCHEMA_DEPENDS= \
+ ${LOCALBASE}/share/rime-data/luna_pinyin.schema.yaml:chinese/rime-luna-pinyin \
+ ${LOCALBASE}/share/rime-data/bopomofo.schema.yaml:chinese/rime-bopomofo \
+ ${LOCALBASE}/share/rime-data/cangjie5.schema.yaml:chinese/rime-cangjie \
+ ${LOCALBASE}/share/rime-data/stroke.schema.yaml:chinese/rime-stroke
+
+.include <bsd.port.mk>
diff --git a/chinese/fcitx5-rime/distinfo b/chinese/fcitx5-rime/distinfo
new file mode 100644
index 000000000000..e03627216e49
--- /dev/null
+++ b/chinese/fcitx5-rime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608288386
+SHA256 (fcitx-fcitx5-rime-5.0.2_GH0.tar.gz) = d3c2663c483a04fc5fbb0490a0de53220903314faa642d0c921815e8a1c28094
+SIZE (fcitx-fcitx5-rime-5.0.2_GH0.tar.gz) = 45722
diff --git a/chinese/fcitx5-rime/pkg-descr b/chinese/fcitx5-rime/pkg-descr
new file mode 100644
index 000000000000..9ba9db9600f0
--- /dev/null
+++ b/chinese/fcitx5-rime/pkg-descr
@@ -0,0 +1,3 @@
+RIME support for Fcitx5 input method framework.
+
+WWW: https://github.com/fcitx/fcitx5-rime
diff --git a/chinese/fcitx5-rime/pkg-plist b/chinese/fcitx5-rime/pkg-plist
new file mode 100644
index 000000000000..8cc9936f9036
--- /dev/null
+++ b/chinese/fcitx5-rime/pkg-plist
@@ -0,0 +1,39 @@
+lib/fcitx5/rime.so
+share/fcitx5/addon/rime.conf
+share/fcitx5/inputmethod/rime.conf
+share/icons/hicolor/48x48/apps/fcitx-rime-deploy.png
+share/icons/hicolor/48x48/apps/fcitx-rime-disable.png
+share/icons/hicolor/48x48/apps/fcitx-rime-im.png
+share/icons/hicolor/48x48/apps/fcitx-rime-latin.png
+share/icons/hicolor/48x48/apps/fcitx-rime-sync.png
+share/icons/hicolor/48x48/apps/fcitx-rime.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime-deploy.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime-disable.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime-im.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime-latin.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime-sync.png
+share/icons/hicolor/48x48/apps/org.fcitx.Fcitx5.fcitx-rime.png
+share/icons/hicolor/scalable/apps/fcitx-rime-deploy.svg
+share/icons/hicolor/scalable/apps/fcitx-rime-disable.svg
+share/icons/hicolor/scalable/apps/fcitx-rime-im.svg
+share/icons/hicolor/scalable/apps/fcitx-rime-latin.svg
+share/icons/hicolor/scalable/apps/fcitx-rime-sync.svg
+share/icons/hicolor/scalable/apps/fcitx-rime.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime-deploy.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime-disable.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime-im.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime-latin.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime-sync.svg
+share/icons/hicolor/scalable/apps/org.fcitx.Fcitx5.fcitx-rime.svg
+share/locale/ca/LC_MESSAGES/fcitx5-rime.mo
+share/locale/da/LC_MESSAGES/fcitx5-rime.mo
+share/locale/de/LC_MESSAGES/fcitx5-rime.mo
+share/locale/he/LC_MESSAGES/fcitx5-rime.mo
+share/locale/ja/LC_MESSAGES/fcitx5-rime.mo
+share/locale/ko/LC_MESSAGES/fcitx5-rime.mo
+share/locale/ru/LC_MESSAGES/fcitx5-rime.mo
+share/locale/tr/LC_MESSAGES/fcitx5-rime.mo
+share/locale/vi/LC_MESSAGES/fcitx5-rime.mo
+share/locale/zh_CN/LC_MESSAGES/fcitx5-rime.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx5-rime.mo
+share/metainfo/org.fcitx.Fcitx5.Addon.Rime.metainfo.xml