aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /chinese/fcitx
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Notes
Notes: svn path=/head/; revision=426118
Diffstat (limited to 'chinese/fcitx')
-rw-r--r--chinese/fcitx/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index cb64281d3535..60604707f707 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -21,8 +21,7 @@ COMMENT= Flexible Input Method Framework
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
- ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
LIB_DEPENDS= libcairo.so:graphics/cairo \
libdbus-1.so:devel/dbus \
libXfixes.so:x11/libXfixes \
@@ -37,11 +36,12 @@ SUB_LIST+= PORTSDIR=${PORTSDIR}
CONFLICTS= zh-scim-fcitx-3.*
USE_GNOME= pango intltool libxml2 introspection
+USE_KDE= ecm
USE_XORG= x11 xext xkbfile sm ice
USE_LDCONFIG= yes
USES= tar:xz cmake desktop-file-utils execinfo \
gettext-tools:build,run gettext-runtime iconv:wchar_t \
- pkgconfig shared-mime-info
+ kde:5 pkgconfig shared-mime-info
INSTALLS_ICONS= yes
OPTIONS_DEFINE= GTK2 GTK3 QT4 OPENCC TPUNC DOCS