aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 05:18:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 05:18:26 +0000
commitbeaf13fa4eb66c4665f51279a0923d3e35ea82fd (patch)
tree60e5a28d07259a771689f7c1597adba37d793329 /chinese/fcitx
parent86c8f35be264b053a13d27dd12406451f3c34b8f (diff)
downloadports-beaf13fa4eb66c4665f51279a0923d3e35ea82fd.tar.gz
ports-beaf13fa4eb66c4665f51279a0923d3e35ea82fd.zip
Notes
Diffstat (limited to 'chinese/fcitx')
-rw-r--r--chinese/fcitx/Makefile71
-rw-r--r--chinese/fcitx/distinfo4
-rw-r--r--chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c24
-rw-r--r--chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.h11
-rw-r--r--chinese/fcitx/files/nodocs-doc_CMakeLists.txt13
-rw-r--r--chinese/fcitx/files/patch-CMakeLists.txt11
-rw-r--r--chinese/fcitx/files/patch-configure33
-rw-r--r--chinese/fcitx/files/patch-data-Makefile.in20
-rw-r--r--chinese/fcitx/files/patch-data-table-Makefile.in20
-rw-r--r--chinese/fcitx/files/patch-data_CMakeLists.txt10
-rw-r--r--chinese/fcitx/files/patch-data_script_fcitx-configtool15
-rw-r--r--chinese/fcitx/files/patch-doc_man_CMakeLists.txt9
-rw-r--r--chinese/fcitx/files/patch-png-Makefile.in11
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt22
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt22
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt22
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx_instance-internal.h11
-rw-r--r--chinese/fcitx/pkg-descr2
-rw-r--r--chinese/fcitx/pkg-message15
-rw-r--r--chinese/fcitx/pkg-plist273
20 files changed, 399 insertions, 220 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index c3bdb186630a..1c900a26c778 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -6,56 +6,75 @@
#
PORTNAME= fcitx
-PORTVERSION= 4.0.0
+PORTVERSION= 4.1.2
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pinyin.tar.gz table.tar.gz
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= darcsis@gmail.com
COMMENT= A simple and fast GBK Chinese XIM server
+LICENSE= GPLv2
+
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-LICENSE= GPLv2
+MAN1= createPYMB.1 fcitx-remote.1 fcitx.1 mb2org.1 mb2txt.1 \
+ readPYBase.1 readPYMB.1 scel2org.1 txt2mb.1
+USE_BZIP2= yes
USE_GNOME= pango intltool gnomehack
-USE_XORG= xpm x11 xtst
+USE_GETTEXT= yes
+USE_XORG= x11 xext
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_CMAKE= yes
+INSTALLS_ICONS= yes
-OPTIONS= XFT "Use Xft for Freetype font support" on \
- TRAY "Enable system tray support" on \
- DBUS "Enable D-Bus for KIMPanel support" off \
- RECORDING "Enable recording of user input" off \
- DEBUG "Build with debug information" off
+OPTIONS= GTK2 "Enable Gtk2 IM module" off \
+ GTK3 "Enable Gtk3 IM module" off \
+ QT4 "Enable Qt4 IM module" off \
+ DBUS "Enable D-Bus for KIMPanel support" off
.include <bsd.port.options.mk>
-.if defined(WITH_XFT)
-USE_XORG+= xft
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
.else
-CONFIGURE_ARGS+= --disable-xft
+CMAKE_ARGS+= -DENABLE_GTK2_IM_MODULE=OFF
+.endif
+
+.if defined(WITH_GTK3)
+USE_GNOME+= gtk30
+CMAKE_ARGS+= -DENABLE_GTK3_IM_MODULE=ON
.endif
-.if defined(WITHOUT_TRAY)
-CONFIGURE_ARGS+= --disable-tray
+.if defined(WITH_QT4)
+USE_QT= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui
+CMAKE_ARGS+= -DENABLE_QT_IM_MODULE=ON
.endif
.if defined(WITH_DBUS)
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+PLIST_SUB+= DBUS=""
.else
-CONFIGURE_ARGS+= --disable-dbus
+CMAKE_ARGS+= -DENABLE_DBUS=OFF
+PLIST_SUB+= DBUS="@comment "
.endif
-.if defined(WITH_RECORDING)
-CONFIGURE_ARGS+= --enable-recording
+.if defined(WITH_DEBUG)
+CMAKE_ARGS+= -DENABLE_DEBUG=ON
.endif
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
+.if defined(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/nodocs-doc_CMakeLists.txt
+.endif
+
+.if defined(NOPORTDATA)
+IGNORE= code tables are required, undefine NOPORTDATA
.endif
post-patch:
@@ -63,16 +82,10 @@ post-patch:
@${CP} ${_DISTDIR}/table.tar.gz ${WRKSRC}/data/table
.if ${OSVERSION} < 800067
# getline() is GNU extension which FreeBSD only recently adopted
- @${REINPLACE_CMD} -E \
- 's:getline\(&(.+, )&(.+, .+\) != )-1:fgets(\1\2NULL:' \
- ${WRKSRC}/src/fcitx-config/fcitx-config.c \
- ${WRKSRC}/src/im/special/QuickPhrase.c \
- ${WRKSRC}/src/tools/tools.c
+EXTRA_PATCHES+= ${FILESDIR}/getline-src_lib_fcitx-utils_utils.c \
+ ${FILESDIR}/getline-src_lib_fcitx-utils_utils.h
.endif
-pre-install:
- @${CHMOD} +x ${WRKSRC}/install-sh
-
post-install:
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/chinese/fcitx/distinfo b/chinese/fcitx/distinfo
index f2dd8af22f80..403ed8c250de 100644
--- a/chinese/fcitx/distinfo
+++ b/chinese/fcitx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (fcitx/fcitx-4.0.0.tar.gz) = 750884e992f51d8557447dc02fe6ada9758392611fc3271849ed26eba33f2d1c
-SIZE (fcitx/fcitx-4.0.0.tar.gz) = 1357079
+SHA256 (fcitx/fcitx-4.1.2.tar.bz2) = cf61355fcd8457df9bac7c1f88dff6781eeba5f9466905c2d8d3b872133c99ae
+SIZE (fcitx/fcitx-4.1.2.tar.bz2) = 764998
SHA256 (fcitx/pinyin.tar.gz) = bf8c581450f9fac0eab0498927d1d5e5c1cd465ed9937e4d9362ca9d67920fa4
SIZE (fcitx/pinyin.tar.gz) = 1613447
SHA256 (fcitx/table.tar.gz) = 6196053c724125e3ae3d8bd6b2f9172d0c83b65b0d410d3cde63b7a8d6ab87b7
diff --git a/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c
new file mode 100644
index 000000000000..8002d5242e70
--- /dev/null
+++ b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c
@@ -0,0 +1,24 @@
+--- ./src/lib/fcitx-utils/utils.c.orig 2011-10-02 05:43:11.000000000 -0500
++++ ./src/lib/fcitx-utils/utils.c 2011-11-09 21:15:42.497306506 -0600
+@@ -249,4 +249,21 @@ char* fcitx_get_process_name()
+ #endif
+ }
+
++ssize_t getline(char ** p, size_t * cap, FILE * fp) {
++ ssize_t l;
++ if (!*cap && (*p = malloc(128))) *cap = 128;
++ else if (!*p) return -1;
++ fgets(*p, *cap, fp);
++ l = strlen(*p);
++ while (!feof(fp) && (*p)[l - 1] != '\n') {
++ if (!(*p = realloc(*p, *cap *= 2))) {
++ *cap = 0;
++ return -1;
++ }
++ fgets(*p + l, *cap / 2, fp);
++ l += strlen(*p + l);
++ }
++ return feof(fp) ? -1 : l;
++}
++
+ // kate: indent-mode cstyle; space-indent on; indent-width 0;
diff --git a/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.h b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.h
new file mode 100644
index 000000000000..7275ae7a08b5
--- /dev/null
+++ b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.h
@@ -0,0 +1,11 @@
+--- ./src/lib/fcitx-utils/utils.h~ 2011-10-02 05:43:11.000000000 -0500
++++ ./src/lib/fcitx-utils/utils.h 2011-11-09 14:43:09.006406004 -0600
+@@ -120,6 +120,8 @@ extern "C" {
+
+ char* fcitx_get_process_name();
+
++ ssize_t getline(char ** linep, size_t * linecapp, FILE * stream);
++
+ #ifdef __cplusplus
+ }
+ #endif
diff --git a/chinese/fcitx/files/nodocs-doc_CMakeLists.txt b/chinese/fcitx/files/nodocs-doc_CMakeLists.txt
new file mode 100644
index 000000000000..9a6b1a9123ed
--- /dev/null
+++ b/chinese/fcitx/files/nodocs-doc_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- doc/CMakeLists.txt~ 2011-10-02 05:43:11.000000000 -0500
++++ doc/CMakeLists.txt 2011-11-09 05:47:39.686199652 -0600
+@@ -1,9 +1,7 @@
+ add_subdirectory(man)
+-add_subdirectory(examples)
+
+ set(FCITX_DOC_FILES
+ cjkvinput.txt wb_fh.htm pinyin.txt
+ Develop_Readme API.txt
+ )
+
+-install(FILES ${FCITX_DOC_FILES} DESTINATION share/doc/${package} )
+\ No newline at end of file
diff --git a/chinese/fcitx/files/patch-CMakeLists.txt b/chinese/fcitx/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e1dc7fdab463
--- /dev/null
+++ b/chinese/fcitx/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt~ 2011-10-02 05:43:11.000000000 -0500
++++ CMakeLists.txt 2011-11-09 07:51:31.801020675 -0600
+@@ -93,7 +93,7 @@ if (ENABLE_OPENCC)
+ endif (ENABLE_OPENCC)
+
+ if(ENABLE_DEBUG)
+- set(_DEBUG)
++ set(_DEBUG ON)
+ endif(ENABLE_DEBUG)
+
+ set(package fcitx)
diff --git a/chinese/fcitx/files/patch-configure b/chinese/fcitx/files/patch-configure
deleted file mode 100644
index ab2350fbfc13..000000000000
--- a/chinese/fcitx/files/patch-configure
+++ /dev/null
@@ -1,33 +0,0 @@
---- configure.orig 2010-11-17 16:45:30.000000000 +0100
-+++ configure 2010-11-29 19:17:00.000000000 +0100
-@@ -12635,7 +12635,7 @@
- case "$host" in
- *-*-*freebsd*)
- HOST_LIBS="-lexecinfo -pthread"
-- md5prog=gmd5sum
-+ md5prog=md5
- ;;
- *-*-linux*)
- HOST_LIBS="-ldl -lpthread"
-@@ -12691,11 +12691,6 @@
- done
- test -n "$WGET" || WGET="no"
-
--if test "x$WGET" = "xno";
--then
-- as_fn_error $? "You need to install wget" "$LINENO" 5
--fi
--
- for ac_prog in tar
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
-@@ -14550,6 +14545,9 @@
- fi
-
- ;;
-+ *-*-*freebsd*)
-+ DATADIRNAME=share
-+ ;;
- *)
- DATADIRNAME=lib
- ;;
diff --git a/chinese/fcitx/files/patch-data-Makefile.in b/chinese/fcitx/files/patch-data-Makefile.in
deleted file mode 100644
index dfa3c7235762..000000000000
--- a/chinese/fcitx/files/patch-data-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- data/Makefile.in.orig 2010-11-27 20:20:50.990507459 +0800
-+++ data/Makefile.in 2010-11-27 20:21:11.099145804 +0800
-@@ -702,16 +702,9 @@
- tools:
- $(MAKE) -C ../tools
-
--$(pyorg_data): $(py_tar) md5check
-+$(pyorg_data):
- cd $(srcdir) && $(TAR) xzvf $(py_tar)
-
--$(py_tar):
-- $(WGET) -O $(py_tar) $(py_url)
-- $(WGET) -O $(py_tar).md5 $(py_url).md5
--
--md5check: $(py_tar)
-- cd $(srcdir) && $(MD5SUM) -c $(py_tar).md5 || ( $(RM) $(py_tar); exit 1 )
--
- all-local: tools $(py_data)
- rm -f pyERROR
- rm -f pyPhrase.ok
diff --git a/chinese/fcitx/files/patch-data-table-Makefile.in b/chinese/fcitx/files/patch-data-table-Makefile.in
deleted file mode 100644
index 4d06dd8a4cad..000000000000
--- a/chinese/fcitx/files/patch-data-table-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- data/table/Makefile.in.orig 2010-11-27 19:49:38.241629454 +0800
-+++ data/table/Makefile.in 2010-11-27 19:50:12.259003812 +0800
-@@ -487,16 +487,9 @@
-
- $(txt_m_data): cj.txt ;
-
--cj.txt: $(table_tar) md5check
-+cj.txt:
- $(TAR) xzvf $(table_tar)
-
--$(table_tar):
-- $(WGET) -O $(table_tar) $(table_url)
-- $(WGET) -O $(table_tar).md5 $(table_url).md5
--
--md5check: $(table_tar)
-- cd $(srcdir) && $(MD5SUM) -c $(table_tar).md5 || ( $(RM) $(table_tar); exit 1)
--
- all-local: tools $(txt_data) $(mb_data)
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/chinese/fcitx/files/patch-data_CMakeLists.txt b/chinese/fcitx/files/patch-data_CMakeLists.txt
new file mode 100644
index 000000000000..8ed9375ad511
--- /dev/null
+++ b/chinese/fcitx/files/patch-data_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- data/CMakeLists.txt~ 2011-10-02 05:43:11.000000000 -0500
++++ data/CMakeLists.txt 2011-11-09 04:34:25.659393502 -0600
+@@ -43,7 +43,6 @@ intltool_merge_translation(${CMAKE_CURRE
+ add_custom_target(pinyin_data ALL DEPENDS ${PY_DATA})
+
+ add_custom_command(OUTPUT ${PY_ORGDATA}
+- COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/download.sh "${WGET}" "${PY_URL}" "${PY_TAR}"
+ COMMAND ${TAR} xzmvf ${PY_TAR})
+ add_custom_command(OUTPUT ${PY_DATA}
+ DEPENDS ${PY_ORGDATA}
diff --git a/chinese/fcitx/files/patch-data_script_fcitx-configtool b/chinese/fcitx/files/patch-data_script_fcitx-configtool
new file mode 100644
index 000000000000..f805c706eb11
--- /dev/null
+++ b/chinese/fcitx/files/patch-data_script_fcitx-configtool
@@ -0,0 +1,15 @@
+--- ./data/script/fcitx-configtool~ 2011-10-02 05:43:11.000000000 -0500
++++ ./data/script/fcitx-configtool 2011-11-09 21:18:23.600500583 -0600
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #--------------------------------------
+ # fcitx-config
+ #
+@@ -61,4 +61,4 @@ case "$DE" in
+ *)
+ run_gtk
+ ;;
+-esac
+\ No newline at end of file
++esac
diff --git a/chinese/fcitx/files/patch-doc_man_CMakeLists.txt b/chinese/fcitx/files/patch-doc_man_CMakeLists.txt
new file mode 100644
index 000000000000..bdb4c8cd8b09
--- /dev/null
+++ b/chinese/fcitx/files/patch-doc_man_CMakeLists.txt
@@ -0,0 +1,9 @@
+--- doc/man/CMakeLists.txt~ 2011-10-02 05:43:11.000000000 -0500
++++ doc/man/CMakeLists.txt 2011-11-09 05:30:55.468797225 -0600
+@@ -2,4 +2,4 @@ set(FCITX_MANS
+ fcitx.1 createPYMB.1 readPYBase.1 readPYMB.1 mb2org.1 scel2org.1 mb2txt.1 txt2mb.1 fcitx-remote.1
+ )
+
+-install(FILES ${FCITX_MANS} DESTINATION share/man/man1)
+\ No newline at end of file
++install(FILES ${FCITX_MANS} DESTINATION man/man1)
diff --git a/chinese/fcitx/files/patch-png-Makefile.in b/chinese/fcitx/files/patch-png-Makefile.in
deleted file mode 100644
index 3453f7557557..000000000000
--- a/chinese/fcitx/files/patch-png-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- png/Makefile.in.orig 2010-11-27 21:49:04.591697974 +0800
-+++ png/Makefile.in 2010-11-27 21:50:06.021645318 +0800
-@@ -228,7 +228,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--pngdir = $(datadir)/pixmaps
-+pngdir = $(datadir)/pixmaps/@PACKAGE@
- png_DATA = \
- fcitx.png \
- fcitx-cangjie.png \
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
new file mode 100644
index 000000000000..c03db3d89338
--- /dev/null
+++ b/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/lib/fcitx-config/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
++++ src/lib/fcitx-config/CMakeLists.txt 2011-11-09 23:47:47.999482381 -0600
+@@ -14,8 +14,8 @@ set(FCITX_CONFIG_HEADERS
+ add_library(fcitx-config SHARED ${FCITX_CONFIG_SOURCES})
+ target_link_libraries(fcitx-config fcitx-utils)
+ set_target_properties(fcitx-config
+- PROPERTIES VERSION 4.1.0
+- SOVERSION 4.1
++ PROPERTIES VERSION 4.1
++ SOVERSION 4
+ COMPILE_FLAGS "-fvisibility=hidden"
+ LINK_FLAGS "-Wl,--no-undefined"
+ )
+@@ -23,7 +23,7 @@ set_target_properties(fcitx-config
+ configure_file(fcitx-config.pc.in ${CMAKE_CURRENT_BINARY_DIR}/fcitx-config.pc)
+
+ install(TARGETS fcitx-config DESTINATION ${libdir})
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx-config.pc DESTINATION "${libdir}/pkgconfig")
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx-config.pc DESTINATION "libdata/pkgconfig")
+ install(FILES ${FCITX_CONFIG_HEADERS} DESTINATION "${includedir}/fcitx-config")
+
+ if (ENABLE_STATIC)
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
new file mode 100644
index 000000000000..824c74001d86
--- /dev/null
+++ b/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/lib/fcitx-utils/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
++++ src/lib/fcitx-utils/CMakeLists.txt 2011-11-09 23:48:04.469816075 -0600
+@@ -20,8 +20,8 @@ endif (LIBKVM_FOUND)
+
+ add_library(fcitx-utils SHARED ${FCITX_UTILS_SOURCES})
+ set_target_properties(fcitx-utils
+- PROPERTIES VERSION 0.1.0
+- SOVERSION 0.1
++ PROPERTIES VERSION 0.1
++ SOVERSION 0
+ COMPILE_FLAGS "-fvisibility=hidden"
+ LINK_FLAGS "-Wl,--no-undefined"
+ )
+@@ -34,7 +34,7 @@ endif (LIBKVM_FOUND)
+ configure_file(fcitx-utils.pc.in ${CMAKE_CURRENT_BINARY_DIR}/fcitx-utils.pc)
+
+ install(TARGETS fcitx-utils LIBRARY DESTINATION "${libdir}")
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx-utils.pc DESTINATION "${libdir}/pkgconfig")
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx-utils.pc DESTINATION "libdata/pkgconfig")
+ install(FILES ${FCITX_UTILS_HEADERS} DESTINATION "${includedir}/fcitx-utils")
+
+ if (ENABLE_STATIC)
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
new file mode 100644
index 000000000000..cd565a7955cd
--- /dev/null
+++ b/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/lib/fcitx/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
++++ src/lib/fcitx/CMakeLists.txt 2011-11-09 23:45:35.930811384 -0600
+@@ -31,8 +31,8 @@ link_directories(${DL_LIBRARY_DIRS} ${PT
+
+ add_library(fcitx-core SHARED ${LIBFCITX_SOURCES})
+ set_target_properties(fcitx-core
+- PROPERTIES VERSION 0.2.0
+- SOVERSION 0.2
++ PROPERTIES VERSION 0.2
++ SOVERSION 0
+ COMPILE_FLAGS "-fvisibility=hidden"
+ LINK_FLAGS "-Wl,--no-undefined"
+ )
+@@ -41,7 +41,7 @@ configure_file(fcitx.pc.in ${CMAKE_CURRE
+
+ target_link_libraries(fcitx-core fcitx-config fcitx-utils ${DL_LIBRARIES} ${PTHREAD_LIBRARIES})
+ install(TARGETS fcitx-core LIBRARY DESTINATION "${libdir}")
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx.pc DESTINATION "${libdir}/pkgconfig")
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/fcitx.pc DESTINATION "libdata/pkgconfig")
+ install(FILES ${FCITX_HEADERS} DESTINATION "${includedir}/fcitx")
+
+ if (ENABLE_STATIC)
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx_instance-internal.h b/chinese/fcitx/files/patch-src_lib_fcitx_instance-internal.h
new file mode 100644
index 000000000000..0955b8e45043
--- /dev/null
+++ b/chinese/fcitx/files/patch-src_lib_fcitx_instance-internal.h
@@ -0,0 +1,11 @@
+--- src/lib/fcitx/instance-internal.h~ 2011-10-02 05:43:11.000000000 -0500
++++ src/lib/fcitx/instance-internal.h 2011-11-09 04:34:08.305040197 -0600
+@@ -26,6 +26,8 @@
+ #define _FCITX_INSTANCE_INTERNAL_H_
+
+ #include <semaphore.h>
++#include <sys/select.h>
++#include <pthread.h>
+
+ #include "fcitx-utils/utarray.h"
+ #include "configfile.h"
diff --git a/chinese/fcitx/pkg-descr b/chinese/fcitx/pkg-descr
index 02d7c4958865..0deaca11a74d 100644
--- a/chinese/fcitx/pkg-descr
+++ b/chinese/fcitx/pkg-descr
@@ -4,4 +4,4 @@ To be more precise, it is a collection of Simplified Chinese input methods
based on XIM (X Input Method), including WuBi, PinYin, and QuWei, and is
distributed under GPL. It is the descendent of gWuBi.
-WWW: http://www.fcitx.org/
+WWW: http://code.google.com/p/fcitx/
diff --git a/chinese/fcitx/pkg-message b/chinese/fcitx/pkg-message
index 873dff8d106e..cb407f49e9ed 100644
--- a/chinese/fcitx/pkg-message
+++ b/chinese/fcitx/pkg-message
@@ -12,18 +12,7 @@ Additionally, for GTK/Qt programs, you must also set:
sh/bash: export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim
-Xterm users should also add ``XTerm.VT100.inputMethod:fcitx'' or similar
-line to their ~/.Xdefaults file.
-
-For the first time use, run the program with -c switch to create default
-configuration file (~/.config/fcitx/config).
-
-For users migrating from 3.x to 4.0, just copy existing configuration to
-the new location:
-
- mv ~/.fcitx ~/.config/fcitx
-
-If there are any problems starting up, remove the old configuration file
-(optionally) and create a new one by running ``fcitx -c'' again.
+You can replace the `xim` above with `fcitx` if you built fcitx with
+the corresponding IM module.
************************************************************************
diff --git a/chinese/fcitx/pkg-plist b/chinese/fcitx/pkg-plist
index 122a6968ec2d..80983f2eddab 100644
--- a/chinese/fcitx/pkg-plist
+++ b/chinese/fcitx/pkg-plist
@@ -1,109 +1,143 @@
bin/createPYMB
bin/fcitx
-bin/fcitx-config
+bin/fcitx-configtool
bin/fcitx-remote
+bin/fcitx-skin-installer
+bin/fcitx4-config
bin/mb2org
bin/mb2txt
bin/readPYBase
bin/readPYMB
bin/scel2org
bin/txt2mb
-include/fcitx-config/configfile.h
include/fcitx-config/fcitx-config.h
include/fcitx-config/hotkey.h
-include/fcitx-config/profile.h
include/fcitx-config/xdg.h
-include/fcitx/im.h
-lib/libfcitx-config.a
-lib/libfcitx-config.la
+include/fcitx-utils/log.h
+include/fcitx-utils/utarray.h
+include/fcitx-utils/utf8.h
+include/fcitx-utils/uthash.h
+include/fcitx-utils/utils.h
+include/fcitx/addon.h
+include/fcitx/candidate.h
+include/fcitx/configfile.h
+include/fcitx/fcitx.h
+include/fcitx/frontend.h
+include/fcitx/hook.h
+include/fcitx/ime.h
+include/fcitx/instance.h
+include/fcitx/keys.h
+include/fcitx/module.h
+include/fcitx/module/classicui/classicuiinterface.h
+%%DBUS%%include/fcitx/module/dbus/dbusstuff.h
+%%DBUS%%include/fcitx/module/ipc/ipc.h
+include/fcitx/module/pinyin/pydef.h
+include/fcitx/module/punc/punc.h
+include/fcitx/module/x11/x11stuff.h
+include/fcitx/profile.h
+include/fcitx/ui.h
+lib/fcitx/fcitx-autoeng.so
+lib/fcitx/fcitx-chttrans.so
+lib/fcitx/fcitx-classic-ui.so
+%%DBUS%%lib/fcitx/fcitx-dbus.so
+lib/fcitx/fcitx-fullwidth-char.so
+%%DBUS%%lib/fcitx/fcitx-ipc.so
+%%DBUS%%lib/fcitx/fcitx-kimpanel-ui.so
+lib/fcitx/fcitx-pinyin.so
+lib/fcitx/fcitx-punc.so
+lib/fcitx/fcitx-quickphrase.so
+lib/fcitx/fcitx-qw.so
+lib/fcitx/fcitx-remote-module.so
+lib/fcitx/fcitx-table.so
+lib/fcitx/fcitx-vk.so
+lib/fcitx/fcitx-x11.so
+lib/fcitx/fcitx-xim.so
lib/libfcitx-config.so
lib/libfcitx-config.so.4
+lib/libfcitx-config.so.4.1
+lib/libfcitx-core.so
+lib/libfcitx-core.so.0
+lib/libfcitx-core.so.0.2
+lib/libfcitx-utils.so
+lib/libfcitx-utils.so.0
+lib/libfcitx-utils.so.0.1
libdata/pkgconfig/fcitx-config.pc
+libdata/pkgconfig/fcitx-utils.pc
libdata/pkgconfig/fcitx.pc
-share/locale/zh_CN/LC_MESSAGES/fcitx.mo
-share/pixmaps/fcitx/fcitx-cangjie.png
-share/pixmaps/fcitx/fcitx-chn.png
-share/pixmaps/fcitx/fcitx-eng.png
-share/pixmaps/fcitx/fcitx-erbi.png
-share/pixmaps/fcitx/fcitx-full-letter.png
-share/pixmaps/fcitx/fcitx-full-punct.png
-share/pixmaps/fcitx/fcitx-half-letter.png
-share/pixmaps/fcitx/fcitx-half-punct.png
-share/pixmaps/fcitx/fcitx-legend.png
-share/pixmaps/fcitx/fcitx-nolegend.png
-share/pixmaps/fcitx/fcitx-pinyin.png
-share/pixmaps/fcitx/fcitx-simp.png
-share/pixmaps/fcitx/fcitx-trad.png
-share/pixmaps/fcitx/fcitx-vkoff.png
-share/pixmaps/fcitx/fcitx-vkon.png
-share/pixmaps/fcitx/fcitx-wubi.png
-share/pixmaps/fcitx/fcitx-ziranma.png
-share/pixmaps/fcitx/fcitx.png
+share/applications/fcitx-configtool.desktop
+%%DBUS%%share/applications/fcitx-kimpanel.desktop
+share/applications/fcitx-skin-installer.desktop
+share/applications/fcitx.desktop
+share/cmake/fcitx/FcitxConfig.cmake
+share/cmake/fcitx/FcitxConfigVersion.cmake
+share/cmake/fcitx/FcitxMacro.cmake
+%%PORTDOCS%%%%DOCSDIR%%/API.txt
+%%PORTDOCS%%%%DOCSDIR%%/Develop_Readme
+%%PORTDOCS%%%%DOCSDIR%%/cjkvinput.txt
+%%PORTDOCS%%%%DOCSDIR%%/disable-table.conf.template
+%%PORTDOCS%%%%DOCSDIR%%/pinyin.txt
+%%PORTDOCS%%%%DOCSDIR%%/wb_fh.htm
+%%DATADIR%%/addon/fcitx-autoeng.conf
+%%DATADIR%%/addon/fcitx-chttrans.conf
+%%DATADIR%%/addon/fcitx-classic-ui.conf
+%%DBUS%%%%DATADIR%%/addon/fcitx-dbus.conf
+%%DATADIR%%/addon/fcitx-fullwidth-char.conf
+%%DBUS%%%%DATADIR%%/addon/fcitx-ipc.conf
+%%DBUS%%%%DATADIR%%/addon/fcitx-kimpanel-ui.conf
+%%DATADIR%%/addon/fcitx-pinyin.conf
+%%DATADIR%%/addon/fcitx-punc.conf
+%%DATADIR%%/addon/fcitx-quickphrase.conf
+%%DATADIR%%/addon/fcitx-qw.conf
+%%DATADIR%%/addon/fcitx-remote-module.conf
+%%DATADIR%%/addon/fcitx-table.conf
+%%DATADIR%%/addon/fcitx-vk.conf
+%%DATADIR%%/addon/fcitx-x11.conf
+%%DATADIR%%/addon/fcitx-xim.conf
+%%DATADIR%%/configdesc/addon.desc
+%%DATADIR%%/configdesc/config.desc
+%%DATADIR%%/configdesc/fcitx-chttrans.desc
+%%DATADIR%%/configdesc/fcitx-classic-ui.desc
+%%DATADIR%%/configdesc/fcitx-pinyin.desc
+%%DATADIR%%/configdesc/fcitx-xim.desc
+%%DATADIR%%/configdesc/profile.desc
+%%DATADIR%%/configdesc/skin.desc
+%%DATADIR%%/configdesc/table.desc
%%DATADIR%%/data/AutoEng.dat
-%%DATADIR%%/data/addon.desc
-%%DATADIR%%/data/config.desc
%%DATADIR%%/data/gbks2t.tab
-%%DATADIR%%/data/profile.desc
%%DATADIR%%/data/punc.mb
-%%DATADIR%%/data/pySym.mb
-%%DATADIR%%/data/pybase.mb
-%%DATADIR%%/data/pyphrase.mb
-%%DATADIR%%/data/skin.desc
-%%DATADIR%%/data/sp.dat
-%%DATADIR%%/data/table.desc
-%%DATADIR%%/data/table/cangjie.conf
-%%DATADIR%%/data/table/cj.mb
-%%DATADIR%%/data/table/db.conf
-%%DATADIR%%/data/table/db.mb
-%%DATADIR%%/data/table/disable-table.conf.template
-%%DATADIR%%/data/table/erbi.conf
-%%DATADIR%%/data/table/erbi.mb
-%%DATADIR%%/data/table/qxm.conf
-%%DATADIR%%/data/table/qxm.mb
-%%DATADIR%%/data/table/wanfeng.conf
-%%DATADIR%%/data/table/wanfeng.mb
-%%DATADIR%%/data/table/wbpy.conf
-%%DATADIR%%/data/table/wbpy.mb
-%%DATADIR%%/data/table/wbx.conf
-%%DATADIR%%/data/table/wbx.mb
-%%DATADIR%%/data/table/zrm.conf
-%%DATADIR%%/data/table/zrm.mb
%%DATADIR%%/data/vk.conf
-%%DATADIR%%/doc/API.txt
-%%DATADIR%%/doc/Develop_Readme
-%%DATADIR%%/doc/cjkvinput.txt
-%%DATADIR%%/doc/fcitx4.pdf
-%%DATADIR%%/doc/fcitx_trunk.doxyfile
-%%DATADIR%%/doc/pinyin.txt
-%%DATADIR%%/doc/wb_fh.htm
+%%DATADIR%%/pinyin/pySym.mb
+%%DATADIR%%/pinyin/pybase.mb
+%%DATADIR%%/pinyin/pyphrase.mb
+%%DATADIR%%/pinyin/sp.dat
%%DATADIR%%/skin/classic/active.png
%%DATADIR%%/skin/classic/bar.png
%%DATADIR%%/skin/classic/bingchan.png
%%DATADIR%%/skin/classic/cangjie.png
-%%DATADIR%%/skin/classic/chnpunc.png
+%%DATADIR%%/skin/classic/chttrans_active.png
+%%DATADIR%%/skin/classic/chttrans_inactive.png
%%DATADIR%%/skin/classic/cn.png
%%DATADIR%%/skin/classic/dianbaoma.png
%%DATADIR%%/skin/classic/en.png
-%%DATADIR%%/skin/classic/engpunc.png
%%DATADIR%%/skin/classic/erbi.png
-%%DATADIR%%/skin/classic/fan.png
%%DATADIR%%/skin/classic/fcitx_skin.conf
-%%DATADIR%%/skin/classic/full.png
-%%DATADIR%%/skin/classic/half.png
+%%DATADIR%%/skin/classic/fullwidth_active.png
+%%DATADIR%%/skin/classic/fullwidth_inactive.png
%%DATADIR%%/skin/classic/inactive.png
%%DATADIR%%/skin/classic/input.png
-%%DATADIR%%/skin/classic/jian.png
-%%DATADIR%%/skin/classic/legend.png
%%DATADIR%%/skin/classic/logo.png
%%DATADIR%%/skin/classic/menu.png
%%DATADIR%%/skin/classic/next.png
-%%DATADIR%%/skin/classic/nolegend.png
-%%DATADIR%%/skin/classic/novk.png
%%DATADIR%%/skin/classic/pinyin.png
%%DATADIR%%/skin/classic/prev.png
+%%DATADIR%%/skin/classic/punc_active.png
+%%DATADIR%%/skin/classic/punc_inactive.png
%%DATADIR%%/skin/classic/quwei.png
+%%DATADIR%%/skin/classic/remind_active.png
+%%DATADIR%%/skin/classic/remind_inactive.png
%%DATADIR%%/skin/classic/shuangpin.png
-%%DATADIR%%/skin/classic/vk.png
+%%DATADIR%%/skin/classic/vk_active.png
+%%DATADIR%%/skin/classic/vk_inactive.png
%%DATADIR%%/skin/classic/wanfeng.png
%%DATADIR%%/skin/classic/wbpy.png
%%DATADIR%%/skin/classic/wubi.png
@@ -112,30 +146,31 @@ share/pixmaps/fcitx/fcitx.png
%%DATADIR%%/skin/dark/bar.png
%%DATADIR%%/skin/dark/bingchan.png
%%DATADIR%%/skin/dark/cangjie.png
-%%DATADIR%%/skin/dark/chnpunc.png
+%%DATADIR%%/skin/dark/chttrans_active.png
+%%DATADIR%%/skin/dark/chttrans_inactive.png
%%DATADIR%%/skin/dark/cn.png
%%DATADIR%%/skin/dark/dianbaoma.png
%%DATADIR%%/skin/dark/en.png
-%%DATADIR%%/skin/dark/engpunc.png
%%DATADIR%%/skin/dark/erbi.png
-%%DATADIR%%/skin/dark/fan.png
%%DATADIR%%/skin/dark/fcitx_skin.conf
-%%DATADIR%%/skin/dark/full.png
-%%DATADIR%%/skin/dark/half.png
+%%DATADIR%%/skin/dark/fullwidth_active.png
+%%DATADIR%%/skin/dark/fullwidth_inactive.png
%%DATADIR%%/skin/dark/inactive.png
%%DATADIR%%/skin/dark/input.png
-%%DATADIR%%/skin/dark/jian.png
-%%DATADIR%%/skin/dark/legend.png
+%%DATADIR%%/skin/dark/keyboard.png
%%DATADIR%%/skin/dark/logo.png
%%DATADIR%%/skin/dark/menu.png
%%DATADIR%%/skin/dark/next.png
-%%DATADIR%%/skin/dark/nolegend.png
-%%DATADIR%%/skin/dark/novk.png
%%DATADIR%%/skin/dark/pinyin.png
%%DATADIR%%/skin/dark/prev.png
+%%DATADIR%%/skin/dark/punc_active.png
+%%DATADIR%%/skin/dark/punc_inactive.png
%%DATADIR%%/skin/dark/quwei.png
+%%DATADIR%%/skin/dark/remind_active.png
+%%DATADIR%%/skin/dark/remind_inactive.png
%%DATADIR%%/skin/dark/shuangpin.png
-%%DATADIR%%/skin/dark/vk.png
+%%DATADIR%%/skin/dark/vk_active.png
+%%DATADIR%%/skin/dark/vk_inactive.png
%%DATADIR%%/skin/dark/wanfeng.png
%%DATADIR%%/skin/dark/wbpy.png
%%DATADIR%%/skin/dark/wubi.png
@@ -144,43 +179,99 @@ share/pixmaps/fcitx/fcitx.png
%%DATADIR%%/skin/default/bar.png
%%DATADIR%%/skin/default/bingchan.png
%%DATADIR%%/skin/default/cangjie.png
-%%DATADIR%%/skin/default/chnpunc.png
+%%DATADIR%%/skin/default/chttrans_active.png
+%%DATADIR%%/skin/default/chttrans_inactive.png
%%DATADIR%%/skin/default/cn.png
%%DATADIR%%/skin/default/dianbaoma.png
%%DATADIR%%/skin/default/en.png
-%%DATADIR%%/skin/default/engpunc.png
%%DATADIR%%/skin/default/erbi.png
-%%DATADIR%%/skin/default/fan.png
%%DATADIR%%/skin/default/fcitx_skin.conf
-%%DATADIR%%/skin/default/full.png
-%%DATADIR%%/skin/default/half.png
+%%DATADIR%%/skin/default/fullwidth_active.png
+%%DATADIR%%/skin/default/fullwidth_inactive.png
%%DATADIR%%/skin/default/inactive.png
%%DATADIR%%/skin/default/input.png
-%%DATADIR%%/skin/default/jian.png
%%DATADIR%%/skin/default/keyboard.png
-%%DATADIR%%/skin/default/legend.png
%%DATADIR%%/skin/default/logo.png
%%DATADIR%%/skin/default/menu.png
%%DATADIR%%/skin/default/next.png
-%%DATADIR%%/skin/default/nolegend.png
-%%DATADIR%%/skin/default/novk.png
%%DATADIR%%/skin/default/pinyin.png
%%DATADIR%%/skin/default/prev.png
+%%DATADIR%%/skin/default/punc_active.png
+%%DATADIR%%/skin/default/punc_inactive.png
%%DATADIR%%/skin/default/quwei.png
+%%DATADIR%%/skin/default/remind_active.png
+%%DATADIR%%/skin/default/remind_inactive.png
%%DATADIR%%/skin/default/shuangpin.png
-%%DATADIR%%/skin/default/vk.png
+%%DATADIR%%/skin/default/vk_active.png
+%%DATADIR%%/skin/default/vk_inactive.png
%%DATADIR%%/skin/default/wanfeng.png
%%DATADIR%%/skin/default/wbpy.png
%%DATADIR%%/skin/default/wubi.png
%%DATADIR%%/skin/default/ziranma.png
+%%DATADIR%%/table/cangjie.conf
+%%DATADIR%%/table/cj.mb
+%%DATADIR%%/table/db.conf
+%%DATADIR%%/table/db.mb
+%%DATADIR%%/table/erbi.conf
+%%DATADIR%%/table/erbi.mb
+%%DATADIR%%/table/qxm.conf
+%%DATADIR%%/table/qxm.mb
+%%DATADIR%%/table/wanfeng.conf
+%%DATADIR%%/table/wanfeng.mb
+%%DATADIR%%/table/wbpy.conf
+%%DATADIR%%/table/wbpy.mb
+%%DATADIR%%/table/wbx.conf
+%%DATADIR%%/table/wbx.mb
+%%DATADIR%%/table/zrm.conf
+%%DATADIR%%/table/zrm.mb
+share/icons/hicolor/128x128/apps/fcitx.png
+share/icons/hicolor/16x16/apps/fcitx.png
+share/icons/hicolor/22x22/apps/fcitx.png
+share/icons/hicolor/24x24/apps/fcitx.png
+share/icons/hicolor/32x32/apps/fcitx.png
+share/icons/hicolor/32x32/status/fcitx-fullwidth-active.png
+share/icons/hicolor/32x32/status/fcitx-fullwidth-inactive.png
+share/icons/hicolor/32x32/status/fcitx-punc-active.png
+share/icons/hicolor/32x32/status/fcitx-punc-inactive.png
+share/icons/hicolor/32x32/status/fcitx-vk-active.png
+share/icons/hicolor/32x32/status/fcitx-vk-inactive.png
+share/icons/hicolor/48x48/apps/fcitx.png
+share/icons/hicolor/48x48/status/fcitx-cangjie.png
+share/icons/hicolor/48x48/status/fcitx-chn.png
+share/icons/hicolor/48x48/status/fcitx-chttrans-active.png
+share/icons/hicolor/48x48/status/fcitx-chttrans-inactive.png
+share/icons/hicolor/48x48/status/fcitx-eng.png
+share/icons/hicolor/48x48/status/fcitx-erbi.png
+share/icons/hicolor/48x48/status/fcitx-pinyin.png
+share/icons/hicolor/48x48/status/fcitx-remind-active.png
+share/icons/hicolor/48x48/status/fcitx-remind-inactive.png
+share/icons/hicolor/48x48/status/fcitx-shuangpin.png
+share/icons/hicolor/48x48/status/fcitx-wbpy.png
+share/icons/hicolor/48x48/status/fcitx-wubi.png
+share/icons/hicolor/48x48/status/fcitx-ziranma.png
+share/locale/zh_CN/LC_MESSAGES/fcitx.mo
+share/mime/packages/x-fskin.xml
+@dirrmtry share/applications
+@dirrm %%DATADIR%%/table
@dirrm %%DATADIR%%/skin/default
@dirrm %%DATADIR%%/skin/dark
@dirrm %%DATADIR%%/skin/classic
@dirrm %%DATADIR%%/skin
-@dirrm %%DATADIR%%/doc
-@dirrm %%DATADIR%%/data/table
+@dirrm %%DATADIR%%/pinyin
@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/configdesc
+@dirrm %%DATADIR%%/addon
@dirrm %%DATADIR%%
-@dirrm share/pixmaps/fcitx
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/cmake/fcitx
+@dirrm lib/fcitx
+@dirrm include/fcitx/module/x11
+@dirrm include/fcitx/module/punc
+@dirrm include/fcitx/module/pinyin
+%%DBUS%%@dirrm include/fcitx/module/ipc
+%%DBUS%%@dirrm include/fcitx/module/dbus
+@dirrm include/fcitx/module/classicui
+@dirrm include/fcitx/module
+@dirrm include/fcitx-utils
@dirrm include/fcitx-config
@dirrm include/fcitx