aboutsummaryrefslogtreecommitdiff
path: root/chinese/fireflyttf/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
commit222461c302e52a3848555e999ecc7a10f98b278e (patch)
tree4fad0f8d9c328a570a49371daf5f0078d7075272 /chinese/fireflyttf/Makefile
parentb6155c63444b79580e9bd13727472581d1ed66f1 (diff)
downloadports-222461c302e52a3848555e999ecc7a10f98b278e.tar.gz
ports-222461c302e52a3848555e999ecc7a10f98b278e.zip
Notes
Diffstat (limited to 'chinese/fireflyttf/Makefile')
-rw-r--r--chinese/fireflyttf/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/chinese/fireflyttf/Makefile b/chinese/fireflyttf/Makefile
index c5108075b643..a7babae564a0 100644
--- a/chinese/fireflyttf/Makefile
+++ b/chinese/fireflyttf/Makefile
@@ -20,40 +20,41 @@ CONFLICTS= zh-opendesktop-fonts-*
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS= LGJ_FONT "Patch for Taiwan horn" on
+OPTIONS_DEFINE= LGJ_FONT X11
+OPTIONS_DEFAULT= LGJ_FONT X11
+LGJ_FONT_DESC= Patch for Taiwan horn
TTF= fireflysung.ttf
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_LGJ_FONT)
-.else
+.if ${PORT_OPTIONS:MLGJ_FONT}
PKGNAMESUFFIX+= -LGJ
MASTER_SITES= http://edt1023.sayya.org/fonts/
DISTNAME= fireflysung-1.3.0p1
.endif
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
PLIST_SUB+= X11=""
.else
PLIST_SUB+= X11="@comment "
.endif
post-extract:
-.if defined(WITHOUT_LGJ_FONT)
- @${DO_NADA}
-.else
+.if ${PORT_OPTIONS:MLGJ_FONT}
@${TAR} -C ${WRKSRC} -zxf ${DISTDIR}/fireflysung-1.3.0p1.tar.gz \
fireflysung-1.3.0p1/fireflysung.ttf
@${MV} ${WRKSRC}/fireflysung-1.3.0p1/fireflysung.ttf ${WRKSRC}
@${RM} -rf ${WRKSRC}/fireflysung-1.3.0p1
+.else
+ ${DO_NADA}
.endif
do-install:
${MKDIR} ${FONTSDIR}
${INSTALL_DATA} ${WRKSRC}/${TTF} ${FONTSDIR}
${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTSDIR}
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${LOCALBASE}/etc/fonts/local.conf
.endif