aboutsummaryrefslogtreecommitdiff
path: root/chinese/hc
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-02-08 00:36:02 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-02-08 00:36:02 +0000
commit884bc613071a4fc2331b6b05a890a19adf212390 (patch)
tree05d23e8ac339391db6837d7939da3d85b0724c8c /chinese/hc
parentf624f3f4083cd90af517934593243f2ba1e378df (diff)
downloadports-884bc613071a4fc2331b6b05a890a19adf212390.tar.gz
ports-884bc613071a4fc2331b6b05a890a19adf212390.zip
This is the Hanzi Converter, which converts between GB and BIG-5 codes.
Notes
Notes: svn path=/head/; revision=5563
Diffstat (limited to 'chinese/hc')
-rw-r--r--chinese/hc/Makefile33
-rw-r--r--chinese/hc/distinfo2
-rw-r--r--chinese/hc/files/patch-0117
-rw-r--r--chinese/hc/pkg-comment1
-rw-r--r--chinese/hc/pkg-descr9
-rw-r--r--chinese/hc/pkg-plist6
6 files changed, 68 insertions, 0 deletions
diff --git a/chinese/hc/Makefile b/chinese/hc/Makefile
new file mode 100644
index 000000000000..164a4e361ff0
--- /dev/null
+++ b/chinese/hc/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: hc
+# Version required: 3.0
+# Date created: Mon Feb 03, 1997
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+PKGNAME= cn-hc-3.0
+CATEGORIES= chinese
+MASTER_SITES= ftp://ftp.ifcss.org/pub/software/unix/convert/ \
+ ftp://ftp.edu.tw/Chinese/ifcss/software/unix/convert/ \
+ ftp://ftp.cuhk.hk/pub/chinese/ifcss/software/unix/convert/
+DISTFILES= hc-30.tar.gz hc-supp.tab
+
+MAINTAINER= obrien@NUXI.com
+
+WRKSRC= ${WRKDIR}/hc3
+EXTRACT_ONLY= hc-30.tar.gz
+ALL_TARGET= hc b2g g2b
+MAN1= hc.1
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/chinese
+ ${INSTALL_PROGRAM} ${WRKSRC}/hc ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/b2g ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/g2b ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/hc.tab ${PREFIX}/share/chinese
+ ${INSTALL_DATA} ${DISTDIR}/hc-supp.tab ${PREFIX}/share/chinese
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/chinese/hc/distinfo b/chinese/hc/distinfo
new file mode 100644
index 000000000000..31651862d6dc
--- /dev/null
+++ b/chinese/hc/distinfo
@@ -0,0 +1,2 @@
+MD5 (hc-30.tar.gz) = e3a0fad6154e1d3f4e8abbb52abf28e1
+MD5 (hc-supp.tab) = 5b12db3fbe75b4b252a4f588a1d25a58
diff --git a/chinese/hc/files/patch-01 b/chinese/hc/files/patch-01
new file mode 100644
index 000000000000..2e56bffc366c
--- /dev/null
+++ b/chinese/hc/files/patch-01
@@ -0,0 +1,17 @@
+--- Makefile.orig Wed Mar 10 23:22:44 1993
++++ Makefile Tue Feb 4 02:48:17 1997
+@@ -5,12 +5,12 @@
+
+ b2g:
+ echo "#! /bin/csh" > b2g
+- echo $(PWD)/hc "-m b2g -t" $(PWD)/hc.tab "$$*" >> b2g
++ echo $(PREFIX)/bin/hc "-m b2g -t" $(PREFIX)/share/chinese/hc.tab "$$*" >> b2g
+ chmod a+x b2g
+
+ g2b:
+ echo "#! /bin/csh" > g2b
+- echo $(PWD)/hc -m g2b -t $(PWD)/hc.tab "$$*" >> g2b
++ echo $(PREFIX)/bin/hc -m g2b -t $(PREFIX)/share/chinese/hc.tab "$$*" >> g2b
+ chmod a+x g2b
+
+ clean:
diff --git a/chinese/hc/pkg-comment b/chinese/hc/pkg-comment
new file mode 100644
index 000000000000..747400a8df39
--- /dev/null
+++ b/chinese/hc/pkg-comment
@@ -0,0 +1 @@
+Hanzi Converter -- converts between GB and BIG-5 codes
diff --git a/chinese/hc/pkg-descr b/chinese/hc/pkg-descr
new file mode 100644
index 000000000000..2a8e2d2f3495
--- /dev/null
+++ b/chinese/hc/pkg-descr
@@ -0,0 +1,9 @@
+This is the Hanzi Converter, which converts between GB and BIG-5 codes.
+
+The program converts a GB file to a BIG-5 file, or a BIG-5 file to a GB file.
+GB (GuoBiao) refers to the standard implementation of "GB2312-80" of
+Mainland China, in which the two bytes representing a GB code have their
+most significant bit set to 1. BIG-5 refers to the Big Five standard
+published in 1984 by Taiwan's Institute for Information Industry.
+
+-- David O'Brien
diff --git a/chinese/hc/pkg-plist b/chinese/hc/pkg-plist
new file mode 100644
index 000000000000..136dbd51a319
--- /dev/null
+++ b/chinese/hc/pkg-plist
@@ -0,0 +1,6 @@
+bin/hc
+bin/b2g
+bin/g2b
+share/chinese/hc.tab
+share/chinese/hc-supp.tab
+man/man1/hc.1.gz