aboutsummaryrefslogtreecommitdiff
path: root/chinese/ibus-libpinyin
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2015-03-31 21:06:47 +0000
committerXin LI <delphij@FreeBSD.org>2015-03-31 21:06:47 +0000
commit3dded20050a2f31311d695771a52ddb1d73db5db (patch)
tree49313b119d396a7e3af5a08fbf731162f986c8c6 /chinese/ibus-libpinyin
parent2fba1cb34dce99e9f45f975c1c9c8f7b7098746e (diff)
downloadports-3dded20050a2f31311d695771a52ddb1d73db5db.tar.gz
ports-3dded20050a2f31311d695771a52ddb1d73db5db.zip
Add ibus-libpinyin 1.7.1, intelligent Pinyin engine based on libpinyin
for IBus. This is based on an old version of ibus-libpinyin submitted by Henry Hu <henry.hu.sh gmail com> with updates from myself. PR: 197116
Notes
Notes: svn path=/head/; revision=382867
Diffstat (limited to 'chinese/ibus-libpinyin')
-rw-r--r--chinese/ibus-libpinyin/Makefile71
-rw-r--r--chinese/ibus-libpinyin/distinfo2
-rw-r--r--chinese/ibus-libpinyin/pkg-descr6
-rw-r--r--chinese/ibus-libpinyin/pkg-plist39
4 files changed, 118 insertions, 0 deletions
diff --git a/chinese/ibus-libpinyin/Makefile b/chinese/ibus-libpinyin/Makefile
new file mode 100644
index 000000000000..bf3af95268a1
--- /dev/null
+++ b/chinese/ibus-libpinyin/Makefile
@@ -0,0 +1,71 @@
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ibus-libpinyin
+PORTVERSION= 1.7.1
+CATEGORIES= chinese
+MASTER_SITES= SF/libpinyin/${PORTNAME}
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Intelligent Pinyin engine based on libpinyin for IBus
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libibus-1.0.so:${PORTSDIR}/textproc/ibus \
+ libpinyin.so:${PORTSDIR}/chinese/libpinyin
+
+USES= compiler:c++0x gmake python pkgconfig gettext
+USE_GNOME= glib20
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-dependency-tracking --disable-boost \
+ --disable-lua-extension
+
+OPTIONS_DEFINE= ENGLISH STROKE OPENCC NLS
+OPTIONS_DEFAULT= ENGLISH STROKE NLS
+ENGLISH_DESC= Enable English input mode
+STROKE_DESC= Enable stroke input mode
+OPENCC_DESC= Use opencc for simplified and traditional Chinese conversion
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MENGLISH}
+CONFIGURE_ARGS+= --enable-english-input-mode
+PLIST_SUB+= ENGLISH=""
+.else
+CONFIGURE_ARGS+= --disable-english-input-mode
+PLIST_SUB+= ENGLISH="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MSTROKE}
+CONFIGURE_ARGS+= --enable-stroke-input-mode
+PLIST_SUB+= STROKE=""
+.else
+CONFIGURE_ARGS+= --disable-stroke-input-mode
+PLIST_SUB+= STROKE="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MOPENCC}
+BROKEN= Requires newer OpenCC
+CONFIGURE_ARGS+= --enable-opencc
+LIB_DEPENDS+= libopencc.so:${PORTSDIR}/chinese/opencc
+.else
+CONFIGURE_ARGS+= --disable-opencc
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+USE_GNOME+= intltool
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|DATADIRNAME = lib|DATADIRNAME = share|' ${WRKSRC}/po/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/chinese/ibus-libpinyin/distinfo b/chinese/ibus-libpinyin/distinfo
new file mode 100644
index 000000000000..37ce5e60dfeb
--- /dev/null
+++ b/chinese/ibus-libpinyin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ibus-libpinyin-1.7.1.tar.gz) = 81e9dc953b53bf5aff3b66c61d63180dc109eb645ab3cbcc1b733393f6c78afb
+SIZE (ibus-libpinyin-1.7.1.tar.gz) = 1043569
diff --git a/chinese/ibus-libpinyin/pkg-descr b/chinese/ibus-libpinyin/pkg-descr
new file mode 100644
index 000000000000..870648d020a2
--- /dev/null
+++ b/chinese/ibus-libpinyin/pkg-descr
@@ -0,0 +1,6 @@
+Intelligent Pinyin engine based on libpinyin for IBus
+
+It includes a Chinese Pinyin input method and a Chinese ZhuYin (Bopomofo)
+input method based on libpinyin for IBus.
+
+WWW: http://github.com/libpinyin/ibus-libpinyin
diff --git a/chinese/ibus-libpinyin/pkg-plist b/chinese/ibus-libpinyin/pkg-plist
new file mode 100644
index 000000000000..2fb0f7df3b32
--- /dev/null
+++ b/chinese/ibus-libpinyin/pkg-plist
@@ -0,0 +1,39 @@
+%%NLS%%share/locale/fr/LC_MESSAGES/ibus-libpinyin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/ibus-libpinyin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-libpinyin.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus-libpinyin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-libpinyin.mo
+libexec/ibus-engine-libpinyin
+libexec/ibus-setup-libpinyin
+share/applications/ibus-setup-libbopomofo.desktop
+share/applications/ibus-setup-libpinyin.desktop
+%%ENGLISH%%%%DATADIR%%/db/english.db
+%%STROKE%%%%DATADIR%%/db/strokes.db
+%%DATADIR%%/icons/chinese.svg
+%%DATADIR%%/icons/english.svg
+%%DATADIR%%/icons/full-punct.svg
+%%DATADIR%%/icons/full.svg
+%%DATADIR%%/icons/half-punct.svg
+%%DATADIR%%/icons/half.svg
+%%DATADIR%%/icons/ibus-bopomofo.svg
+%%DATADIR%%/icons/ibus-pinyin.svg
+%%DATADIR%%/icons/simp-chinese.svg
+%%DATADIR%%/icons/trad-chinese.svg
+%%DATADIR%%/phrases.txt
+%%DATADIR%%/setup/config.py
+%%DATADIR%%/setup/config.pyc
+%%DATADIR%%/setup/config.pyo
+%%DATADIR%%/setup/dicttreeview.py
+%%DATADIR%%/setup/dicttreeview.pyc
+%%DATADIR%%/setup/dicttreeview.pyo
+%%DATADIR%%/setup/ibus-libpinyin-preferences.ui
+%%DATADIR%%/setup/keyboardshortcut.py
+%%DATADIR%%/setup/keyboardshortcut.pyc
+%%DATADIR%%/setup/keyboardshortcut.pyo
+%%DATADIR%%/setup/main2.py
+%%DATADIR%%/setup/main2.pyc
+%%DATADIR%%/setup/main2.pyo
+%%DATADIR%%/setup/shortcuteditor.py
+%%DATADIR%%/setup/shortcuteditor.pyc
+%%DATADIR%%/setup/shortcuteditor.pyo
+share/ibus/component/libpinyin.xml