aboutsummaryrefslogtreecommitdiff
path: root/chinese/ibus-pinyin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-03-26 09:36:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-03-26 09:36:38 +0000
commit9ceaac8094e4ac867c06a5afd73ae51ec90dc90e (patch)
tree13ef2cb25f2a9bf0d60e50378c35fc272688bb9f /chinese/ibus-pinyin/Makefile
parent821d9010723d7c31c744e0d42af1e27c607e46f6 (diff)
downloadports-9ceaac8094e4ac867c06a5afd73ae51ec90dc90e.tar.gz
ports-9ceaac8094e4ac867c06a5afd73ae51ec90dc90e.zip
PinYin engine for IBus.
WWW: http://code.google.com/p/ibus PR: ports/128371 Submitted by: Henry Hu <henry.hu.sh@gmail.com>
Notes
Notes: svn path=/head/; revision=231048
Diffstat (limited to 'chinese/ibus-pinyin/Makefile')
-rw-r--r--chinese/ibus-pinyin/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
new file mode 100644
index 000000000000..50e13f9f68d7
--- /dev/null
+++ b/chinese/ibus-pinyin/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ibus
+# Date created: 21 October 2008
+# Whom: Henry Hu <henry.hu.sh@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-pinyin
+PORTVERSION= 1.1.0.20090303
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DBTAR}
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= PinYin engine for IBus
+
+RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+
+USE_PYTHON= yes
+USE_GNOME= pygtk2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-dependency-tracking
+
+PROJECTHOST= ibus
+DBVER= 0.1.10.6
+DBTAR= pinyin-database-${DBVER}.tar.bz2
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-extract:
+ ${MV} ${WRKDIR}/py.db ${WRKSRC}/engine/
+ ${TOUCH} ${WRKSRC}/engine/${DBTAR}
+
+.include <bsd.port.mk>