aboutsummaryrefslogtreecommitdiff
path: root/chinese/libchewing
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2013-06-27 01:47:18 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2013-06-27 01:47:18 +0000
commit6811f298e9d49aa9f7a71816b1261ebcebd92b06 (patch)
tree91a33abf1886050c5deb001b946fab4fa38597d1 /chinese/libchewing
parent5d9a5e41d956d7d197afcfdae9863a27e3ca2231 (diff)
downloadports-6811f298e9d49aa9f7a71816b1261ebcebd92b06.tar.gz
ports-6811f298e9d49aa9f7a71816b1261ebcebd92b06.zip
Update chinese/libchewing to 0.3.4
* Master site changed to Google Code * Patches to install data into PREFIX/share/chewing Patch created and tested by me and Zhihao Yuan(lichray@gmail.com) PR: ports/176021 Submitted by: Henry Hu <henry.hu.sh_AT_gmail.com>
Notes
Notes: svn path=/head/; revision=321829
Diffstat (limited to 'chinese/libchewing')
-rw-r--r--chinese/libchewing/Makefile17
-rw-r--r--chinese/libchewing/distinfo4
-rw-r--r--chinese/libchewing/files/patch-data_Makefile.in11
-rw-r--r--chinese/libchewing/files/patch-plat_path.c15
-rw-r--r--chinese/libchewing/files/patch-src_porting_layer_Makefile.in10
5 files changed, 47 insertions, 10 deletions
diff --git a/chinese/libchewing/Makefile b/chinese/libchewing/Makefile
index 4c25caac883b..41526684602f 100644
--- a/chinese/libchewing/Makefile
+++ b/chinese/libchewing/Makefile
@@ -1,24 +1,25 @@
-# New ports collection makefile for: libchewing
-# Date created: 5 Sep 2004
-# Whom: Kuang-che Wu <kcwu@csie.org>
-#
+# Created by: Kuang-che Wu <kcwu@csie.org>
# $FreeBSD$
-#
PORTNAME= libchewing
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= chinese textproc
-MASTER_SITES= http://chewing.csie.net/download/libchewing/
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= clsung@FreeBSD.org
COMMENT= The Chewing intelligent phonetic input method library
-USE_GNOME= gnomehack pkgconfig
+INFO= libchewing
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_BZIP2= yes
DATADIR= ${PREFIX}/share/chewing
+PROJECTHOST= chewing
.include <bsd.port.pre.mk>
diff --git a/chinese/libchewing/distinfo b/chinese/libchewing/distinfo
index f0fe8fb33ed7..78ce8dc59f8d 100644
--- a/chinese/libchewing/distinfo
+++ b/chinese/libchewing/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libchewing-0.3.3.tar.bz2) = 72a0de12b86c4d5f6468a68d88c736227ff16fa7a915f8595ffe5a31cae95eae
-SIZE (libchewing-0.3.3.tar.bz2) = 1798134
+SHA256 (libchewing-0.3.4.tar.bz2) = f940734d514d52f0375cb1afa5d4d7536a93fd8ff0c3ce4a002ab1698dd07ff6
+SIZE (libchewing-0.3.4.tar.bz2) = 1926898
diff --git a/chinese/libchewing/files/patch-data_Makefile.in b/chinese/libchewing/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..62bee924a8f9
--- /dev/null
+++ b/chinese/libchewing/files/patch-data_Makefile.in
@@ -0,0 +1,11 @@
+--- data/Makefile.in.orig 2013-02-10 19:20:34.000000000 -0500
++++ data/Makefile.in 2013-02-10 19:20:40.000000000 -0500
+@@ -261,7 +261,7 @@
+ tsi.src \
+ $(NULL)
+
+-chewing_datadir = $(pkglibdir)
++chewing_datadir = $(datadir)/chewing
+ chewing_data_DATA = \
+ $(static_tables) \
+ $(datas) \
diff --git a/chinese/libchewing/files/patch-plat_path.c b/chinese/libchewing/files/patch-plat_path.c
new file mode 100644
index 000000000000..80b8a49d8804
--- /dev/null
+++ b/chinese/libchewing/files/patch-plat_path.c
@@ -0,0 +1,15 @@
+--- src/porting_layer/src/plat_path.c.orig 2013-02-10 19:57:20.000000000 -0500
++++ src/porting_layer/src/plat_path.c 2013-02-10 19:57:35.000000000 -0500
+@@ -37,10 +37,10 @@
+ home = getenv( "HOME" );
+ if ( home ) {
+ snprintf( path, path_len, "%s/.chewing" SEARCH_PATH_SEP
+- LIBDIR "/libchewing", home );
++ DATADIR "/chewing", home );
+ } else {
+ // No HOME ?
+- strncpy( path, SEARCH_PATH_SEP LIBDIR "/libchewing", path_len );
++ strncpy( path, SEARCH_PATH_SEP DATADIR "/chewing", path_len );
+ }
+ }
+
diff --git a/chinese/libchewing/files/patch-src_porting_layer_Makefile.in b/chinese/libchewing/files/patch-src_porting_layer_Makefile.in
new file mode 100644
index 000000000000..b1aacdb2939c
--- /dev/null
+++ b/chinese/libchewing/files/patch-src_porting_layer_Makefile.in
@@ -0,0 +1,10 @@
+--- src/porting_layer/src/Makefile.in.orig 2013-02-10 19:59:20.000000000 -0500
++++ src/porting_layer/src/Makefile.in 2013-02-10 19:59:33.000000000 -0500
+@@ -113,6 +113,7 @@
+ AM_CFLAGS = @AM_CFLAGS@
+ AM_CPPFLAGS = \
+ -DLIBDIR=\"@libdir@\" \
++ -DDATADIR=\"@datadir@\" \
+ $(NULL)
+
+ AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@