aboutsummaryrefslogtreecommitdiff
path: root/chinese/libime/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-01-18 16:51:15 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-01-18 16:51:15 +0000
commit70a8a105ef852bf4a1459ba26290754e164ffe13 (patch)
tree4e5aa9f4faf5c09255448519b2cbd3d65370393d /chinese/libime/Makefile
parent9f04cf7499214b251a588dea036e008050a3279e (diff)
downloadports-70a8a105ef852bf4a1459ba26290754e164ffe13.tar.gz
ports-70a8a105ef852bf4a1459ba26290754e164ffe13.zip
Notes
Diffstat (limited to 'chinese/libime/Makefile')
-rw-r--r--chinese/libime/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/chinese/libime/Makefile b/chinese/libime/Makefile
index f7ded5e5eea9..38fd73961623 100644
--- a/chinese/libime/Makefile
+++ b/chinese/libime/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libime
-DISTVERSION= 1.0.2-4
+DISTVERSION= 1.0.3
CATEGORIES= chinese textproc
MASTER_SITES= https://download.fcitx-im.org/data/:opengram_lm,opengram_dict,table_dict
DISTFILES= ${OPENGRAM_LM_TAR}:opengram_lm \
@@ -18,18 +18,22 @@ LICENSE= LGPL21
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libFcitx5Utils.so:textproc/fcitx5
+USES= compiler:c++17-lang cmake kde:5
+
+PLIST_SUB= VER=${PORTVERSION} VER_MAJOR=${PORTVERSION:R:R}
+
+USE_LDCONFIG= yes
+
USE_GITHUB= yes
GH_ACCOUNT= fcitx
-GH_TAGNAME= e2e48ed
GH_TUPLE= kpu:kenlm:01c49fe:kenlm/src/libime/core/kenlm
-USES= compiler:c++17-lang cmake kde:5
-
USE_KDE= ecm
CMAKE_OFF= ENABLE_TEST
MAKE_ENV= FCITX5_DOWNLOAD_DISALLOWED=TRUE
+# These must follow data/CMakeLists.txt
OPENGRAM_LM_TAR= lm_sc.3gm.arpa-20140820.tar.bz2
OPENGRAM_DICT_TAR= dict.utf8-20200715.tar.xz
TABLE_DICT_TAR= table.tar.gz