aboutsummaryrefslogtreecommitdiff
path: root/chinese/libtabe
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-09 11:50:49 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-09 11:50:49 +0000
commit1970ee35e2ede7d1799bb2e2cb293a7db7730a63 (patch)
tree5f1b1f057c068bc807cdf61420850bfe370b181f /chinese/libtabe
parent4d14fdf1dbd7a176ec69bcaed19668e387aeffc9 (diff)
downloadports-1970ee35e2ede7d1799bb2e2cb293a7db7730a63.tar.gz
ports-1970ee35e2ede7d1799bb2e2cb293a7db7730a63.zip
chinese/libtabe: Unbreak fetch (slightly different distfile)
I don't know why, but the other repositories use a version of libtabe that's about 5 days newer, although both are listed as version 0.2.6. Apparently it was re-rolled about 11 years ago. A patch had to be regenerated as a result. I reviewed differences between the two tarballs and everything was innocent (a good chunk of different was html documentation in chinese. The DEBIAN_POOL magic doesn't support libraries, so MASTER_SITE_DEBIAN had to be manually tweaked to use the Debian pool. While here, clean up the X11 option a bit and wrap lines at 80 columns.
Notes
Notes: svn path=/head/; revision=383638
Diffstat (limited to 'chinese/libtabe')
-rw-r--r--chinese/libtabe/Makefile29
-rw-r--r--chinese/libtabe/distinfo4
-rw-r--r--chinese/libtabe/files/patch-util__tsipackdb.in17
3 files changed, 24 insertions, 26 deletions
diff --git a/chinese/libtabe/Makefile b/chinese/libtabe/Makefile
index 12277d6123db..406f171fd33e 100644
--- a/chinese/libtabe/Makefile
+++ b/chinese/libtabe/Makefile
@@ -3,14 +3,14 @@
PORTNAME= libtabe
PORTVERSION= 0.2.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= chinese
-MASTER_SITES= ftp://cle.linux.org.tw/pub/xcin/cvs/
+MASTER_SITES= ${MASTER_SITE_DEBIAN:C|(/%SUBDIR%/)|/pool/main/libt/libtabe/|}
+DISTNAME= libtabe_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Unified library for Chinese text processing
-BROKEN= Unfetchable
USES= gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -23,20 +23,16 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include/tabe \
--with-db-inc=${BDB_INCLUDE_DIR} \
--with-db-lib=${BDB_LIB_DIR} \
--with-db-bin=${LOCALBASE}/bin
+WRKSRC= ${WRKDIR}/${DISTNAME:S|_|-|}
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_SUB= X11
+X11_USE= XORG=x11
+X11_CONFIGURE_WITH= x
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MX11}
-USE_XORG= x11
-PLIST_SUB+= X11=""
-.else
-CONFIGURE_ARGS+= --without-x
-PLIST_SUB+= X11="@comment "
-.endif
-
pre-everything::
.if defined(WITH_BDB_VER)
pre-everything::
@@ -50,15 +46,18 @@ pre-everything::
post-patch:
.if !${PORT_OPTIONS:MX11}
- ${REINPLACE_CMD} -e '/all:/s/ bims//; /bims/d' ${WRKSRC}/src/Makefile.in
+ ${REINPLACE_CMD} -e '/all:/s/ bims//; /bims/d' \
+ ${WRKSRC}/src/Makefile.in
.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/tsi-src/README ${STAGEDIR}${DOCSDIR}/README.tsi
+ ${INSTALL_DATA} ${WRKSRC}/tsi-src/README \
+ ${STAGEDIR}${DOCSDIR}/README.tsi
.if ${PORT_OPTIONS:MX11}
- ${INSTALL_DATA} ${WRKSRC}/src/supports/bims/README ${STAGEDIR}${DOCSDIR}/README.bims
+ ${INSTALL_DATA} ${WRKSRC}/src/supports/bims/README \
+ ${STAGEDIR}${DOCSDIR}/README.bims
.endif
.for DOC in BoPoMoFo.shtml Changes Changes.pre-0.1 TODO ZuYinCode.txt \
et26.txt libtabe.sgml
diff --git a/chinese/libtabe/distinfo b/chinese/libtabe/distinfo
index 5002183e82aa..13c135fbe9fe 100644
--- a/chinese/libtabe/distinfo
+++ b/chinese/libtabe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libtabe-0.2.6.tar.gz) = 02b3f2e39958978dd6a1ffd95f892b7b9a087622dac409f2dbf8f325668714b6
-SIZE (libtabe-0.2.6.tar.gz) = 1788455
+SHA256 (libtabe_0.2.6.orig.tar.gz) = 7fbe0f7bb853f9385ccd14e0ce85a7b881342ecd702f1dfff6df803510e00d0c
+SIZE (libtabe_0.2.6.orig.tar.gz) = 1792199
diff --git a/chinese/libtabe/files/patch-util__tsipackdb.in b/chinese/libtabe/files/patch-util__tsipackdb.in
index b2a574cfb057..71041a5e1af3 100644
--- a/chinese/libtabe/files/patch-util__tsipackdb.in
+++ b/chinese/libtabe/files/patch-util__tsipackdb.in
@@ -1,6 +1,6 @@
---- util/tsipackdb.in.orig Sun Sep 19 22:25:51 2004
-+++ util/tsipackdb.in Fri Apr 21 23:31:23 2006
-@@ -26,14 +26,26 @@
+--- util/tsipackdb.in.orig 2004-09-28 14:59:14 UTC
++++ util/tsipackdb.in
+@@ -26,13 +26,25 @@ mywhich () {
}
pack_db_file () {
@@ -17,21 +17,20 @@
+ db_load=`mywhich db_load-${db_name}`
+ ;;
+ *)
-+ echo "unsupportted Berkyley version: ${1}"
++ echo "unsupported Berkeley version: ${1}"
+ return 1
+ esac
if [ -x "$db_dump" ] && [ -x "$db_load" ]; then
-
echo "Try using $db_dump and $db_load to pack $2 ...."
- ${1}_dump $2 > $2.tmp && \
- ${1}_load $2.new < $2.tmp && \
-+ $db_dump $2 > $2.tmp && \
-+ $db_load $2.new < $2.tmp && \
++ $db_dump $2 > $2.tmp && \
++ $db_load $2.new < $2.tmp && \
mv $2.new $2 && \
+ rm -f $2.tmp && \
return 0
-
-@@ -42,9 +54,9 @@
+@@ -41,9 +53,9 @@ pack_db_file () {
return 1
}