aboutsummaryrefslogtreecommitdiff
path: root/chinese/oicq
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-02-09 08:19:38 +0000
committerXin LI <delphij@FreeBSD.org>2007-02-09 08:19:38 +0000
commitd1cc1c719126f77fe3350d4826b2fce8576b7e9b (patch)
treed0d79cac1ad62dd007d91d86fb7020610851d55d /chinese/oicq
parentcc091d95a638cdcd4a5d9a10205362aa3e8dcb8e (diff)
downloadports-d1cc1c719126f77fe3350d4826b2fce8576b7e9b.tar.gz
ports-d1cc1c719126f77fe3350d4826b2fce8576b7e9b.zip
Re-add OICQ with updated version (1.3)
Submitted by: Ren Zhen <bg1tpt at gmail dot com>
Notes
Notes: svn path=/head/; revision=184668
Diffstat (limited to 'chinese/oicq')
-rw-r--r--chinese/oicq/Makefile37
-rw-r--r--chinese/oicq/distinfo3
-rw-r--r--chinese/oicq/files/patch-Makefile.PL20
-rw-r--r--chinese/oicq/pkg-descr5
-rw-r--r--chinese/oicq/pkg-plist12
5 files changed, 77 insertions, 0 deletions
diff --git a/chinese/oicq/Makefile b/chinese/oicq/Makefile
new file mode 100644
index 000000000000..8432ea85ee54
--- /dev/null
+++ b/chinese/oicq/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: zh-oicq
+# Date created: 10 Nov 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oicq
+PORTVERSION= 1.3
+CATEGORIES= chinese net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-oicq
+DISTNAME= Net-OICQ-${PORTVERSION}
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Implements OICQ messaging protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/Crypt/OICQ.pm:${PORTSDIR}/security/p5-Crypt-OICQ
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OICQ.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # inherits from security/p5-Crypt-OICQ
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/qq ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/demo1 ${PREFIX}/bin/qq-demo1
+
+.include <bsd.port.post.mk>
diff --git a/chinese/oicq/distinfo b/chinese/oicq/distinfo
new file mode 100644
index 000000000000..37bd035c729d
--- /dev/null
+++ b/chinese/oicq/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-OICQ-1.3.tar.gz) = 2393be26c64036643b8fa3652a173eab
+SHA256 (Net-OICQ-1.3.tar.gz) = 2b4585e35f51eaf6513d90750de5fae743dfc63ca0c606a0c72f89a29a65c6ad
+SIZE (Net-OICQ-1.3.tar.gz) = 31136
diff --git a/chinese/oicq/files/patch-Makefile.PL b/chinese/oicq/files/patch-Makefile.PL
new file mode 100644
index 000000000000..8d0143444221
--- /dev/null
+++ b/chinese/oicq/files/patch-Makefile.PL
@@ -0,0 +1,20 @@
+--- ./Makefile.PL.orig Tue Feb 6 03:22:45 2007
++++ ./Makefile.PL Fri Feb 9 15:57:13 2007
+@@ -14,7 +14,7 @@
+
+ WriteMakefile(
+ 'NAME' => 'Net::OICQ',
+- 'VERSION_FROM' => 'OICQ.pm', # finds $VERSION
++ 'VERSION_FROM' => 'lib/Net/OICQ.pm', # finds $VERSION
+ 'PREREQ_PM' => {Crypt::OICQ => 1.0,
+ Digest::MD5 => 0.1,
+ IO::Select => 0.1,
+@@ -22,7 +22,7 @@
+ Term::ReadKey => 0,
+ },
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+- (ABSTRACT_FROM => 'OICQ.pm', # retrieve abstract from module
++ (ABSTRACT_FROM => 'lib/Net/OICQ.pm', # retrieve abstract from module
+ AUTHOR => 'Shufeng Tan <shufengtan@gmail.com>') : ()),
+ 'LIBS' => [''],
+ 'DEFINE' => '',
diff --git a/chinese/oicq/pkg-descr b/chinese/oicq/pkg-descr
new file mode 100644
index 000000000000..962522387e07
--- /dev/null
+++ b/chinese/oicq/pkg-descr
@@ -0,0 +1,5 @@
+Perl-oicq provides Perl module Net::OICQ which implements OICQ messaging
+protocol. It includes a concole-only OICQ client for you to chat with tens
+of millons of OICQ users through servers operated by Tencent.
+
+WWW: http://sourceforge.net/projects/perl-oicq/
diff --git a/chinese/oicq/pkg-plist b/chinese/oicq/pkg-plist
new file mode 100644
index 000000000000..dc4f0bb7ebbc
--- /dev/null
+++ b/chinese/oicq/pkg-plist
@@ -0,0 +1,12 @@
+bin/qq
+bin/qq-demo1
+%%SITE_PERL%%/Net/OICQ.pm
+%%SITE_PERL%%/Net/OICQ/TextConsole.pm
+%%SITE_PERL%%/Net/OICQ/Event.pm
+%%SITE_PERL%%/Net/OICQ/ClientEvent.pm
+%%SITE_PERL%%/Net/OICQ/ServerEvent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/OICQ
+@dirrmtry %%SITE_PERL%%/Net