aboutsummaryrefslogtreecommitdiff
path: root/chinese/oicq
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-11-13 04:58:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-11-13 04:58:31 +0000
commitdc01a0e8497d79494bfd65ad8aa146810e689151 (patch)
treef84497d66659420e072c81910726a3fee050755e /chinese/oicq
parentf920274390fd75278fed406cf4f309c77b1917d9 (diff)
downloadports-dc01a0e8497d79494bfd65ad8aa146810e689151.tar.gz
ports-dc01a0e8497d79494bfd65ad8aa146810e689151.zip
Add oicq 0.7, implements OICQ messaging protocol.
PR: 59093 Submitted by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
Notes
Notes: svn path=/head/; revision=93858
Diffstat (limited to 'chinese/oicq')
-rw-r--r--chinese/oicq/Makefile35
-rw-r--r--chinese/oicq/distinfo1
-rw-r--r--chinese/oicq/pkg-descr5
-rw-r--r--chinese/oicq/pkg-plist11
4 files changed, 52 insertions, 0 deletions
diff --git a/chinese/oicq/Makefile b/chinese/oicq/Makefile
new file mode 100644
index 000000000000..e39e56ee0708
--- /dev/null
+++ b/chinese/oicq/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: oicq
+# Date created: 10 Nov 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oicq
+PORTVERSION= 0.7
+CATEGORIES= chinese net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-oicq
+DISTNAME= Net-OICQ-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= Implements OICQ messaging protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OICQ.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/oicq ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/chinese/oicq/distinfo b/chinese/oicq/distinfo
new file mode 100644
index 000000000000..1a94517d8c56
--- /dev/null
+++ b/chinese/oicq/distinfo
@@ -0,0 +1 @@
+MD5 (Net-OICQ-0.7.tgz) = 9c3f864171ad56e865c27b25f16bbd90
diff --git a/chinese/oicq/pkg-descr b/chinese/oicq/pkg-descr
new file mode 100644
index 000000000000..962522387e07
--- /dev/null
+++ b/chinese/oicq/pkg-descr
@@ -0,0 +1,5 @@
+Perl-oicq provides Perl module Net::OICQ which implements OICQ messaging
+protocol. It includes a concole-only OICQ client for you to chat with tens
+of millons of OICQ users through servers operated by Tencent.
+
+WWW: http://sourceforge.net/projects/perl-oicq/
diff --git a/chinese/oicq/pkg-plist b/chinese/oicq/pkg-plist
new file mode 100644
index 000000000000..80aed05e6cb0
--- /dev/null
+++ b/chinese/oicq/pkg-plist
@@ -0,0 +1,11 @@
+bin/oicq
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ/OICQ.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ/OICQ.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ/Event.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ/TextConsole.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ/ServerEvent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ/ClientEvent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OICQ
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/OICQ