aboutsummaryrefslogtreecommitdiff
path: root/chinese/pcmanx
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-05-14 18:00:14 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-05-14 18:00:14 +0000
commit205c178deae9668e6e11f3746e5d85daf2961466 (patch)
treeff858d4e6b6ae4b433dff67a19d52689d4d70941 /chinese/pcmanx
parent2fde53c27d9f2b227a21f58ed010a5b6d72bb54b (diff)
downloadports-205c178deae9668e6e11f3746e5d85daf2961466.tar.gz
ports-205c178deae9668e6e11f3746e5d85daf2961466.zip
- Update to 1.1
- Pass maintainership to submitter PR: ports/167475 Submitted by: Po-Chien Lin <linpc@cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=296591
Diffstat (limited to 'chinese/pcmanx')
-rw-r--r--chinese/pcmanx/Makefile72
-rw-r--r--chinese/pcmanx/distinfo4
-rw-r--r--chinese/pcmanx/files/patch-src-core-pcmanx_utils.h10
-rw-r--r--chinese/pcmanx/files/patch-src-core-proxy.c11
-rw-r--r--chinese/pcmanx/files/patch-src-mainframe.cpp12
-rw-r--r--chinese/pcmanx/files/patch-src-pcmanx_gtk2.cpp11
-rw-r--r--chinese/pcmanx/pkg-plist8
7 files changed, 93 insertions, 35 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index e402de7b174f..4cd1b2255a8d 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -6,29 +6,37 @@
#
PORTNAME= pcmanx
-PORTVERSION= 0.3.9
+PORTVERSION= 1.1
CATEGORIES= chinese net gnome
-MASTER_SITES= http://pcmanx-gtk2.googlecode.com/svn/website/release/
+MASTER_SITES= http://pcmanx-gtk2.googlecode.com/files/
DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= linpc@cs.nctu.edu.tw
COMMENT= BBS client using GTK+ 2.x
-USE_BZIP2= yes
+LICENSE= GPLv2
+
+USE_XZ= yes
USE_GNOME= gtk20 intlhack
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-OPTIONS= WGET "enable wget support for download articles" on
+OPTIONS= NLS "Use Native Language Support" on \
+ DEBUG "Build with debugging support" off \
+ DOCKLET "Docklet / system tray support" on \
+ NOTIFIER "Popup notifier support" on \
+ LIBNOTIFY "Popup notifier support by libnotify" off \
+ NANCY "Nancy bot support" on \
+ MOUSE "Mouse click and wheel support" on \
+ EXTERNAL "Eexternal SSH/Telnet support" on \
+ IPLOOKUP "IP location lookup support" off \
+ PROXY "Proxy support" off
-.include <bsd.port.pre.mk>
+MAN1= pcmanx.1
-.if !defined(WITHOUT_WGET)
-RUN_DEPENDS+= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
-CONFIGURE_ARGS+=--enable-wget
-.endif
+.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -40,14 +48,40 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-extract:
- @${REINPLACE_CMD} -e 's/wget/fetch/' ${WRKSRC}/po/zh_CN.po \
- ${WRKSRC}/po/zh_TW.po ${WRKSRC}/src/generalprefpage.cpp \
- ${WRKSRC}/src/view/telnetview.cpp
- @${REINPLACE_CMD} -e 's/wget -O/fetch -o/' ${WRKSRC}/src/mainframe.cpp
- @${REINPLACE_CMD} -e 's/Antiidlestr/AntiIdleStr/' \
- ${WRKSRC}/src/appconfig.cpp
- @${REINPLACE_CMD} -e '136 s/, \(.*\)/,1\);/' \
- ${WRKSRC}/src/view/telnetview.cpp
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if defined(WITHOUT_DOCKLET)
+CONFIGURE_ARGS+=--disable-docklet
+.endif
+
+.if defined(WITHOUT_NOTIFIER)
+CONFIGURE_ARGS+=--disable-notifier
+.endif
+
+.if defined(WITH_LIBNOTIFY)
+CONFIGURE_ARGS+=--enable-libnotify
+.endif
+
+.if defined(WITHOUT_NANCY)
+CONFIGURE_ARGS+=--disable-nancy
+.endif
+
+.if defined(WITHOUT_MOUSE)
+CONFIGURE_ARGS+=--disable-mouse
+.endif
+
+.if defined(WITHOUT_EXTERNAL)
+CONFIGURE_ARGS+=--disable-external
+.endif
+
+.if defined(WITH_IPLOOKUP)
+CONFIGURE_ARGS+=--enable-iplookup
+.endif
+
+.if defined(WITH_PROXY)
+CONFIGURE_ARGS+=--enable-proxy
+.endif
.include <bsd.port.post.mk>
diff --git a/chinese/pcmanx/distinfo b/chinese/pcmanx/distinfo
index 90728d44a512..b674ec9b76e1 100644
--- a/chinese/pcmanx/distinfo
+++ b/chinese/pcmanx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pcmanx-gtk2-0.3.9.tar.bz2) = 774fb06b48ac773243ce57b87eba4429f4cb05ef1febb87ee489ea6d7c3937b3
-SIZE (pcmanx-gtk2-0.3.9.tar.bz2) = 485014
+SHA256 (pcmanx-gtk2-1.1.tar.xz) = 377cccdd9e71ffbe434016f7ed93d8b82771f33398ce6804a0bf5926d2a4acd0
+SIZE (pcmanx-gtk2-1.1.tar.xz) = 527164
diff --git a/chinese/pcmanx/files/patch-src-core-pcmanx_utils.h b/chinese/pcmanx/files/patch-src-core-pcmanx_utils.h
deleted file mode 100644
index 8425578631d4..000000000000
--- a/chinese/pcmanx/files/patch-src-core-pcmanx_utils.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/core/pcmanx_utils.h.orig 2010-10-12 21:10:55.000000000 +0800
-+++ src/core/pcmanx_utils.h 2010-10-12 21:11:00.000000000 +0800
-@@ -5,7 +5,6 @@
- #include <config.h>
- #endif
-
--#include <bits/wordsize.h>
- #if __WORDSIZE == 64
- typedef unsigned long int word_t;
- #else
diff --git a/chinese/pcmanx/files/patch-src-core-proxy.c b/chinese/pcmanx/files/patch-src-core-proxy.c
new file mode 100644
index 000000000000..4995e22d8ef1
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-core-proxy.c
@@ -0,0 +1,11 @@
+--- src/core/proxy.c.orig 2011-12-28 19:59:03.000000000 +0800
++++ src/core/proxy.c 2012-05-01 10:42:46.000000000 +0800
+@@ -23,6 +23,8 @@
+ #include <unistd.h>
+ #include <errno.h>
+
++#include <sys/socket.h>
++
+ #include "proxy.h"
+
+ #define SOCKS_CMD_CONNECT 0x01
diff --git a/chinese/pcmanx/files/patch-src-mainframe.cpp b/chinese/pcmanx/files/patch-src-mainframe.cpp
new file mode 100644
index 000000000000..c0558c79cfd3
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-mainframe.cpp
@@ -0,0 +1,12 @@
+--- src/mainframe.cpp.orig 2012-01-26 22:31:52.000000000 +0800
++++ src/mainframe.cpp 2012-05-01 11:03:06.000000000 +0800
+@@ -171,7 +171,9 @@
+ m_FavoritesMenu = NULL;
+ m_IsFlashing = false;
+ m_Mode = NORMAL_MODE;
++#ifdef USE_DOCKLET
+ m_TrayIcon = NULL;
++#endif
+
+ if (desktop != NULL && strcmp("Unity", desktop) == 0) {
+ m_Unity = true;
diff --git a/chinese/pcmanx/files/patch-src-pcmanx_gtk2.cpp b/chinese/pcmanx/files/patch-src-pcmanx_gtk2.cpp
new file mode 100644
index 000000000000..3af9ae50bdba
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-pcmanx_gtk2.cpp
@@ -0,0 +1,11 @@
+--- src/pcmanx_gtk2.cpp.orig 2012-01-26 22:31:52.000000000 +0800
++++ src/pcmanx_gtk2.cpp 2012-05-01 00:36:00.000000000 +0800
+@@ -35,6 +35,8 @@
+ #include <cstring>
+ #include <ltdl.h>
+
++#include <libintl.h>
++
+ #include "mainframe.h"
+ #include "appconfig.h"
+ #include "telnetcon.h"
diff --git a/chinese/pcmanx/pkg-plist b/chinese/pcmanx/pkg-plist
index 8c8ada00c24a..8265be28b982 100644
--- a/chinese/pcmanx/pkg-plist
+++ b/chinese/pcmanx/pkg-plist
@@ -1,9 +1,6 @@
bin/pcmanx
-lib/libpcmanx_core.la
-lib/libpcmanx_core.so
-lib/libpcmanx_core.so.3
share/applications/pcmanx.desktop
-share/pixmaps/pcmanx.png
+share/pixmaps/pcmanx.svg
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pcmanx.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pcmanx.mo
%%DATADIR%%/emoticons
@@ -18,3 +15,6 @@ share/pixmaps/pcmanx.png
@dirrmtry %%DATADIR%%/nancy_bot
@dirrmtry %%DATADIR%%
@dirrmtry share/applications
+@dirrmtry %%JAVAJARDIR%%
+@exec mkdir -p %D/%%DATADIR%%/script
+@exec mkdir -p %D/%%JAVAJARDIR%%