aboutsummaryrefslogtreecommitdiff
path: root/chinese/pcmanx
diff options
context:
space:
mode:
authorPo-Chien Lin <pclin@FreeBSD.org>2013-02-23 07:21:57 +0000
committerPo-Chien Lin <pclin@FreeBSD.org>2013-02-23 07:21:57 +0000
commitc417b6f10d59733f3984b0ab4bb24f1850fb663a (patch)
treef0212e4be80374cec60f46c597a6411daa6d4a4e /chinese/pcmanx
parent53bda2f119c78e6581ed771eac5737d725a87155 (diff)
downloadports-c417b6f10d59733f3984b0ab4bb24f1850fb663a.tar.gz
ports-c417b6f10d59733f3984b0ab4bb24f1850fb663a.zip
- Update to 1.2
- Remove unused USE_LDCONFIG knob Approved by: swills (mentor)
Notes
Notes: svn path=/head/; revision=312799
Diffstat (limited to 'chinese/pcmanx')
-rw-r--r--chinese/pcmanx/Makefile10
-rw-r--r--chinese/pcmanx/distinfo4
-rw-r--r--chinese/pcmanx/files/patch-configure10
-rw-r--r--chinese/pcmanx/files/patch-src-core-proxy.c9
-rw-r--r--chinese/pcmanx/files/patch-src-mainframe.cpp12
-rw-r--r--chinese/pcmanx/files/patch-src-view-telnetcon.cpp2
-rw-r--r--chinese/pcmanx/pkg-plist5
7 files changed, 25 insertions, 27 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index bf61c2884f2b..78d2267d386d 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pcmanx
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= chinese net gnome
MASTER_SITES= http://pcmanx-gtk2.googlecode.com/files/
DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
@@ -18,7 +17,6 @@ USE_GNOME= gtk20 intlhack
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
OPTIONS_DEFINE= NLS DEBUG DOCKLET NOTIFIER LIBNOTIFY NANCY MOUSE EXTERNAL IPLOOKUP PROXY
OPTIONS_DEFAULT= DOCKLET NOTIFIER NANCY MOUSE EXTERNAL
@@ -60,7 +58,7 @@ CONFIGURE_ARGS+=--disable-notifier
.if ${PORT_OPTIONS:MLIBNOTIFY}
CONFIGURE_ARGS+=--enable-libnotify
-BUILD_DEPENDS= libnotify>0:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
.endif
.if empty(PORT_OPTIONS:MNANCY)
@@ -83,4 +81,8 @@ CONFIGURE_ARGS+=--enable-iplookup
CONFIGURE_ARGS+=--enable-proxy
.endif
+post-install:
+ @# create directory for user friendly
+ ${MKDIR} ${DATADIR}/script/
+
.include <bsd.port.mk>
diff --git a/chinese/pcmanx/distinfo b/chinese/pcmanx/distinfo
index b674ec9b76e1..1c4c0e70d9e7 100644
--- a/chinese/pcmanx/distinfo
+++ b/chinese/pcmanx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pcmanx-gtk2-1.1.tar.xz) = 377cccdd9e71ffbe434016f7ed93d8b82771f33398ce6804a0bf5926d2a4acd0
-SIZE (pcmanx-gtk2-1.1.tar.xz) = 527164
+SHA256 (pcmanx-gtk2-1.2.tar.xz) = 2463652d9b75ba1bea7420069e28d66f6e8064cfcfea2a697f06c1d491ec774a
+SIZE (pcmanx-gtk2-1.2.tar.xz) = 534684
diff --git a/chinese/pcmanx/files/patch-configure b/chinese/pcmanx/files/patch-configure
new file mode 100644
index 000000000000..f7e8e6275de7
--- /dev/null
+++ b/chinese/pcmanx/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2013-02-23 12:34:26.239318500 +0800
++++ configure 2013-02-23 12:34:47.839542597 +0800
+@@ -17189,7 +17189,6 @@
+
+ fi
+ fi
+- USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/chinese/pcmanx/files/patch-src-core-proxy.c b/chinese/pcmanx/files/patch-src-core-proxy.c
index 4995e22d8ef1..55aaa130f7b8 100644
--- a/chinese/pcmanx/files/patch-src-core-proxy.c
+++ b/chinese/pcmanx/files/patch-src-core-proxy.c
@@ -1,11 +1,12 @@
--- src/core/proxy.c.orig 2011-12-28 19:59:03.000000000 +0800
+++ src/core/proxy.c 2012-05-01 10:42:46.000000000 +0800
-@@ -23,6 +23,8 @@
+@@ -22,6 +22,9 @@
+ #include <string.h>
#include <unistd.h>
#include <errno.h>
-
++#if defined(__FreeBSD__)
+#include <sys/socket.h>
-+
++#endif
+
#include "proxy.h"
- #define SOCKS_CMD_CONNECT 0x01
diff --git a/chinese/pcmanx/files/patch-src-mainframe.cpp b/chinese/pcmanx/files/patch-src-mainframe.cpp
deleted file mode 100644
index c0558c79cfd3..000000000000
--- a/chinese/pcmanx/files/patch-src-mainframe.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/mainframe.cpp.orig 2012-01-26 22:31:52.000000000 +0800
-+++ src/mainframe.cpp 2012-05-01 11:03:06.000000000 +0800
-@@ -171,7 +171,9 @@
- m_FavoritesMenu = NULL;
- m_IsFlashing = false;
- m_Mode = NORMAL_MODE;
-+#ifdef USE_DOCKLET
- m_TrayIcon = NULL;
-+#endif
-
- if (desktop != NULL && strcmp("Unity", desktop) == 0) {
- m_Unity = true;
diff --git a/chinese/pcmanx/files/patch-src-view-telnetcon.cpp b/chinese/pcmanx/files/patch-src-view-telnetcon.cpp
index 09b1bdcc1c4b..4b1341645472 100644
--- a/chinese/pcmanx/files/patch-src-view-telnetcon.cpp
+++ b/chinese/pcmanx/files/patch-src-view-telnetcon.cpp
@@ -1,6 +1,6 @@
--- src/view/telnetcon.cpp.orig 2010-10-12 21:12:03.000000000 +0800
+++ src/view/telnetcon.cpp 2010-10-12 21:12:09.000000000 +0800
-@@ -72,7 +72,6 @@
+@@ -77,7 +77,6 @@
#ifdef USING_LINUX
#include <pty.h>
#endif
diff --git a/chinese/pcmanx/pkg-plist b/chinese/pcmanx/pkg-plist
index 8265be28b982..6dc2a80fa8f9 100644
--- a/chinese/pcmanx/pkg-plist
+++ b/chinese/pcmanx/pkg-plist
@@ -11,10 +11,7 @@ share/pixmaps/pcmanx.svg
%%DATADIR%%/nancy_bot/example_msg.data
%%DATADIR%%/nancy_bot/example_usages.data
%%DATADIR%%/sitelist
-@dirrmtry %%DATADIR%%/script
@dirrmtry %%DATADIR%%/nancy_bot
+@dirrmtry %%DATADIR%%/script
@dirrmtry %%DATADIR%%
@dirrmtry share/applications
-@dirrmtry %%JAVAJARDIR%%
-@exec mkdir -p %D/%%DATADIR%%/script
-@exec mkdir -p %D/%%JAVAJARDIR%%