aboutsummaryrefslogtreecommitdiff
path: root/chinese/qterm
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-12-15 05:46:24 +0000
committerClive Lin <clive@FreeBSD.org>2004-12-15 05:46:24 +0000
commita2605b3968a7a88e02d840a260fc33a9e6d06bf9 (patch)
tree6b018568fcbaaa20741420956873ae929de6f067 /chinese/qterm
parent650b669bd2cd479cdd03ed8a527e2be6d0efa60f (diff)
downloadports-a2605b3968a7a88e02d840a260fc33a9e6d06bf9.tar.gz
ports-a2605b3968a7a88e02d840a260fc33a9e6d06bf9.zip
Notes
Diffstat (limited to 'chinese/qterm')
-rw-r--r--chinese/qterm/Makefile17
-rw-r--r--chinese/qterm/distinfo4
-rw-r--r--chinese/qterm/files/patch-qterm_qtermiplocation.cpp18
-rw-r--r--chinese/qterm/pkg-message6
4 files changed, 33 insertions, 12 deletions
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index 54345c24ff6a..0febdd03525a 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= qterm
-PORTVERSION= 0.4.0.p1
+PORTVERSION= 0.4.0.p2
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-0.4.0pre1
+DISTNAME= ${PORTNAME}-0.4.0pre2
MAINTAINER= gavin@FreeBSDChina.org
COMMENT= QTerm is a BBS client in Unix
@@ -22,16 +22,10 @@ CONFIGURE_ARGS= --enable-mt --prefix=${PREFIX} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
.if !defined(WITHOUT_PYTHON)
-USE_PYTHON= -2.3
+USE_PYTHON= 2.3+
CONFIGURE_ARGS+= --with-pythondir=${LOCALBASE}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000 && ${ARCH} != "i386"
-BROKEN= "Does not compile on FreeBSD >= 6.x on !i386"
-.endif
-
pre-everything::
.if !defined(WITHOUT_PYTHON)
@${ECHO_MSG} "Define WITHOUT_PYTHON to disable Python scripts support."
@@ -41,4 +35,7 @@ post-patch:
@${REINPLACE_CMD} -e 's,-lssl,-lssl -lcrypto,' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/chinese/qterm/distinfo b/chinese/qterm/distinfo
index 2bcce0272101..07a4711d9e38 100644
--- a/chinese/qterm/distinfo
+++ b/chinese/qterm/distinfo
@@ -1,2 +1,2 @@
-MD5 (qterm-0.4.0pre1.tar.gz) = dbd80ec692e4603f7775ffbdb1d52bff
-SIZE (qterm-0.4.0pre1.tar.gz) = 1077778
+MD5 (qterm-0.4.0pre2.tar.gz) = 379a5932ee282bedcfa70d3f16e3e91e
+SIZE (qterm-0.4.0pre2.tar.gz) = 895907
diff --git a/chinese/qterm/files/patch-qterm_qtermiplocation.cpp b/chinese/qterm/files/patch-qterm_qtermiplocation.cpp
new file mode 100644
index 000000000000..8b98e0d9e56a
--- /dev/null
+++ b/chinese/qterm/files/patch-qterm_qtermiplocation.cpp
@@ -0,0 +1,18 @@
+--- qterm/qtermiplocation.cpp.orig Tue Dec 14 18:45:37 2004
++++ qterm/qtermiplocation.cpp Tue Dec 14 18:46:21 2004
+@@ -79,13 +79,13 @@
+ if( fseek( fp, (long)offset, SEEK_SET ) ==-1 )
+ {
+ qDebug( " readLineFrom error 1 " );
+- ret_str = QCString(NULL);
++ ret_str = QCString();
+ return -1;
+ }
+ if( fgets( (char *) str, 512, fp ) == NULL )
+ {
+ qDebug( " readLineFrom error 2 " );
+- ret_str = QCString(NULL);
++ ret_str = QCString();
+ return -1;
+ }
+ ret_str = str;
diff --git a/chinese/qterm/pkg-message b/chinese/qterm/pkg-message
new file mode 100644
index 000000000000..d899cb265257
--- /dev/null
+++ b/chinese/qterm/pkg-message
@@ -0,0 +1,6 @@
+*************************************************************************
+ You can't modify the SITE definition until setting
+QTerm's config file privilege in your ~/.qterm directory to 0755 at least
+ To display IP location when using QTerm
+you must get file "QQWry.dat" and put it into your ~/.qterm directory
+*************************************************************************