aboutsummaryrefslogtreecommitdiff
path: root/chinese/rime-combo-pinyin
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 15:47:09 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 15:47:09 +0000
commit401b2fdc9e1872a08fabcbac4efa9c4b0392ece6 (patch)
treefd5ceb2a6f78097bb1137f01c4fbd5bbf6222a24 /chinese/rime-combo-pinyin
parent5252e4c5ba0a615bc24638998e078e04e93be857 (diff)
downloadports-401b2fdc9e1872a08fabcbac4efa9c4b0392ece6.tar.gz
ports-401b2fdc9e1872a08fabcbac4efa9c4b0392ece6.zip
new ports: chinese/rime-*: Add all schemas for RIME framework
This adds the following new schemas: - chinese/rime-array - chinese/rime-combo-pinyin - chinese/rime-double-pinyin - chinese/rime-emoji - chinese/rime-ipa - chinese/rime-jyutping - chinese/rime-middle-pinyin - chinese/rime-pinyin-simp - chinese/rime-quick - chinese/rime-scj - chinese/rime-soutzoe - chinese/rime-stenotype - chinese/rime-wubi - chinese/rime-wugniu The following metaport has been added: - chinese/rime-data-full Users can install the metaport to immediately get a full bundle of schemas available in upstream RIME. Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27739
Notes
Notes: svn path=/head/; revision=559589
Diffstat (limited to 'chinese/rime-combo-pinyin')
-rw-r--r--chinese/rime-combo-pinyin/Makefile63
-rw-r--r--chinese/rime-combo-pinyin/distinfo3
-rw-r--r--chinese/rime-combo-pinyin/pkg-descr3
-rw-r--r--chinese/rime-combo-pinyin/pkg-plist10
4 files changed, 79 insertions, 0 deletions
diff --git a/chinese/rime-combo-pinyin/Makefile b/chinese/rime-combo-pinyin/Makefile
new file mode 100644
index 000000000000..402a6186b7f0
--- /dev/null
+++ b/chinese/rime-combo-pinyin/Makefile
@@ -0,0 +1,63 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-combo-pinyin
+DISTVERSION= g20201204
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Combo Pinyin schema support
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude \
+ zh-rime-luna-pinyin>g0:chinese/rime-luna-pinyin
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude \
+ zh-rime-luna-pinyin>g0:chinese/rime-luna-pinyin
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 5300951b8de07252d7565fefe84f5fae50205564
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+LUNA_PINYIN_FILES= luna_pinyin.dict.yaml
+SCHEMA_FILES= combo_pinyin.schema.yaml combo_pinyin_kbcon.schema.yaml \
+ combo_pinyin_left.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES} ${LUNA_PINYIN_FILES}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data/build
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${MY_OUTDIR}/build/combo_pinyin* \
+ ${STAGEDIR}${PREFIX}/share/rime-data/build
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-combo-pinyin/distinfo b/chinese/rime-combo-pinyin/distinfo
new file mode 100644
index 000000000000..174ed72111df
--- /dev/null
+++ b/chinese/rime-combo-pinyin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608708086
+SHA256 (rime-rime-combo-pinyin-g20201204-5300951b8de07252d7565fefe84f5fae50205564_GH0.tar.gz) = 6eb8f61f5300891a39385f3c8126230b6779456f6c92be577166a0d049638182
+SIZE (rime-rime-combo-pinyin-g20201204-5300951b8de07252d7565fefe84f5fae50205564_GH0.tar.gz) = 17753
diff --git a/chinese/rime-combo-pinyin/pkg-descr b/chinese/rime-combo-pinyin/pkg-descr
new file mode 100644
index 000000000000..6ed14b3274db
--- /dev/null
+++ b/chinese/rime-combo-pinyin/pkg-descr
@@ -0,0 +1,3 @@
+Rime Combo Pinyin schema for Mandarin input support.
+
+WWW: https://github.com/rime/rime-combo-pinyin
diff --git a/chinese/rime-combo-pinyin/pkg-plist b/chinese/rime-combo-pinyin/pkg-plist
new file mode 100644
index 000000000000..7bb411edba15
--- /dev/null
+++ b/chinese/rime-combo-pinyin/pkg-plist
@@ -0,0 +1,10 @@
+share/rime-data/build/combo_pinyin.prism.bin
+share/rime-data/build/combo_pinyin.schema.yaml
+share/rime-data/build/combo_pinyin_kbcon.prism.bin
+share/rime-data/build/combo_pinyin_kbcon.schema.yaml
+share/rime-data/build/combo_pinyin_left.prism.bin
+share/rime-data/build/combo_pinyin_left.schema.yaml
+share/rime-data/combo_pinyin.schema.yaml
+share/rime-data/combo_pinyin_kbcon.options.yaml
+share/rime-data/combo_pinyin_kbcon.schema.yaml
+share/rime-data/combo_pinyin_left.schema.yaml