aboutsummaryrefslogtreecommitdiff
path: root/chinese/tin
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-21 19:53:08 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-21 19:53:08 +0000
commit230579ee9554b012d528ada59c99dd74863eed13 (patch)
tree16619b06f9799c4c17a0e8a1f3871f762b2bba86 /chinese/tin
parent652e21a8380387d0a3842956a2c5c872655ef572 (diff)
downloadports-230579ee9554b012d528ada59c99dd74863eed13.tar.gz
ports-230579ee9554b012d528ada59c99dd74863eed13.zip
Regenerate a few patches to unbreak after the news/tin update in r406242.
Notes
Notes: svn path=/head/; revision=409309
Diffstat (limited to 'chinese/tin')
-rw-r--r--chinese/tin/Makefile2
-rw-r--r--chinese/tin/files/patch-attrib.c6
-rw-r--r--chinese/tin/files/patch-cook.c8
3 files changed, 7 insertions, 9 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index e16bce243551..e702e539e12b 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -7,8 +7,6 @@ CATEGORIES= chinese
MAINTAINER= ports@FreeBSD.org
-BROKEN= fails to patch
-
EXTRA_PATCHES= ${.CURDIR}/files/patch-attrib.c \
${.CURDIR}/files/patch-cook.c \
${.CURDIR}/files/patch-mail.c \
diff --git a/chinese/tin/files/patch-attrib.c b/chinese/tin/files/patch-attrib.c
index 43e57008d4e9..aeb8b3e27145 100644
--- a/chinese/tin/files/patch-attrib.c
+++ b/chinese/tin/files/patch-attrib.c
@@ -1,6 +1,6 @@
---- src/attrib.c.orig 2014-07-16 00:41:51.940655746 +0800
-+++ src/attrib.c 2014-07-16 00:43:36.205651630 +0800
-@@ -583,6 +583,9 @@
+--- src/attrib.c.orig 2015-11-22 01:14:29.000000000 +0100
++++ src/attrib.c 2016-02-21 20:49:48.322143000 +0100
+@@ -593,6 +593,9 @@
add_scope("*");
snprintf(buf, sizeof(buf), "%s", "~/.tin/headers");
set_attrib(OPT_ATTRIB_X_HEADERS, "*", "", buf);
diff --git a/chinese/tin/files/patch-cook.c b/chinese/tin/files/patch-cook.c
index d105d27ba897..703092bb90ed 100644
--- a/chinese/tin/files/patch-cook.c
+++ b/chinese/tin/files/patch-cook.c
@@ -1,11 +1,11 @@
---- src/cook.c.orig 2014-07-16 00:43:47.656653653 +0800
-+++ src/cook.c 2014-07-16 00:47:26.498655673 +0800
-@@ -471,7 +471,12 @@
+--- src/cook.c.orig 2015-12-23 19:42:27.000000000 +0100
++++ src/cook.c 2016-02-21 20:50:33.672278000 +0100
+@@ -470,7 +470,12 @@
/* convert network to local charset, tex2iso, iso2asc etc. */
ncharset = get_param(part->params, "charset");
+#ifndef CHARSET_CONVERSION
- process_charsets(&line, &max_line_len, ncharset ? ncharset : "US-ASCII" , tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+ process_charsets(&line, &max_line_len, ncharset ? ncharset : "US-ASCII", tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+#else
+ /* use undeclared charset */
+ process_charsets(&line, &max_line_len, get_param(part->params, "charset") ? get_param(part->params, "charset") : curr_group->attribute->undeclared_charset, tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);