aboutsummaryrefslogtreecommitdiff
path: root/chinese/tin
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2014-07-15 17:28:52 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2014-07-15 17:28:52 +0000
commit3ee60a37282fc09f80aa4d0378bec95ee963ff8d (patch)
tree1bd7beb9034feed797ab3739dfae0d4814feeaea /chinese/tin
parent85bd011bc71ca46407a2a4d95feca3613d282b35 (diff)
downloadports-3ee60a37282fc09f80aa4d0378bec95ee963ff8d.tar.gz
ports-3ee60a37282fc09f80aa4d0378bec95ee963ff8d.zip
- Unbreak
Notes
Notes: svn path=/head/; revision=361985
Diffstat (limited to 'chinese/tin')
-rw-r--r--chinese/tin/Makefile2
-rw-r--r--chinese/tin/files/patch-attrib.c6
-rw-r--r--chinese/tin/files/patch-cook.c10
-rw-r--r--chinese/tin/files/patch-init.c6
-rw-r--r--chinese/tin/files/patch-mail.c7
5 files changed, 14 insertions, 17 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index d8fd136a4770..e702e539e12b 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -7,8 +7,6 @@ CATEGORIES= chinese
MAINTAINER= ports@FreeBSD.org
-BROKEN= Fails to patch
-
EXTRA_PATCHES= ${.CURDIR}/files/patch-attrib.c \
${.CURDIR}/files/patch-cook.c \
${.CURDIR}/files/patch-mail.c \
diff --git a/chinese/tin/files/patch-attrib.c b/chinese/tin/files/patch-attrib.c
index d179ff4f16a3..43e57008d4e9 100644
--- a/chinese/tin/files/patch-attrib.c
+++ b/chinese/tin/files/patch-attrib.c
@@ -1,6 +1,6 @@
---- src/attrib.c.orig 2011-09-18 04:55:30.000000000 -0700
-+++ src/attrib.c 2012-01-02 03:14:00.000000000 -0800
-@@ -548,6 +548,9 @@
+--- src/attrib.c.orig 2014-07-16 00:41:51.940655746 +0800
++++ src/attrib.c 2014-07-16 00:43:36.205651630 +0800
+@@ -583,6 +583,9 @@
add_scope("*");
snprintf(buf, sizeof(buf), "%s", "~/.tin/headers");
set_attrib(OPT_ATTRIB_X_HEADERS, "*", "", buf);
diff --git a/chinese/tin/files/patch-cook.c b/chinese/tin/files/patch-cook.c
index a8916bf1b63e..d105d27ba897 100644
--- a/chinese/tin/files/patch-cook.c
+++ b/chinese/tin/files/patch-cook.c
@@ -1,11 +1,11 @@
---- src/cook.c.orig 2011-08-18 03:58:24.288554846 +0800
-+++ src/cook.c 2011-08-18 13:36:23.791151539 +0800
-@@ -472,7 +472,12 @@
- break; /* premature end of file, file error etc. */
+--- src/cook.c.orig 2014-07-16 00:43:47.656653653 +0800
++++ src/cook.c 2014-07-16 00:47:26.498655673 +0800
+@@ -471,7 +471,12 @@
/* convert network to local charset, tex2iso, iso2asc etc. */
+ ncharset = get_param(part->params, "charset");
+#ifndef CHARSET_CONVERSION
- process_charsets(&line, &max_line_len, get_param(part->params, "charset"), tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+ process_charsets(&line, &max_line_len, ncharset ? ncharset : "US-ASCII" , tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
+#else
+ /* use undeclared charset */
+ process_charsets(&line, &max_line_len, get_param(part->params, "charset") ? get_param(part->params, "charset") : curr_group->attribute->undeclared_charset, tinrc.mm_local_charset, curr_group->attribute->tex2iso_conv && art->tex2iso);
diff --git a/chinese/tin/files/patch-init.c b/chinese/tin/files/patch-init.c
index ef36fa3aafec..33a648e340ea 100644
--- a/chinese/tin/files/patch-init.c
+++ b/chinese/tin/files/patch-init.c
@@ -1,6 +1,6 @@
---- src/init.c.orig 2011-08-18 12:58:08.564585495 +0800
-+++ src/init.c 2011-08-18 12:58:30.264685035 +0800
-@@ -354,11 +354,11 @@
+--- src/init.c.orig 2014-07-16 00:47:37.352661040 +0800
++++ src/init.c 2014-07-16 00:48:08.424652944 +0800
+@@ -361,11 +361,11 @@
#endif /* USE_INVERSE_HACK */
TRUE, /* keep_dead_articles */
POSTED_FILE, /* posted_articles_file */
diff --git a/chinese/tin/files/patch-mail.c b/chinese/tin/files/patch-mail.c
index 11b01f140cea..cc7884cdd68b 100644
--- a/chinese/tin/files/patch-mail.c
+++ b/chinese/tin/files/patch-mail.c
@@ -1,6 +1,6 @@
---- src/mail.c.orig 2011-04-17 15:14:00.000000000 -0700
-+++ src/mail.c 2012-01-02 05:08:38.000000000 -0800
-@@ -510,7 +510,12 @@
+--- src/mail.c.orig 2014-07-16 00:48:14.918652518 +0800
++++ src/mail.c 2014-07-16 00:48:50.462660253 +0800
+@@ -514,7 +514,11 @@
/*
* Protect against invalid character sequences.
*/
@@ -9,7 +9,6 @@
+#else
+ process_charsets(&r, &r_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : "UTF-8", tinrc.mm_local_charset, FALSE);
+#endif
-+
group->description = convert_to_printable(r, FALSE);
}