aboutsummaryrefslogtreecommitdiff
path: root/chinese/tin
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-04-19 02:44:17 +0000
committerClive Lin <clive@FreeBSD.org>2001-04-19 02:44:17 +0000
commit84310fa3a2a44c19c999e3c76c9e79d8e5261282 (patch)
treec3d48f1372154677b3129a6a6b8ca8b4796cdbd2 /chinese/tin
parent14c317729b1fdd60a29982bb6a6a02819271fffb (diff)
downloadports-84310fa3a2a44c19c999e3c76c9e79d8e5261282.tar.gz
ports-84310fa3a2a44c19c999e3c76c9e79d8e5261282.zip
Essential line wrapping fix for embedded color assii art.
PORTREVISION bumped. PR: 26691 Submitted by: Yen-Ming Lee <leeym@bsd.ce.ntu.edu.tw> Approved by: MAINTAINER
Notes
Notes: svn path=/head/; revision=41669
Diffstat (limited to 'chinese/tin')
-rw-r--r--chinese/tin/Makefile4
-rw-r--r--chinese/tin/files/patch-page.c20
2 files changed, 23 insertions, 1 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index aaecf59f22ce..57a750d93afe 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -8,12 +8,14 @@
MASTERDIR= ${.CURDIR}/../../news/tin
+PORTREVISION= 1
MAINTAINER= yssu@CCCA.NCTU.edu.tw
EXTRA_PATCHES= ${.CURDIR}/files/patch-charset.c \
${.CURDIR}/files/patch-cook.c \
${.CURDIR}/files/patch-init.c \
- ${.CURDIR}/files/patch-misc.c
+ ${.CURDIR}/files/patch-misc.c \
+ ${.CURDIR}/files/patch-page.c
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/tin/files/patch-page.c b/chinese/tin/files/patch-page.c
new file mode 100644
index 000000000000..10a7573c152f
--- /dev/null
+++ b/chinese/tin/files/patch-page.c
@@ -0,0 +1,20 @@
+--- src/page.c.orig Wed Feb 21 03:18:52 2001
++++ src/page.c Thu Apr 19 09:35:25 2001
+@@ -867,7 +867,7 @@
+ curr = &artline[curr_line+i];
+ fseek (note_fp, curr->offset, SEEK_SET);
+
+- fgets (buff, cCOLS+1, note_fp);
++ fgets (buff, MAXPATHLEN, note_fp);
+
+ /*
+ * rotN encoding on body and sig data only
+@@ -1186,7 +1186,7 @@
+
+ make_group_path (CURR_GROUP.name, group_path);
+
+- switch (art_open (TRUE, &arts[new_respnum], group_path, &pgart)) {
++ switch (art_open (FALSE, &arts[new_respnum], group_path, &pgart)) {
+
+ case ART_UNAVAILABLE:
+ art_mark_read (&CURR_GROUP, &arts[new_respnum]);