aboutsummaryrefslogtreecommitdiff
path: root/chinese/ttfm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /chinese/ttfm
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'chinese/ttfm')
-rw-r--r--chinese/ttfm/Makefile.ttf12
1 files changed, 6 insertions, 6 deletions
diff --git a/chinese/ttfm/Makefile.ttf b/chinese/ttfm/Makefile.ttf
index 47b0c0711231..efaaf2829efc 100644
--- a/chinese/ttfm/Makefile.ttf
+++ b/chinese/ttfm/Makefile.ttf
@@ -16,12 +16,12 @@ FONTSDIR?= ${PREFIX}/share/fonts/TrueType
FONTSDIR_REL= ${FONTSDIR:S,^${PREFIX}/,,}
PLIST_SUB+= FONTSDIR=${FONTSDIR_REL}
-XFONTSDIR?= ${X11BASE}/lib/X11/fonts/TrueType
-XFONTSDIR_REL= ${XFONTSDIR:S,${X11BASE}/,,}
+XFONTSDIR?= ${LOCALBASE}/lib/X11/fonts/TrueType
+XFONTSDIR_REL= ${XFONTSDIR:S,${LOCALBASE}/,,}
PLIST_SUB+= XFONTSDIR=${XFONTSDIR_REL}
.if !defined(WITHOUT_X11)
-RUN_DEPENDS+= ${X11BASE}/bin/fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS+= ${LOCALBASE}/bin/fc-cache:${PORTSDIR}/x11-fonts/fontconfig
_TTF_MODULES= xttfm
.endif
@@ -62,7 +62,7 @@ do-install-ttf:
.endfor
.if !defined(WITHOUT_X11)
@${ECHO_MSG} "===> Running fc-cache"
- -@${X11BASE}/bin/fc-cache -f -v ${XFONTSDIR}
+ -@${LOCALBASE}/bin/fc-cache -f -v ${XFONTSDIR}
.endif
add-plist-post: add-plist-ttf
@@ -81,8 +81,8 @@ add-plist-ttf:
. endfor
.endfor
.if !defined(WITHOUT_X11)
- @${ECHO_CMD} "@unexec ${X11BASE}/bin/fc-cache -f -v ${XFONTSDIR} || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${X11BASE}/bin/fc-cache -f -v ${XFONTSDIR} || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${LOCALBASE}/bin/fc-cache -f -v ${XFONTSDIR} || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${LOCALBASE}/bin/fc-cache -f -v ${XFONTSDIR} || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec find ${XFONTSDIR} -size -3c -delete || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir ${XFONTSDIR} 2>/dev/null || true" >> ${TMPPLIST}
.endif