aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-17 10:47:28 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-12-17 10:47:28 +0000
commit5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b (patch)
tree54faa7db045057bbb39ef2ba59dab48084f173c3 /chinese
parent0d56e935721190a97decfe2077ab142269c09fe8 (diff)
downloadports-5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b.tar.gz
ports-5b269d5e9683e49bde94fc6fa9d0e3500fa3cd8b.zip
Add chinese/rime-data and its dependencies
A new metaport that provides an essential set of configuration ports and a preset of IME schema ports for the Rime IME framework. This is a metaport which depends on the following essential ports: chinese/rime-essay chinese/rime-prelude This also depends on the following ports to form a preset of IME schemas available: chinese/rime-stroke chinese/rime-cangjie chinese/rime-bopomofo chinese/rime-luna-pinyin chinese/rime-terra-pinyin Besides the above essential + preset IME schema ports, chinese/rime-cantonese is also added as a IME schema port for Cantonese users. Submitted by: Ka Ho Ng <khng300@gmail.com> Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27652
Notes
Notes: svn path=/head/; revision=558280
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile9
-rw-r--r--chinese/rime-bopomofo/Makefile66
-rw-r--r--chinese/rime-bopomofo/distinfo3
-rw-r--r--chinese/rime-bopomofo/pkg-descr3
-rw-r--r--chinese/rime-bopomofo/pkg-plist12
-rw-r--r--chinese/rime-cangjie/Makefile57
-rw-r--r--chinese/rime-cangjie/distinfo3
-rw-r--r--chinese/rime-cangjie/pkg-descr3
-rw-r--r--chinese/rime-cangjie/pkg-plist10
-rw-r--r--chinese/rime-cantonese/Makefile67
-rw-r--r--chinese/rime-cantonese/distinfo3
-rw-r--r--chinese/rime-cantonese/pkg-descr3
-rw-r--r--chinese/rime-cantonese/pkg-plist18
-rw-r--r--chinese/rime-data/Makefile21
-rw-r--r--chinese/rime-data/pkg-descr5
-rw-r--r--chinese/rime-essay/Makefile37
-rw-r--r--chinese/rime-essay/distinfo3
-rw-r--r--chinese/rime-essay/pkg-descr3
-rw-r--r--chinese/rime-luna-pinyin/Makefile62
-rw-r--r--chinese/rime-luna-pinyin/distinfo3
-rw-r--r--chinese/rime-luna-pinyin/pkg-descr3
-rw-r--r--chinese/rime-luna-pinyin/pkg-plist24
-rw-r--r--chinese/rime-prelude/Makefile44
-rw-r--r--chinese/rime-prelude/distinfo3
-rw-r--r--chinese/rime-prelude/pkg-descr3
-rw-r--r--chinese/rime-stroke/Makefile58
-rw-r--r--chinese/rime-stroke/distinfo3
-rw-r--r--chinese/rime-stroke/pkg-descr3
-rw-r--r--chinese/rime-stroke/pkg-plist7
-rw-r--r--chinese/rime-terra-pinyin/Makefile58
-rw-r--r--chinese/rime-terra-pinyin/distinfo3
-rw-r--r--chinese/rime-terra-pinyin/pkg-descr3
-rw-r--r--chinese/rime-terra-pinyin/pkg-plist8
33 files changed, 611 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index b02172b89881..99f1a97c2ee2 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -92,6 +92,15 @@
SUBDIR += pycangjie
SUBDIR += pyzy
SUBDIR += qe
+ SUBDIR += rime-bopomofo
+ SUBDIR += rime-cangjie
+ SUBDIR += rime-cantonese
+ SUBDIR += rime-data
+ SUBDIR += rime-essay
+ SUBDIR += rime-luna-pinyin
+ SUBDIR += rime-prelude
+ SUBDIR += rime-stroke
+ SUBDIR += rime-terra-pinyin
SUBDIR += scim-fcitx
SUBDIR += scim-pinyin
SUBDIR += scim-tables
diff --git a/chinese/rime-bopomofo/Makefile b/chinese/rime-bopomofo/Makefile
new file mode 100644
index 000000000000..c1460a1ee8ad
--- /dev/null
+++ b/chinese/rime-bopomofo/Makefile
@@ -0,0 +1,66 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-bopomofo
+DISTVERSION= g20190120
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Chewing schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= \
+ rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude \
+ zh-rime-terra-pinyin>g0:chinese/rime-terra-pinyin
+RUN_DEPENDS= \
+ zh-rime-prelude>g0:chinese/rime-prelude \
+ zh-rime-terra-pinyin>g0:chinese/rime-terra-pinyin
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= ed25098386f5efd3d70b08650f0d1b70c41c11a3
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+TERRA_PINYIN_FILES= terra_pinyin.dict.yaml
+SCHEMA_FILES= bopomofo.schema.yaml \
+ bopomofo_express.schema.yaml \
+ bopomofo_tw.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES} ${TERRA_PINYIN_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data/build
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${MY_OUTDIR}/build/bopomofo* \
+ ${STAGEDIR}${PREFIX}/share/rime-data/build
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-bopomofo/distinfo b/chinese/rime-bopomofo/distinfo
new file mode 100644
index 000000000000..9194d314185b
--- /dev/null
+++ b/chinese/rime-bopomofo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608102657
+SHA256 (rime-rime-bopomofo-g20190120-ed25098386f5efd3d70b08650f0d1b70c41c11a3_GH0.tar.gz) = 0b2a0496cf2a291d8e4aa9bf467fd507f6674378e5951c9e2b6470cbf7edaed7
+SIZE (rime-rime-bopomofo-g20190120-ed25098386f5efd3d70b08650f0d1b70c41c11a3_GH0.tar.gz) = 5835
diff --git a/chinese/rime-bopomofo/pkg-descr b/chinese/rime-bopomofo/pkg-descr
new file mode 100644
index 000000000000..b414246df1aa
--- /dev/null
+++ b/chinese/rime-bopomofo/pkg-descr
@@ -0,0 +1,3 @@
+Rime Chewing schema for Mandarin input support.
+
+WWW: https://github.com/rime/rime-bopomofo
diff --git a/chinese/rime-bopomofo/pkg-plist b/chinese/rime-bopomofo/pkg-plist
new file mode 100644
index 000000000000..7c778a412016
--- /dev/null
+++ b/chinese/rime-bopomofo/pkg-plist
@@ -0,0 +1,12 @@
+share/rime-data/bopomofo.schema.yaml
+share/rime-data/bopomofo_express.schema.yaml
+share/rime-data/bopomofo_tw.schema.yaml
+share/rime-data/build/bopomofo.prism.bin
+share/rime-data/build/bopomofo.prism.txt
+share/rime-data/build/bopomofo.schema.yaml
+share/rime-data/build/bopomofo_express.prism.bin
+share/rime-data/build/bopomofo_express.prism.txt
+share/rime-data/build/bopomofo_express.schema.yaml
+share/rime-data/build/bopomofo_tw.prism.bin
+share/rime-data/build/bopomofo_tw.prism.txt
+share/rime-data/build/bopomofo_tw.schema.yaml
diff --git a/chinese/rime-cangjie/Makefile b/chinese/rime-cangjie/Makefile
new file mode 100644
index 000000000000..43c8249ea101
--- /dev/null
+++ b/chinese/rime-cangjie/Makefile
@@ -0,0 +1,57 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-cangjie
+DISTVERSION= g20201030
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Cangjie v5 schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= d0f6f521ec049166ada29085434126be175f6439
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= cangjie5.schema.yaml cangjie5_express.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-cangjie/distinfo b/chinese/rime-cangjie/distinfo
new file mode 100644
index 000000000000..d0c6fa9c84d5
--- /dev/null
+++ b/chinese/rime-cangjie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608103989
+SHA256 (rime-rime-cangjie-g20201030-d0f6f521ec049166ada29085434126be175f6439_GH0.tar.gz) = 50803c76b1865690cf692ce98335c8a1139f0f5fa2e553875b293939f05a02b4
+SIZE (rime-rime-cangjie-g20201030-d0f6f521ec049166ada29085434126be175f6439_GH0.tar.gz) = 392830
diff --git a/chinese/rime-cangjie/pkg-descr b/chinese/rime-cangjie/pkg-descr
new file mode 100644
index 000000000000..06cc2fc80c1d
--- /dev/null
+++ b/chinese/rime-cangjie/pkg-descr
@@ -0,0 +1,3 @@
+Rime Cangjie v5 schema input support.
+
+WWW: https://github.com/rime/rime-cangjie
diff --git a/chinese/rime-cangjie/pkg-plist b/chinese/rime-cangjie/pkg-plist
new file mode 100644
index 000000000000..625e2d73221d
--- /dev/null
+++ b/chinese/rime-cangjie/pkg-plist
@@ -0,0 +1,10 @@
+share/rime-data/build/cangjie5.prism.bin
+share/rime-data/build/cangjie5.reverse.bin
+share/rime-data/build/cangjie5.schema.yaml
+share/rime-data/build/cangjie5.table.bin
+share/rime-data/build/cangjie5.table.txt
+share/rime-data/build/cangjie5_express.prism.bin
+share/rime-data/build/cangjie5_express.schema.yaml
+share/rime-data/cangjie5.dict.yaml
+share/rime-data/cangjie5.schema.yaml
+share/rime-data/cangjie5_express.schema.yaml
diff --git a/chinese/rime-cantonese/Makefile b/chinese/rime-cantonese/Makefile
new file mode 100644
index 000000000000..392debd11b40
--- /dev/null
+++ b/chinese/rime-cantonese/Makefile
@@ -0,0 +1,67 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-cantonese
+DISTVERSION= g20201212
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Cantonese (Jyutping) schema support
+
+LICENSE= CC-BY-4.0 ODbL
+LICENSE_COMB= multi
+LICENSE_NAME_ODbL= Open Database License
+LICENSE_FILE_CC-BY-4.0= ${WRKSRC}/LICENSE-CC-BY
+LICENSE_FILE_ODbL= ${WRKSRC}/LICENSE-ODbL
+LICENSE_PERMS_ODbL= dist-mirror dist-sell auto-accept
+
+BUILD_DEPENDS= \
+ rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 99785a30d1f3bffef4142bbc7b73435a73a16cb1
+
+NO_ARCH= yes
+
+PORTDOCS= README.md README-cmn.md README-en.md demo/*
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= jyut6ping3.schema.yaml jyut6ping3_ipa.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data/opencc
+ ${INSTALL_DATA} ${WRKSRC}/opencc/* ${STAGEDIR}${PREFIX}/share/rime-data/opencc
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/demo
+ ${INSTALL_DATA} ${WRKSRC}/demo/* ${STAGEDIR}${DOCSDIR}/demo
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README-cmn.md ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README-en.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-cantonese/distinfo b/chinese/rime-cantonese/distinfo
new file mode 100644
index 000000000000..d898815589eb
--- /dev/null
+++ b/chinese/rime-cantonese/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608031935
+SHA256 (rime-rime-cantonese-g20201212-99785a30d1f3bffef4142bbc7b73435a73a16cb1_GH0.tar.gz) = 0a34a829c2cf2379259cfa9fec5bea57697049aee9e5f051fb94a428d8804cc1
+SIZE (rime-rime-cantonese-g20201212-99785a30d1f3bffef4142bbc7b73435a73a16cb1_GH0.tar.gz) = 3585583
diff --git a/chinese/rime-cantonese/pkg-descr b/chinese/rime-cantonese/pkg-descr
new file mode 100644
index 000000000000..09b720535ea1
--- /dev/null
+++ b/chinese/rime-cantonese/pkg-descr
@@ -0,0 +1,3 @@
+Rime Jyutping schema for Cantonese input support.
+
+WWW: https://github.com/rime/rime-cantonese
diff --git a/chinese/rime-cantonese/pkg-plist b/chinese/rime-cantonese/pkg-plist
new file mode 100644
index 000000000000..9fc74afc1f2b
--- /dev/null
+++ b/chinese/rime-cantonese/pkg-plist
@@ -0,0 +1,18 @@
+share/rime-data/build/jyut6ping3.prism.bin
+share/rime-data/build/jyut6ping3.prism.txt
+share/rime-data/build/jyut6ping3.reverse.bin
+share/rime-data/build/jyut6ping3.schema.yaml
+share/rime-data/build/jyut6ping3.table.bin
+share/rime-data/build/jyut6ping3.table.txt
+share/rime-data/build/jyut6ping3_ipa.prism.bin
+share/rime-data/build/jyut6ping3_ipa.prism.txt
+share/rime-data/build/jyut6ping3_ipa.schema.yaml
+share/rime-data/jyut6ping3.dict.yaml
+share/rime-data/jyut6ping3.lettered.dict.yaml
+share/rime-data/jyut6ping3.maps.dict.yaml
+share/rime-data/jyut6ping3.phrase.dict.yaml
+share/rime-data/jyut6ping3.schema.yaml
+share/rime-data/jyut6ping3_ipa.schema.yaml
+share/rime-data/opencc/HKVariantsFull.txt
+share/rime-data/opencc/t2hkf.json
+share/rime-data/symbols_cantonese.yaml
diff --git a/chinese/rime-data/Makefile b/chinese/rime-data/Makefile
new file mode 100644
index 000000000000..425a5f147000
--- /dev/null
+++ b/chinese/rime-data/Makefile
@@ -0,0 +1,21 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-data
+PORTVERSION= g20201216
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime data files preset
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= \
+ ${LOCALBASE}/share/rime-data/luna_pinyin.schema.yaml:chinese/rime-luna-pinyin \
+ ${LOCALBASE}/share/rime-data/bopomofo.schema.yaml:chinese/rime-bopomofo \
+ ${LOCALBASE}/share/rime-data/cangjie5.schema.yaml:chinese/rime-cangjie \
+ ${LOCALBASE}/share/rime-data/stroke.schema.yaml:chinese/rime-stroke
+
+USES= localbase metaport
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-data/pkg-descr b/chinese/rime-data/pkg-descr
new file mode 100644
index 000000000000..857d24587381
--- /dev/null
+++ b/chinese/rime-data/pkg-descr
@@ -0,0 +1,5 @@
+Rime data files. This is a metaport that provides an essential set of
+configuration ports and a preset of IME schema ports for the Rime IME
+framework.
+
+WWW: https://github.com/rime/plum
diff --git a/chinese/rime-essay/Makefile b/chinese/rime-essay/Makefile
new file mode 100644
index 000000000000..85b59df9db96
--- /dev/null
+++ b/chinese/rime-essay/Makefile
@@ -0,0 +1,37 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-essay
+DISTVERSION= g20201004
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Essay - the shared vocabulary and language model for Rime
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 964ff5c5854a4452256891a4fe3b333592f3d68b
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PLIST_FILES= share/rime-data/essay.txt
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/essay.txt ${STAGEDIR}${PREFIX}/share/rime-data
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-essay/distinfo b/chinese/rime-essay/distinfo
new file mode 100644
index 000000000000..fb4e5479cf87
--- /dev/null
+++ b/chinese/rime-essay/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608060143
+SHA256 (rime-rime-essay-g20201004-964ff5c5854a4452256891a4fe3b333592f3d68b_GH0.tar.gz) = 1bbdc62cbaac5ec03caa2d3bfacc304b0ea07f3bba1cb6f8ccf22ff879075568
+SIZE (rime-rime-essay-g20201004-964ff5c5854a4452256891a4fe3b333592f3d68b_GH0.tar.gz) = 1771557
diff --git a/chinese/rime-essay/pkg-descr b/chinese/rime-essay/pkg-descr
new file mode 100644
index 000000000000..9b2132b03ca9
--- /dev/null
+++ b/chinese/rime-essay/pkg-descr
@@ -0,0 +1,3 @@
+Shared vocabulary and language model for Rime.
+
+WWW: https://github.com/rime/rime-essay
diff --git a/chinese/rime-luna-pinyin/Makefile b/chinese/rime-luna-pinyin/Makefile
new file mode 100644
index 000000000000..8e67bb431b2c
--- /dev/null
+++ b/chinese/rime-luna-pinyin/Makefile
@@ -0,0 +1,62 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-luna-pinyin
+DISTVERSION= g20201105
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Luna Pinyin schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= \
+ rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 3e03d65a1a9162871ee521d5d4846661e59298e0
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= luna_pinyin_fluency.schema.yaml \
+ luna_pinyin_simp.schema.yaml \
+ luna_pinyin_tw.schema.yaml \
+ luna_pinyin.schema.yaml \
+ luna_quanpin.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-luna-pinyin/distinfo b/chinese/rime-luna-pinyin/distinfo
new file mode 100644
index 000000000000..98e4fe1f4cba
--- /dev/null
+++ b/chinese/rime-luna-pinyin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608102480
+SHA256 (rime-rime-luna-pinyin-g20201105-3e03d65a1a9162871ee521d5d4846661e59298e0_GH0.tar.gz) = 28ceb79c288c17c8c861174ba0180766033105fea58f564537f0106a79632829
+SIZE (rime-rime-luna-pinyin-g20201105-3e03d65a1a9162871ee521d5d4846661e59298e0_GH0.tar.gz) = 393707
diff --git a/chinese/rime-luna-pinyin/pkg-descr b/chinese/rime-luna-pinyin/pkg-descr
new file mode 100644
index 000000000000..88683f30beee
--- /dev/null
+++ b/chinese/rime-luna-pinyin/pkg-descr
@@ -0,0 +1,3 @@
+Rime Luna Pinyin schema for Mandarin input support.
+
+WWW: https://github.com/rime/rime-luna-pinyin
diff --git a/chinese/rime-luna-pinyin/pkg-plist b/chinese/rime-luna-pinyin/pkg-plist
new file mode 100644
index 000000000000..0a2ee6fb0bbe
--- /dev/null
+++ b/chinese/rime-luna-pinyin/pkg-plist
@@ -0,0 +1,24 @@
+share/rime-data/build/luna_pinyin.prism.bin
+share/rime-data/build/luna_pinyin.prism.txt
+share/rime-data/build/luna_pinyin.reverse.bin
+share/rime-data/build/luna_pinyin.schema.yaml
+share/rime-data/build/luna_pinyin.table.bin
+share/rime-data/build/luna_pinyin.table.txt
+share/rime-data/build/luna_pinyin_fluency.prism.bin
+share/rime-data/build/luna_pinyin_fluency.prism.txt
+share/rime-data/build/luna_pinyin_fluency.schema.yaml
+share/rime-data/build/luna_pinyin_simp.prism.bin
+share/rime-data/build/luna_pinyin_simp.prism.txt
+share/rime-data/build/luna_pinyin_simp.schema.yaml
+share/rime-data/build/luna_pinyin_tw.prism.bin
+share/rime-data/build/luna_pinyin_tw.prism.txt
+share/rime-data/build/luna_pinyin_tw.schema.yaml
+share/rime-data/build/luna_quanpin.prism.bin
+share/rime-data/build/luna_quanpin.prism.txt
+share/rime-data/build/luna_quanpin.schema.yaml
+share/rime-data/luna_pinyin.dict.yaml
+share/rime-data/luna_pinyin.schema.yaml
+share/rime-data/luna_pinyin_fluency.schema.yaml
+share/rime-data/luna_pinyin_simp.schema.yaml
+share/rime-data/luna_pinyin_tw.schema.yaml
+share/rime-data/luna_quanpin.schema.yaml
diff --git a/chinese/rime-prelude/Makefile b/chinese/rime-prelude/Makefile
new file mode 100644
index 000000000000..0676d194d24f
--- /dev/null
+++ b/chinese/rime-prelude/Makefile
@@ -0,0 +1,44 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-prelude
+DISTVERSION= g20201212
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Essential files for building up your Rime configuration
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 00a5b5a40b0e4419869ec3783744c75a8c86a5d7
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PLIST_FILES= \
+ share/rime-data/default.yaml \
+ share/rime-data/key_bindings.yaml \
+ share/rime-data/punctuation.yaml \
+ share/rime-data/symbols.yaml
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/default.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/key_bindings.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/punctuation.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/symbols.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-prelude/distinfo b/chinese/rime-prelude/distinfo
new file mode 100644
index 000000000000..368d24e7cbf4
--- /dev/null
+++ b/chinese/rime-prelude/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608026020
+SHA256 (rime-rime-prelude-g20201212-00a5b5a40b0e4419869ec3783744c75a8c86a5d7_GH0.tar.gz) = 29b5122c6713a30ae6bb6914ee7b58e4b02f48f9248ac3d8413adc48e5a64cd2
+SIZE (rime-rime-prelude-g20201212-00a5b5a40b0e4419869ec3783744c75a8c86a5d7_GH0.tar.gz) = 18287
diff --git a/chinese/rime-prelude/pkg-descr b/chinese/rime-prelude/pkg-descr
new file mode 100644
index 000000000000..18366576f2c8
--- /dev/null
+++ b/chinese/rime-prelude/pkg-descr
@@ -0,0 +1,3 @@
+Essential files for building up your Rime configuration.
+
+WWW: https://github.com/rime/rime-prelude
diff --git a/chinese/rime-stroke/Makefile b/chinese/rime-stroke/Makefile
new file mode 100644
index 000000000000..3fcb4296126d
--- /dev/null
+++ b/chinese/rime-stroke/Makefile
@@ -0,0 +1,58 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-stroke
+DISTVERSION= g20191221
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Stroke schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= \
+ rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= ea8576d1accd6fda339e96b415caadb56e2a07d1
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= stroke.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-stroke/distinfo b/chinese/rime-stroke/distinfo
new file mode 100644
index 000000000000..5c6dd841e6fd
--- /dev/null
+++ b/chinese/rime-stroke/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608104190
+SHA256 (rime-rime-stroke-g20191221-ea8576d1accd6fda339e96b415caadb56e2a07d1_GH0.tar.gz) = 6ff57556a7a047514911226db9dd244f9517912573826c0d20b21456b98202be
+SIZE (rime-rime-stroke-g20191221-ea8576d1accd6fda339e96b415caadb56e2a07d1_GH0.tar.gz) = 714917
diff --git a/chinese/rime-stroke/pkg-descr b/chinese/rime-stroke/pkg-descr
new file mode 100644
index 000000000000..cb3b9a68c2e2
--- /dev/null
+++ b/chinese/rime-stroke/pkg-descr
@@ -0,0 +1,3 @@
+Rime Stroke schema input support.
+
+WWW: https://github.com/rime/rime-stroke
diff --git a/chinese/rime-stroke/pkg-plist b/chinese/rime-stroke/pkg-plist
new file mode 100644
index 000000000000..bcde5755d939
--- /dev/null
+++ b/chinese/rime-stroke/pkg-plist
@@ -0,0 +1,7 @@
+share/rime-data/build/stroke.prism.bin
+share/rime-data/build/stroke.reverse.bin
+share/rime-data/build/stroke.schema.yaml
+share/rime-data/build/stroke.table.bin
+share/rime-data/build/stroke.table.txt
+share/rime-data/stroke.dict.yaml
+share/rime-data/stroke.schema.yaml
diff --git a/chinese/rime-terra-pinyin/Makefile b/chinese/rime-terra-pinyin/Makefile
new file mode 100644
index 000000000000..a93c4b895305
--- /dev/null
+++ b/chinese/rime-terra-pinyin/Makefile
@@ -0,0 +1,58 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= rime-terra-pinyin
+DISTVERSION= g20201018
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Rime Terra Pinyin schema support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= \
+ rime_deployer:chinese/librime \
+ zh-rime-essay>g0:chinese/rime-essay \
+ zh-rime-prelude>g0:chinese/rime-prelude
+RUN_DEPENDS= zh-rime-prelude>g0:chinese/rime-prelude
+
+USES= localbase
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rime
+GH_TAGNAME= 5a445e2953c4b8149daac9d4625782fd5f80d9f2
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS README.md
+
+PRELUDE_FILES= default.yaml key_bindings.yaml punctuation.yaml symbols.yaml
+ESSAY_FILES= essay.txt
+SCHEMA_FILES= terra_pinyin.schema.yaml
+MY_OUTDIR= ${WRKDIR}/out
+
+do-build:
+ @${MKDIR} ${MY_OUTDIR}
+ @${RLN} ${WRKSRC}/* ${MY_OUTDIR}
+.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
+ @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+.endfor
+.for i in ${SCHEMA_FILES}
+ rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
+.endfor
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/rime-data
+ ${INSTALL_DATA} ${WRKSRC}/*.yaml ${STAGEDIR}${PREFIX}/share/rime-data
+ (cd ${MY_OUTDIR} && ${COPYTREE_SHARE} build ${STAGEDIR}${PREFIX}/share/rime-data)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/rime-terra-pinyin/distinfo b/chinese/rime-terra-pinyin/distinfo
new file mode 100644
index 000000000000..fbf69f28b963
--- /dev/null
+++ b/chinese/rime-terra-pinyin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608102914
+SHA256 (rime-rime-terra-pinyin-g20201018-5a445e2953c4b8149daac9d4625782fd5f80d9f2_GH0.tar.gz) = c5fda93a0f5b3fd64b875f853b214a23289802b9022c9b0227af515e97009bfb
+SIZE (rime-rime-terra-pinyin-g20201018-5a445e2953c4b8149daac9d4625782fd5f80d9f2_GH0.tar.gz) = 730315
diff --git a/chinese/rime-terra-pinyin/pkg-descr b/chinese/rime-terra-pinyin/pkg-descr
new file mode 100644
index 000000000000..a77636c3df79
--- /dev/null
+++ b/chinese/rime-terra-pinyin/pkg-descr
@@ -0,0 +1,3 @@
+Rime Terra Pinyin schema for Mandarin input support.
+
+WWW: https://github.com/rime/rime-terra-pinyin
diff --git a/chinese/rime-terra-pinyin/pkg-plist b/chinese/rime-terra-pinyin/pkg-plist
new file mode 100644
index 000000000000..a80bf27800c1
--- /dev/null
+++ b/chinese/rime-terra-pinyin/pkg-plist
@@ -0,0 +1,8 @@
+share/rime-data/build/terra_pinyin.prism.bin
+share/rime-data/build/terra_pinyin.prism.txt
+share/rime-data/build/terra_pinyin.reverse.bin
+share/rime-data/build/terra_pinyin.schema.yaml
+share/rime-data/build/terra_pinyin.table.bin
+share/rime-data/build/terra_pinyin.table.txt
+share/rime-data/terra_pinyin.dict.yaml
+share/rime-data/terra_pinyin.schema.yaml