aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /chinese
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Fix CONFLICTS entries of multiple ports
There have been lots of missing CONFLICTS_INSTALL entries, either because conflicting ports were added without updating existing ports, due to name changes of generated packages, due to mis-understanding the format and semantics of the conflicts entries, or just due to typoes in package names. This patch is the result of a comparison of all files contained in the official packages with each other. This comparison was based on packages built with default options and may therefore have missed further conflicts with optionally installed files. Where possible, version numbers in conflicts entries have been generalized, some times taking advantage of the fact that a port cannot conflict with itself (due to logic in bsd.port.mk that supresses the pattern match result in that case). A few ports that set the conflicts variables depending on complex conditions (e.g. port options), have been left unmodified, despite probably containing outdated package names. These changes should only affect the installation of locally built ports, not the package building with poudriere. They should give an early indication of the install conflict in cases where currently the pkg command aborts an installation when it detects that an existing file would be overwritten, Approved by: portmgr (implicit)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/aterm/Makefile2
-rw-r--r--chinese/bitchx/Makefile2
-rw-r--r--chinese/enscript/Makefile2
-rw-r--r--chinese/eterm/Makefile2
-rw-r--r--chinese/fcitx/Makefile2
-rw-r--r--chinese/hc/Makefile2
-rw-r--r--chinese/scim-fcitx/Makefile2
7 files changed, 13 insertions, 1 deletions
diff --git a/chinese/aterm/Makefile b/chinese/aterm/Makefile
index d95fe35af3ec..3b39cce70865 100644
--- a/chinese/aterm/Makefile
+++ b/chinese/aterm/Makefile
@@ -14,6 +14,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-xim --enable-big5
MAKE_JOBS_UNSAFE= yes
+CONFLICTS_INSTALL= aterm
+
PLIST_FILES= "@(,,4711) bin/aterm" \
man/man1/aterm.1.gz
diff --git a/chinese/bitchx/Makefile b/chinese/bitchx/Makefile
index bbf74cff0100..8dffc33f5005 100644
--- a/chinese/bitchx/Makefile
+++ b/chinese/bitchx/Makefile
@@ -11,6 +11,8 @@ EXTRA_PATCHES= ${.CURDIR}/files/patch-source__input.c \
${.CURDIR}/files/patch-include__config.h \
${.CURDIR}/files/patch-source__screen.c
+CONFLICTS_INSTALL= bitchx
+
OPTIONS_SLAVE= LATIN
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/enscript/Makefile b/chinese/enscript/Makefile
index 2a7b5a338247..da03bf342cc9 100644
--- a/chinese/enscript/Makefile
+++ b/chinese/enscript/Makefile
@@ -16,6 +16,8 @@ PKGMESSAGE= ${.CURDIR}/pkg-message
USES+= ghostscript:run
+CONFLICTS_INSTALL= enscript-a4 enscript-letter enscript-letterdj
+
post-patch:
@${ECHO_CMD} "share/enscript/README.BIG5" > ${WRKDIR}/pkg-plist
@${CAT} ${MASTERDIR}/pkg-plist >> ${WRKDIR}/pkg-plist
diff --git a/chinese/eterm/Makefile b/chinese/eterm/Makefile
index c13290728b35..764533d80514 100644
--- a/chinese/eterm/Makefile
+++ b/chinese/eterm/Makefile
@@ -14,6 +14,8 @@ CONFIGURE_ARGS= --enable-trans --enable-utmp \
--with-backspace=bs --without-terminfo \
--enable-multi-charset=big5
+CONFLICTS_INSTALL= eterm ja-eterm
+
PKGDIR= ${.CURDIR}
PLIST= ${MASTERDIR}/pkg-plist
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 72345d521dc3..d0ca68f282b8 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -37,7 +37,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
SUB_FILES= pkg-message
SUB_LIST+= PORTSDIR=${PORTSDIR}
-CONFLICTS= zh-scim-fcitx-3.* fcitx5
+CONFLICTS= zh-scim-fcitx
USE_GNOME= pango intltool libxml2 introspection
USE_KDE= ecm
diff --git a/chinese/hc/Makefile b/chinese/hc/Makefile
index 15026340f287..cbc1efe985ce 100644
--- a/chinese/hc/Makefile
+++ b/chinese/hc/Makefile
@@ -9,6 +9,8 @@ DISTFILES= hc-30.tar.gz hc-supp.tab
MAINTAINER= ports@FreeBSD.org
COMMENT= Hanzi Converter -- converts between GB and BIG-5 codes
+CONFLICTS_INSTALL= rubygem-hieracles
+
WRKSRC= ${WRKDIR}/hc3
EXTRACT_ONLY= hc-30.tar.gz
ALL_TARGET= hc b2g g2b
diff --git a/chinese/scim-fcitx/Makefile b/chinese/scim-fcitx/Makefile
index cfd4aa04393e..c19e6e78b156 100644
--- a/chinese/scim-fcitx/Makefile
+++ b/chinese/scim-fcitx/Makefile
@@ -23,6 +23,8 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
+CONFIGURE_INSTALL= zh-fcitx
+
WRKSRC= ${WRKDIR}/fcitx
CONFIGURE_ENV+= SCIM_DATADIR=${PREFIX}/share/scim \