aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-01-13 11:53:48 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-01-15 13:56:56 +0000
commitd8be971f1a4f5c304e357e121d918f12b55f9f81 (patch)
tree470be85043cf94228efdc38cee68bbb2903ed262 /chinese
parent42714c697fa42b2ec70641b1e1b38a1e5c589972 (diff)
downloadports-d8be971f1a4f5c304e357e121d918f12b55f9f81.tar.gz
ports-d8be971f1a4f5c304e357e121d918f12b55f9f81.zip
chinese/fctx: Get rid of MANPREFIX and install mans to share/man.
To achieve this, add a temporary hacky knob KDE_MAN_PREFIX to allow ports to override the man installation dir. Once Uses/kde.mk migrates to share/man, this knob will be removed. Approved by: tcberner
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fcitx/Makefile2
-rw-r--r--chinese/fcitx/files/patch-CMakeLists.txt9
-rw-r--r--chinese/fcitx/pkg-plist18
3 files changed, 14 insertions, 15 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index ba6a787fba64..6c2bf55dbb81 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -64,13 +64,13 @@ TPUNC_DESC= Use traditional quotation marks
.include <bsd.port.options.mk>
+KDE_MAN_PREFIX= ${PREFIX}/share/man
CMAKE_ARGS+= -DENABLE_XDGAUTOSTART=OFF -DFORCE_ENCHANT=ON \
-DLIBICONV_LIBC_HAS_ICONV_OPEN=OFF \
-DDATADIR=${DATADIR} \
-DDOCSDIR=${DOCSDIR} \
-DGOBJECT_INTROSPECTION_GIRDIR=${PREFIX}/share/gir-1.0 \
-DGOBJECT_INTROSPECTION_TYPELIBDIR=${PREFIX}/lib/girepository-1.0 \
- -DMANPREFIX=${MANPREFIX} \
-DPREFIX=${PREFIX} \
-DENABLE_QT=OFF -DENABLE_QT_IM_MODULE=OFF -DENABLE_QT_GUI=OFF
diff --git a/chinese/fcitx/files/patch-CMakeLists.txt b/chinese/fcitx/files/patch-CMakeLists.txt
index 2a0d041cbd1f..b84facf6478a 100644
--- a/chinese/fcitx/files/patch-CMakeLists.txt
+++ b/chinese/fcitx/files/patch-CMakeLists.txt
@@ -1,17 +1,16 @@
---- CMakeLists.txt.orig 2015-12-12 08:02:09 UTC
+--- CMakeLists.txt.orig 2020-08-01 01:40:38 UTC
+++ CMakeLists.txt
-@@ -206,16 +206,21 @@ if (NOT DEFINED SYSCONFDIR)
+@@ -200,16 +200,21 @@ endif()
set(SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/etc" CACHE PATH "sys config directory [default=PREFIX/etc/]")
endif()
-set(includedir "${CMAKE_INSTALL_PREFIX}/include")
-set(libdir ${LIB_INSTALL_DIR})
-set(pkgconfdir ${LIBDATA_INSTALL_DIR}/pkgconfig)
--set(mandir ${MAN_INSTALL_DIR})
+set(includedir "${PREFIX}/include")
+set(libdir ${PREFIX}/lib)
+set(pkgconfdir ${PREFIX}/libdata/pkgconfig)
-+set(mandir ${MANPREFIX}/man)
+ set(mandir ${MAN_INSTALL_DIR})
set(addondir ${libdir}/${package} )
-set(pkgdatadir ${prefix}/share/${package})
+set(addondestdir "\${PREFIX}/lib/${package}" )
@@ -28,7 +27,7 @@
list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemPlatformLibDir)
list(FIND CMAKE_CXX_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemCxxLibDir)
-@@ -228,9 +233,13 @@ endif("${_isSystemPlatformLibDir}" STREQ
+@@ -222,9 +227,13 @@ set(FCITX4_ADDON_INSTALL_DIR ${addondir})
# For FcitxMacro
set(FCITX4_ADDON_INSTALL_DIR ${addondir})
diff --git a/chinese/fcitx/pkg-plist b/chinese/fcitx/pkg-plist
index 62e69814a2ba..0edd8d6e685a 100644
--- a/chinese/fcitx/pkg-plist
+++ b/chinese/fcitx/pkg-plist
@@ -126,15 +126,15 @@ libdata/pkgconfig/fcitx-config.pc
libdata/pkgconfig/fcitx-gclient.pc
libdata/pkgconfig/fcitx-utils.pc
libdata/pkgconfig/fcitx.pc
-man/man1/createPYMB.1.gz
-man/man1/fcitx-remote.1.gz
-man/man1/fcitx.1.gz
-man/man1/mb2org.1.gz
-man/man1/mb2txt.1.gz
-man/man1/readPYBase.1.gz
-man/man1/readPYMB.1.gz
-man/man1/scel2org.1.gz
-man/man1/txt2mb.1.gz
+share/man/man1/createPYMB.1.gz
+share/man/man1/fcitx-remote.1.gz
+share/man/man1/fcitx.1.gz
+share/man/man1/mb2org.1.gz
+share/man/man1/mb2txt.1.gz
+share/man/man1/readPYBase.1.gz
+share/man/man1/readPYMB.1.gz
+share/man/man1/scel2org.1.gz
+share/man/man1/txt2mb.1.gz
share/applications/fcitx-configtool.desktop
share/applications/fcitx-skin-installer.desktop
share/applications/fcitx.desktop