aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-10-02 06:19:40 +0000
committerJohn Marino <marino@FreeBSD.org>2013-10-02 06:19:40 +0000
commited1921e7bcd84e11abad88c7c4ad900c06e947cf (patch)
treec37991ef86287adbf1a3636a0d59932b4fc9f9b7 /chinese
parentb748c845b6ace6b62203f2d4f4034b3bb374e3a3 (diff)
downloadports-ed1921e7bcd84e11abad88c7c4ad900c06e947cf.tar.gz
ports-ed1921e7bcd84e11abad88c7c4ad900c06e947cf.zip
Notes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fqterm/Makefile2
-rw-r--r--chinese/fqterm/files/patch-CMakeLists.txt.linux64
-rw-r--r--chinese/fqterm/files/patch-src_common_fqterm__trace.h10
-rw-r--r--chinese/fqterm/files/patch-src_fqterm_fqterm__wndmgr.cpp11
-rw-r--r--chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h16
5 files changed, 62 insertions, 41 deletions
diff --git a/chinese/fqterm/Makefile b/chinese/fqterm/Makefile
index 40a695617fe7..ed1587f958e1 100644
--- a/chinese/fqterm/Makefile
+++ b/chinese/fqterm/Makefile
@@ -19,7 +19,7 @@ USE_QT4= gui network script qt3support imageformats \
qmake_build moc_build rcc_build uic_build linguist_build
HAS_CONFIGURE= yes
-USE_DOS2UNIX= src/ui/popwidget.cpp
+USE_DOS2UNIX= yes
USES= cmake:outsource
CMAKE_ARGS= -Wno-dev
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/chinese/fqterm/files/patch-CMakeLists.txt.linux b/chinese/fqterm/files/patch-CMakeLists.txt.linux
index ca65d021b95f..dc1b417e0dde 100644
--- a/chinese/fqterm/files/patch-CMakeLists.txt.linux
+++ b/chinese/fqterm/files/patch-CMakeLists.txt.linux
@@ -1,37 +1,37 @@
--- CMakeLists.txt.linux.orig 2008-05-19 17:36:29.000000000 +0800
+++ CMakeLists.txt.linux 2008-06-21 08:50:58.000000000 +0800
@@ -7,6 +7,7 @@
- endif(FQTERM_USE_STATIC_QT)
-
- ADD_DEFINITIONS(-Wall)
-+ADD_DEFINITIONS(-D_OS_FREEBSD_)
- ADD_DEFINITIONS(-DFQTERM_VERSION_STRING="\\"${FQTERM_VERSION}\\"")
-
- add_subdirectory(src)
+ endif(FQTERM_USE_STATIC_QT)
+
+ ADD_DEFINITIONS(-Wall)
++ADD_DEFINITIONS(-D_OS_FREEBSD_)
+ ADD_DEFINITIONS(-DFQTERM_VERSION_STRING="\\"${FQTERM_VERSION}\\"")
+
+ add_subdirectory(src)
@@ -42,6 +43,18 @@
- ${QT_PLUGINS_DIR}/codecs/libqtwcodecs.a
- jpeg
- )
-+else(FQTERM_USE_STATIC_QT)
-+ set(FQ_QT_SHARED_PLUGINS
-+ ${QT_PLUGINS_DIR}/imageformats/libqgif.so
-+ ${QT_PLUGINS_DIR}/imageformats/libqjpeg.so
-+ ${QT_PLUGINS_DIR}/imageformats/libqmng.so
-+ ${QT_PLUGINS_DIR}/imageformats/libqsvg.so
-+ ${QT_PLUGINS_DIR}/imageformats/libqtiff.so
-+ ${QT_PLUGINS_DIR}/codecs/libqcncodecs.so
-+ ${QT_PLUGINS_DIR}/codecs/libqjpcodecs.so
-+ ${QT_PLUGINS_DIR}/codecs/libqkrcodecs.so
-+ ${QT_PLUGINS_DIR}/codecs/libqtwcodecs.so
-+ )
- endif(FQTERM_USE_STATIC_QT)
-
- target_link_libraries(fqterm.bin
+ ${QT_PLUGINS_DIR}/codecs/libqtwcodecs.a
+ jpeg
+ )
++else(FQTERM_USE_STATIC_QT)
++ set(FQ_QT_SHARED_PLUGINS
++ ${QT_PLUGINS_DIR}/imageformats/libqgif.so
++ ${QT_PLUGINS_DIR}/imageformats/libqjpeg.so
++ ${QT_PLUGINS_DIR}/imageformats/libqmng.so
++ ${QT_PLUGINS_DIR}/imageformats/libqsvg.so
++ ${QT_PLUGINS_DIR}/imageformats/libqtiff.so
++ ${QT_PLUGINS_DIR}/codecs/libqcncodecs.so
++ ${QT_PLUGINS_DIR}/codecs/libqjpcodecs.so
++ ${QT_PLUGINS_DIR}/codecs/libqkrcodecs.so
++ ${QT_PLUGINS_DIR}/codecs/libqtwcodecs.so
++ )
+ endif(FQTERM_USE_STATIC_QT)
+
+ target_link_libraries(fqterm.bin
@@ -54,6 +67,7 @@
- ${QT_QTNETWORK_LIBRARIES}
- ${QT_QTSCRIPT_LIBRARIES}
- ${FQ_QT_STATIC_PLUGINS}
-+ ${FQ_QT_SHARED_PLUGINS}
- ${QT_LIBRARIES}
- ${OPENSSL_LIBRARIES}
- )
+ ${QT_QTNETWORK_LIBRARIES}
+ ${QT_QTSCRIPT_LIBRARIES}
+ ${FQ_QT_STATIC_PLUGINS}
++ ${FQ_QT_SHARED_PLUGINS}
+ ${QT_LIBRARIES}
+ ${OPENSSL_LIBRARIES}
+ )
diff --git a/chinese/fqterm/files/patch-src_common_fqterm__trace.h b/chinese/fqterm/files/patch-src_common_fqterm__trace.h
new file mode 100644
index 000000000000..c58c2f860195
--- /dev/null
+++ b/chinese/fqterm/files/patch-src_common_fqterm__trace.h
@@ -0,0 +1,10 @@
+--- src/common/fqterm_trace.h.orig 2013-10-02 06:06:02.000000000 +0000
++++ src/common/fqterm_trace.h
+@@ -21,6 +21,7 @@
+ #ifndef FQTERM_TRACE_H
+ #define FQTERM_TRACE_H
+
++#include <unistd.h>
+ #include <cassert>
+ #include <QtDebug>
+ #include <QFileInfo>
diff --git a/chinese/fqterm/files/patch-src_fqterm_fqterm__wndmgr.cpp b/chinese/fqterm/files/patch-src_fqterm_fqterm__wndmgr.cpp
new file mode 100644
index 000000000000..0fcc388c8ec8
--- /dev/null
+++ b/chinese/fqterm/files/patch-src_fqterm_fqterm__wndmgr.cpp
@@ -0,0 +1,11 @@
+--- src/fqterm/fqterm_wndmgr.cpp.orig 2013-10-02 06:06:59.000000000 +0000
++++ src/fqterm/fqterm_wndmgr.cpp
+@@ -53,7 +53,7 @@ int FQTermWndMgr::addWindow(FQTermWindow
+
+ Q_ASSERT(mw != NULL);
+ termWindows_.append(mw);
+- Q_ASSERT(qtab != QString::QString());
++ Q_ASSERT(qtab != QString());
+ tabCaptions_.append(qtab);
+ icons_.append(icon);
+
diff --git a/chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h b/chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h
index 7c1d489e11dd..c0d5e2b4f6de 100644
--- a/chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h
+++ b/chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h
@@ -1,11 +1,11 @@
--- src/ui/fqterm_tool_button.h.orig 2008-05-18 08:46:46.000000000 +0800
+++ src/ui/fqterm_tool_button.h 2008-06-21 08:52:08.000000000 +0800
@@ -21,7 +21,7 @@
- #ifndef FQTERM_TOOL_BUTTON_H
- #define FQTERM_TOOL_BUTTON_H
-
--#include <qtoolbutton.h>
-+#include <QToolButton>
-
- namespace FQTerm {
-
+ #ifndef FQTERM_TOOL_BUTTON_H
+ #define FQTERM_TOOL_BUTTON_H
+
+-#include <qtoolbutton.h>
++#include <QToolButton>
+
+ namespace FQTerm {
+