aboutsummaryrefslogtreecommitdiff
path: root/comms/airspy
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-04 07:53:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-04 07:53:58 +0000
commitb87b08776551b313ba10776a5db0b8467d0c1504 (patch)
tree71f2d9e133ab51483abc65f6e214efd018e02aee /comms/airspy
parent6cd011e34be0d1c23d639d3209fb11370d827e1b (diff)
downloadports-b87b08776551b313ba10776a5db0b8467d0c1504.tar.gz
ports-b87b08776551b313ba10776a5db0b8467d0c1504.zip
comms/airspy: fix build on powerpc64
PR: 237005 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=497802
Diffstat (limited to 'comms/airspy')
-rw-r--r--comms/airspy/Makefile1
-rw-r--r--comms/airspy/files/patch-libairspy_src_iqconverter__float.c2
2 files changed, 1 insertions, 2 deletions
diff --git a/comms/airspy/Makefile b/comms/airspy/Makefile
index 57e78d275861..4f2aaefd044c 100644
--- a/comms/airspy/Makefile
+++ b/comms/airspy/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/airspy-tools/LICENSE.md
BROKEN_aarch64= fails to compile: invalid conversion between vector type '__m64' and integer type 'int'
-BROKEN_powerpc64= fails to build: iqconverter_float.c:45:23: error: immintrin.h: No such file or directory
USES= cmake pkgconfig
USE_GITHUB= yes
diff --git a/comms/airspy/files/patch-libairspy_src_iqconverter__float.c b/comms/airspy/files/patch-libairspy_src_iqconverter__float.c
index b990181a257f..9354d0f9e9bd 100644
--- a/comms/airspy/files/patch-libairspy_src_iqconverter__float.c
+++ b/comms/airspy/files/patch-libairspy_src_iqconverter__float.c
@@ -6,7 +6,7 @@
#elif defined(__FreeBSD__)
+# if defined(FREEBSD_USE_SIMD)
#define USE_SSE2
-+# endif
#include <immintrin.h>
++# endif
#define _inline inline
#define _aligned_free(mem) free(mem)