aboutsummaryrefslogtreecommitdiff
path: root/comms/apitran
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /comms/apitran
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Convert the tree to use PY_PILLOW
With hat: portmgr Originally submitted by: kai
Notes
Notes: svn path=/head/; revision=529063
Diffstat (limited to 'comms/apitran')
-rw-r--r--comms/apitran/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/comms/apitran/Makefile b/comms/apitran/Makefile
index daa8d4cd937c..e6804e8485a3 100644
--- a/comms/apitran/Makefile
+++ b/comms/apitran/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYNUMPY} \
+ ${PY_PILLOW} \
sox:audio/sox \
display:graphics/ImageMagick6
@@ -28,14 +29,6 @@ NO_BUILD= yes
NO_ARCH= yes
SHEBANG_FILES= apitran
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/apitran ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -47,4 +40,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Examples/$f ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>