aboutsummaryrefslogtreecommitdiff
path: root/comms/atslog
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-06 20:04:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-06 20:04:24 +0000
commitaa52fa7fe434575b6e88d93871e52dd01e1a55dc (patch)
treeae4d9df17eb9d152de951d76f0a30ff306395e16 /comms/atslog
parentb28204e4f1a43efe0e6ecd1f7eb5595d5dd1be20 (diff)
downloadports-aa52fa7fe434575b6e88d93871e52dd01e1a55dc.tar.gz
ports-aa52fa7fe434575b6e88d93871e52dd01e1a55dc.zip
- Update to 2.1.1
PR: 109846 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Notes
Notes: svn path=/head/; revision=186718
Diffstat (limited to 'comms/atslog')
-rw-r--r--comms/atslog/Makefile6
-rw-r--r--comms/atslog/distinfo6
-rw-r--r--comms/atslog/files/patch-atslogd.c109
-rw-r--r--comms/atslog/files/patch-atslogmaster.in54
-rw-r--r--comms/atslog/pkg-plist5
5 files changed, 8 insertions, 172 deletions
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index 7341cda0691b..7ffe7215d9cc 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= atslog
-PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTVERSION= 2.1.1
CATEGORIES= comms
MASTER_SITES= BERLIOS
@@ -49,7 +48,6 @@ USE_PHP+= mysql
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.endif
-.include "${PORTSDIR}/Mk/bsd.php.mk"
.else
PLIST_SUB+= WWW="@comment "
.endif
@@ -92,7 +90,7 @@ do-install:
.for i in ${CONFIGS}
${INSTALL_DATA} ${WRKSRC}/include/${i} ${PREFIX}/etc/
.endfor
-.for i in atslogcleardb.pl atslogdaily atslogdb.pl atslogmaster atslogrotate
+.for i in atslogcleardb.pl atslogdb.pl atslogmaster
${INSTALL_SCRIPT} ${WRKSRC}/include/${i} ${PREFIX}/bin
.endfor
${MKDIR} ${DATADIR}/lang
diff --git a/comms/atslog/distinfo b/comms/atslog/distinfo
index 54e37929bd2e..437a00be78d5 100644
--- a/comms/atslog/distinfo
+++ b/comms/atslog/distinfo
@@ -1,3 +1,3 @@
-MD5 (atslog-2.1.0.tar.gz) = 42fc0fe0f7128f68067ed4a5f5420ab6
-SHA256 (atslog-2.1.0.tar.gz) = 6161ca706a0d5983b4fe557c9b28690f011d8f0506af4693921bc05dacf1dfd7
-SIZE (atslog-2.1.0.tar.gz) = 589123
+MD5 (atslog-2.1.1.tar.gz) = 383e8d5c46bdb14dc4c7fd11f33fc457
+SHA256 (atslog-2.1.1.tar.gz) = dd184aeac7665b37d23f09a56ed91492af599f239e2e184eecf27aed45b43315
+SIZE (atslog-2.1.1.tar.gz) = 595393
diff --git a/comms/atslog/files/patch-atslogd.c b/comms/atslog/files/patch-atslogd.c
deleted file mode 100644
index 69d22820e2c4..000000000000
--- a/comms/atslog/files/patch-atslogd.c
+++ /dev/null
@@ -1,109 +0,0 @@
---- atslogd/atslogd.c.orig Sun Jan 28 17:52:03 2007
-+++ atslogd/atslogd.c Wed Feb 14 16:22:23 2007
-@@ -143,16 +143,54 @@
- close(hCom);
- }
-
--static int
--daemonize(void)
--{
-- int rc;
-- rc = fork();
-- if (rc == (-1))
-- return (-1);
-- if (rc != 0)
-- _exit(EX_OK);
-- return rc;
-+/* taken from the http://www.developerweb.net/forum/archive/index.php/t-3025.html */
-+void daemonize(void) {
-+ int fd;
-+ switch (fork()) {
-+ case 0:
-+ break;
-+ case -1:
-+ // Error
-+ fprintf(stderr, "Error demonizing (fork)! %d - %s\n", errno, strerror(errno));
-+ exit(0);
-+ break;
-+ default:
-+ _exit(0);
-+ }
-+
-+ if (setsid() < 0) {
-+ fprintf(stderr, "Error demonizing (setsid)! %d - %s\n", errno, strerror(errno));
-+ exit(0);
-+ }
-+ switch (fork()) {
-+ case 0:
-+ break;
-+ case -1:
-+ // Error
-+ fprintf(stderr, "Error demonizing (fork2)! %d - %s\n", errno, strerror(errno));
-+ exit(0);
-+ break;
-+ default:
-+ _exit(0);
-+ }
-+ /* Are we really need this? */
-+ // chdir("/");
-+
-+ fd = open("/dev/null", O_RDONLY);
-+ if (fd != 0) {
-+ dup2(fd, 0);
-+ close(fd);
-+ }
-+ fd = open("/dev/null", O_WRONLY);
-+ if (fd != 1) {
-+ dup2(fd, 1);
-+ close(fd);
-+ }
-+ fd = open("/dev/null", O_WRONLY);
-+ if (fd != 2) {
-+ dup2(fd, 2);
-+ close(fd);
-+ }
- }
-
- FILE *
-@@ -755,6 +793,9 @@
- argc -= optind;
- argv += optind;
-
-+ if (do_daemonize)
-+ daemonize();
-+
- if (logfile) {
- errout = fopen(logfile, "at");
- if (errout == NULL) {
-@@ -772,28 +813,22 @@
- }
- my_syslog("Starting");
-
-- if (do_daemonize)
-- daemonize();
-
- pid = getpid();
--
- if (do_daemonize && pid == (-1)) {
- my_syslog("Can't become daemon, exiting");
- my_exit(1);
-- }
-+ }
- pfd = open_pid();
- if (pfd != NULL) {
-- (void)fprintf(pfd, "%ld\n", (long)pid);
-+ (void)fprintf(pfd, "%d\n", getpid());
- fclose(pfd);
- } else {
- my_syslog("Can't write to '%s' PID file, exiting", pid_file);
- my_exit(1);
- }
-
-- if (do_daemonize)
-- pid = daemonize();
-- else
-- pid = getpid();
-+ pid = getpid();
-
- if (do_daemonize && pid == (-1)) {
- my_syslog("Can't become daemon, exiting");
diff --git a/comms/atslog/files/patch-atslogmaster.in b/comms/atslog/files/patch-atslogmaster.in
deleted file mode 100644
index d6b2e228729b..000000000000
--- a/comms/atslog/files/patch-atslogmaster.in
+++ /dev/null
@@ -1,54 +0,0 @@
---- include/atslogmaster.in Sun Jan 28 17:52:01 2007
-+++ include/atslogmaster.in Wed Feb 14 16:16:05 2007
-@@ -6,6 +6,7 @@
- NOWDATE=`LANG=en_US;date`
- BASENAME=`basename $0`
- prefix=@prefix@
-+ATSLOGDpid=""
-
- # Readin config file
- if [ -r @sysconfdir@/atslog.conf ]; then
-@@ -26,10 +27,11 @@
- fi
-
- checkstatus(){
-+ ATSLOGDpid=""
- if [ -f $pidfile ] ; then
- PID=`cat $pidfile`
- if [ "x$PID" != "x" ] && kill -0 $PID 2>/dev/null ; then
-- return $PID
-+ ATSLOGDpid=$PID
- fi
- fi
- return 0
-@@ -39,10 +41,6 @@
- PATH=$PATH:$bindir:$sharedir
-
- checkstatus
--ATSLOGDpid=$?
--if [ $ATSLOGDpid -eq 0 ]; then
-- ATSLOGDpid=""
--fi
-
- case "$debug" in
- [Yy][Ee][Ss])
-@@ -98,10 +96,6 @@
- echo "$msg8"
- fi
- checkstatus
-- ATSLOGDpid=$?
-- if [ $ATSLOGDpid -eq 0 ]; then
-- ATSLOGDpid=""
-- fi
- startloging
- if [ $? -eq 0 ]
- then
-@@ -159,7 +153,7 @@
- fi
- sleep 1;
- checkstatus
-- if [ $? -eq 0 ];then
-+ if [ -z ATSLOGDpid ];then
- TORETURN=1; # atslogd not started
- ERRORMESSAGE=$msg4
- echomess
diff --git a/comms/atslog/pkg-plist b/comms/atslog/pkg-plist
index f67ddb21b155..7e0b6e3aad19 100644
--- a/comms/atslog/pkg-plist
+++ b/comms/atslog/pkg-plist
@@ -2,14 +2,13 @@
%%WWW%%@unexec if cmp -s %D/www/atslog/include/config.inc.php %D/www/atslog/include/config.inc.php.default; then rm -f %D/www/atslog/include/config.inc.php; fi
bin/atslogcleardb.pl
bin/atslogd
-bin/atslogdaily
bin/atslogdb.pl
bin/atslogmaster
-bin/atslogrotate
etc/atslog.conf.default
@exec [ -f %B/atslog.conf ] || cp %B/%f %B/atslog.conf
etc/atslog.conf.default.rus
libexec/atslog/4200e.lib
+libexec/atslog/bp-250.lib
libexec/atslog/gd-320.lib
libexec/atslog/gdk-100.lib
libexec/atslog/genindex.sh
@@ -61,6 +60,7 @@ libexec/atslog/skp-816.lib
%%EXAMPLESDIR%%/textlogs/Multicom MAXICOM MP80.TXT
%%EXAMPLESDIR%%/textlogs/Multicom Maxicom MXM300.txt
%%EXAMPLESDIR%%/textlogs/NEC NEAX2000 IPS.txt
+%%EXAMPLESDIR%%/textlogs/NEC NEAX7400 ICS m100.txt
%%EXAMPLESDIR%%/textlogs/Panasonic 816.txt
%%EXAMPLESDIR%%/textlogs/Panasonic DBS-90.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-T1232-RU.txt
@@ -83,6 +83,7 @@ libexec/atslog/skp-816.lib
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 A.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 B.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 C.txt
+%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA600.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TEM824.txt
%%EXAMPLESDIR%%/textlogs/Samsung DCS Compact II.txt
%%EXAMPLESDIR%%/textlogs/Samsung DCS.txt