aboutsummaryrefslogtreecommitdiff
path: root/comms/atslog
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-25 13:36:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-25 13:36:26 +0000
commitb7af2d713b0dc71cbaff811ce5b0721ddf5e070b (patch)
tree85636ed4027cc303b6165a6aa0236f446b77e8c3 /comms/atslog
parent833d870560a5331d2e7b210ecfe6d1d4705ff1a9 (diff)
downloadports-b7af2d713b0dc71cbaff811ce5b0721ddf5e070b.tar.gz
ports-b7af2d713b0dc71cbaff811ce5b0721ddf5e070b.zip
- Switch to options helpers
- Add LICENSE
Notes
Notes: svn path=/head/; revision=446583
Diffstat (limited to 'comms/atslog')
-rw-r--r--comms/atslog/Makefile58
1 files changed, 29 insertions, 29 deletions
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index 85dd1043020e..743b05275298 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -10,25 +10,41 @@ MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= Software for collecting and analyzing calls from different PBX models
-OPTIONS_DEFINE= EXAMPLES LIBWRAP WWW WWWGD DOCS
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5 shebangfix
+SHEBANG_FILES= data/sql/install-sql.pl \
+ include/atslogcleardb.pl.in include/atslogdb.pl.in
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var
+
+USE_RC_SUBR= ${PORTNAME}d
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+
+SUB_FILES= pkg-message
+
+PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL TODO UPDATING USAGE
+
+OPTIONS_DEFINE= EXAMPLES LIBWRAP WWW WWWGD DOCS
OPTIONS_DEFAULT= LIBWRAP MYSQL WWW WWWGD
-OPTIONS_MULTI= DB
+OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= PGSQL MYSQL
+OPTIONS_SUB= yes
+
LIBWRAP_DESC= Enable TCP wrapper support
WWW_DESC= Install web interface
WWWGD_DESC= Graphic reports
-GNU_CONFIGURE= yes
-USES= perl5 shebangfix
-USE_RC_SUBR= ${PORTNAME}d
-SHEBANG_FILES= data/sql/install-sql.pl \
- include/atslogcleardb.pl.in include/atslogdb.pl.in
-PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL LICENSE TODO UPDATING USAGE
-SUB_FILES= pkg-message
-CONFIGS= ${PORTNAME}.conf.default ${PORTNAME}.conf.default.rus
-CONFIGURE_ARGS+=--localstatedir=/var
-PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
-OPTIONS_SUB=yes
+MYSQL_USES= mysql
+MYSQL_BUILD_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+MYSQL_RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql
+
+PGSQL_USES= pgsql
+PGSQL_BUILD_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
+PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
+
+LIBWRAP_CONFIGURE_OFF= --disable-libwrap
.include <bsd.port.options.mk>
@@ -46,22 +62,6 @@ USE_PHP+= pgsql
.endif
.endif
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-BUILD_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
-RUN_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-BUILD_DEPENDS+= p5-DBD-Pg>=0:databases/p5-DBD-Pg
-RUN_DEPENDS+= p5-DBD-Pg>=0:databases/p5-DBD-Pg
-.endif
-
-.if ! ${PORT_OPTIONS:MLIBWRAP}
-CONFIGURE_ARGS+=--disable-libwrap
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|createsqltables.|${DATADIR}/sql/createsqltables.|g' \
-e 's|data.sql|${DATADIR}/sql/data.sql|' ${WRKSRC}/data/sql/install-sql.pl