aboutsummaryrefslogtreecommitdiff
path: root/comms/bforce-kst
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-04 17:02:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-04 17:02:55 +0000
commit53e5d1a39cf150321aa98279fbc0e0a3f60d90f2 (patch)
treef3ca65e9024243a20462ad96a641ca78437d7e58 /comms/bforce-kst
parentbe07c56f120b6f337aece95516a93f323e721cd5 (diff)
downloadports-53e5d1a39cf150321aa98279fbc0e0a3f60d90f2.tar.gz
ports-53e5d1a39cf150321aa98279fbc0e0a3f60d90f2.zip
- Add patch to fix sending HUP to daemon
- Add patch to fix emsi traffic information - Install docs and utils from contrib - Fix pkg-message PR: ports/67557 Submitted by: Andrey Slusar <vasallia@ukr.net> (maintainer)
Notes
Notes: svn path=/head/; revision=110834
Diffstat (limited to 'comms/bforce-kst')
-rw-r--r--comms/bforce-kst/Makefile19
-rw-r--r--comms/bforce-kst/files/patch-daemon.c17
-rw-r--r--comms/bforce-kst/files/patch-prot_emsi.c20
-rw-r--r--comms/bforce-kst/pkg-message9
-rw-r--r--comms/bforce-kst/pkg-plist31
5 files changed, 94 insertions, 2 deletions
diff --git a/comms/bforce-kst/Makefile b/comms/bforce-kst/Makefile
index 1a6ec2eb24c8..b7eea7b3600d 100644
--- a/comms/bforce-kst/Makefile
+++ b/comms/bforce-kst/Makefile
@@ -23,6 +23,13 @@ GNU_CONFIGURE= yes
CONFIGDIR= etc/fido/bforce
+CONTRIBS= bfha/README bfha/bfha.pl bflan callout.sh outman timesync.tcl \
+ u-srif/conf/report.footer u-srif/conf/report.header u-srif/conf/u-srif.aliases \
+ u-srif/conf/u-srif.conf u-srif/conf/u-srif.dirs u-srif/lib/uconfig.py \
+ u-srif/lib/udbase.py u-srif/lib/ufido.py u-srif/lib/unodestat.py \
+ u-srif/lib/utmpl.py u-srif/lib/uutil.py u-srif/u-srif-index.py \
+ u-srif/u-srif-lookup.py u-srif/u-srif.py
+
FIXME= include/bforce.h include/util.h include/logger.h \
bforce/bforce.c bforce/conf_proc.c bforce/conf_read.c bforce/daemon.c \
bforce/daemon_branch.c bforce/daemon_call.c bforce/daemon_lines.c \
@@ -56,9 +63,21 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../examples/bforce.subst ${PREFIX}/${CONFIGDIR}/bforce.subst.sample
${INSTALL_DATA} ${WRKSRC}/../examples/freq.aliases ${PREFIX}/${CONFIGDIR}/freq.aliases.sample
${INSTALL_DATA} ${WRKSRC}/../examples/freq.dirs ${PREFIX}/${CONFIGDIR}/freq.dirs.sample
+
+ ${MKDIR} ${DATADIR} ${DATADIR}/bfha ${DATADIR}/u-srif/conf ${DATADIR}/u-srif/lib
+.for i in ${CONTRIBS}
+ ${INSTALL_DATA} ${WRKSRC}/../contrib/${i} ${DATADIR}/${i}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in CHANGES CHANGES.kst COPYING README README.kst
+ ${INSTALL_DATA} ${WRKSRC}/../${i} ${DOCSDIR}
+.endfor
+.endif
${INSTALL_PROGRAM} ${WRKSRC}/bin/bforce ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/bfindex ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/bfstat ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/nlookup ${PREFIX}/bin
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|' -e 's|%%CONFIGDIR%%|${CONFIGDIR}|' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/comms/bforce-kst/files/patch-daemon.c b/comms/bforce-kst/files/patch-daemon.c
new file mode 100644
index 000000000000..48abb4e97450
--- /dev/null
+++ b/comms/bforce-kst/files/patch-daemon.c
@@ -0,0 +1,17 @@
+--- bforce/daemon.c.old Tue Jun 1 16:14:31 2004
++++ bforce/daemon.c Tue Jun 1 16:20:15 2004
+@@ -772,10 +772,13 @@
+ fclose(pf);
+
+ if (hispid != 0) {
++ if (hispid == mypid)
++ return 0;
+ if (kill(hispid, 0) == 0) {
+ log("daemon_pidfile: another daemon exist. pid=%d", hispid);
+ return (-1);
+- } else if(errno != ESRCH) {
++ }
++ if (errno != ESRCH) {
+ log("daemon_pidfile: error sending signal. pid=%d, errno=%d", hispid, errno);
+ return (-1);
+ }
diff --git a/comms/bforce-kst/files/patch-prot_emsi.c b/comms/bforce-kst/files/patch-prot_emsi.c
new file mode 100644
index 000000000000..53ce650c97e8
--- /dev/null
+++ b/comms/bforce-kst/files/patch-prot_emsi.c
@@ -0,0 +1,20 @@
+diff -ruN bforce-0.22.8.kst7/source/bforce/prot_emsi.c bforce-0.22.8.kst8/source/bforce/prot_emsi.c
+--- bforce/prot_emsi.c Thu Nov 21 23:22:56 2002
++++ bforce/prot_emsi.c Sat Nov 30 01:41:15 2002
+@@ -829,10 +829,14 @@
+ /* ----------------------------------------------------------------- */
+ if( state.caller == 0 && hrc != HRC_BAD_PASSWD )
+ {
+- emsi->have_traf = emsi->have_moh = 1;
++ emsi->have_traf = 1;
+ emsi->netmail_size = state.traff_send.netmail_size;
+ emsi->arcmail_size = state.traff_send.arcmail_size;
+- emsi->files_size = state.traff_send.files_size;
++ if ( state.traff_send.files_size )
++ {
++ emsi->have_moh = 1;
++ emsi->files_size = state.traff_send.files_size;
++ }
+ }
+ }
+
diff --git a/comms/bforce-kst/pkg-message b/comms/bforce-kst/pkg-message
index dde77ba4972f..6dda1551e437 100644
--- a/comms/bforce-kst/pkg-message
+++ b/comms/bforce-kst/pkg-message
@@ -1,3 +1,8 @@
+**************************************************************
+
Please don't forget to copy and edit configuration files found
-in ${PREFIX}/etc/bforce.END-of-bforce-kst/pkg-message
-exit
+in %%PREFIX%%/%%CONFIGDIR%%.
+
+If you using u-srif, please install lang/python
+
+**************************************************************
diff --git a/comms/bforce-kst/pkg-plist b/comms/bforce-kst/pkg-plist
index 09dcd52e34c2..6d9f737d45d7 100644
--- a/comms/bforce-kst/pkg-plist
+++ b/comms/bforce-kst/pkg-plist
@@ -7,4 +7,35 @@ bin/nlookup
%%CONFIGDIR%%/bforce.subst.sample
%%CONFIGDIR%%/freq.aliases.sample
%%CONFIGDIR%%/freq.dirs.sample
+%%DATADIR%%/bfha/README
+%%DATADIR%%/bfha/bfha.pl
+%%DATADIR%%/bflan
+%%DATADIR%%/callout.sh
+%%DATADIR%%/outman
+%%DATADIR%%/timesync.tcl
+%%DATADIR%%/u-srif/conf/report.footer
+%%DATADIR%%/u-srif/conf/report.header
+%%DATADIR%%/u-srif/conf/u-srif.aliases
+%%DATADIR%%/u-srif/conf/u-srif.conf
+%%DATADIR%%/u-srif/conf/u-srif.dirs
+%%DATADIR%%/u-srif/lib/uconfig.py
+%%DATADIR%%/u-srif/lib/udbase.py
+%%DATADIR%%/u-srif/lib/ufido.py
+%%DATADIR%%/u-srif/lib/unodestat.py
+%%DATADIR%%/u-srif/lib/utmpl.py
+%%DATADIR%%/u-srif/lib/uutil.py
+%%DATADIR%%/u-srif/u-srif-index.py
+%%DATADIR%%/u-srif/u-srif-lookup.py
+%%DATADIR%%/u-srif/u-srif.py
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.kst
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.kst
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%CONFIGDIR%%
+@dirrm %%DATADIR%%/u-srif/lib
+@dirrm %%DATADIR%%/u-srif/conf
+@dirrm %%DATADIR%%/u-srif
+@dirrm %%DATADIR%%/bfha
+@dirrm %%DATADIR%%