aboutsummaryrefslogtreecommitdiff
path: root/comms/chu
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-04 22:12:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-04 22:12:35 +0000
commit5b2e3a81ea621a8c7c5ac5e310798068f6ef6a91 (patch)
tree990f57545c45bfabcc5d2272c3d5ee7e9de371d2 /comms/chu
parent903cc2dfd751ff3c94ac4928a8889192daecf5f3 (diff)
downloadports-5b2e3a81ea621a8c7c5ac5e310798068f6ef6a91.tar.gz
ports-5b2e3a81ea621a8c7c5ac5e310798068f6ef6a91.zip
Fix extraction
Notes
Notes: svn path=/head/; revision=317378
Diffstat (limited to 'comms/chu')
-rw-r--r--comms/chu/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/comms/chu/Makefile b/comms/chu/Makefile
index c6404c19fbec..ce043b9f0e69 100644
--- a/comms/chu/Makefile
+++ b/comms/chu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: chu
-# Date created: September 16 2006
-# Whom: Diane Bruce <db@db.net>
-#
+# Created by: Diane Bruce <db@db.net>
# $FreeBSD$
-#
PORTNAME= chu
PORTVERSION= 0.1.29
@@ -17,6 +13,8 @@ COMMENT= Synchronise computer clock to CHU radio station
MAN8= chu.8
+.include <bsd.port.options.mk>
+
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
@@ -27,7 +25,7 @@ do-extract:
exit 1; \
fi \
done
- ${EXTRACT_CMD} -d ${WRKSRC}/testsignal.gz
+ ${GZIP_CMD} -d ${WRKSRC}/testsignal.gz
post-patch:
${REINPLACE_CMD} -e 's|/etc/chu|${PREFIX}/etc/chu|g' ${WRKSRC}/chu.c ${WRKSRC}/chu.8
@@ -39,7 +37,7 @@ do-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/testsignal ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/chu.8 ${PREFIX}/man/man8
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for d in ${WRKSRC}/COPYING \
${WRKSRC}/TESTING \