aboutsummaryrefslogtreecommitdiff
path: root/comms/chu
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-07-14 09:02:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-07-14 09:02:13 +0000
commitf0860c7548b90ca08768b9f9f5be7af2650d14f1 (patch)
tree9a0d57ca771ae1ff84bf4a67aa3bc44cea23545d /comms/chu
parentce252e6399d0a8d742928fe372a3bb28cc941227 (diff)
downloadports-f0860c7548b90ca08768b9f9f5be7af2650d14f1.tar.gz
ports-f0860c7548b90ca08768b9f9f5be7af2650d14f1.zip
- Fix LICENSE
- Add LICENSE_FILE - Switch to options helpers - Regenerate patch - Update WWW - Don't install license with docs Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=506613
Diffstat (limited to 'comms/chu')
-rw-r--r--comms/chu/Makefile11
-rw-r--r--comms/chu/files/patch-chu.c16
-rw-r--r--comms/chu/pkg-descr2
-rw-r--r--comms/chu/pkg-plist1
4 files changed, 16 insertions, 14 deletions
diff --git a/comms/chu/Makefile b/comms/chu/Makefile
index 28326fea7cd3..425c2974290f 100644
--- a/comms/chu/Makefile
+++ b/comms/chu/Makefile
@@ -9,7 +9,8 @@ MASTER_SITES= SUNSITE/system/admin/time
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Synchronise computer clock to CHU radio station
-LICENSE= GPLv1
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
NO_WRKSUBDIR= yes
@@ -25,11 +26,13 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/chu ${STAGEDIR}${PREFIX}/sbin
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/testsignal ${STAGEDIR}${DATADIR}
${INSTALL_MAN} ${WRKSRC}/chu.8 ${STAGEDIR}${PREFIX}/man/man8
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for d in COPYING TESTING chu.html chuman.html ntp.html
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for d in TESTING chu.html chuman.html ntp.html
${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/comms/chu/files/patch-chu.c b/comms/chu/files/patch-chu.c
index bdb6addc3d78..419b133f7c42 100644
--- a/comms/chu/files/patch-chu.c
+++ b/comms/chu/files/patch-chu.c
@@ -1,5 +1,5 @@
---- chu.c.orig 1999-03-17 11:42:18.000000000 -0500
-+++ chu.c 2011-07-01 08:42:06.000000000 -0400
+--- chu.c.orig 1999-03-17 16:42:18 UTC
++++ chu.c
@@ -20,15 +20,21 @@
#include <stdlib.h>
#include <string.h>
@@ -24,7 +24,7 @@
#define SAMPLE_RATE 8000
#define SAMPLES 512
#define OVERLAP 50
-@@ -389,6 +395,21 @@
+@@ -389,6 +395,21 @@ void saveAdjTime()
}
}
@@ -46,7 +46,7 @@
#ifdef USE_TIMEX
void timex_adjustment(int microsec)
{
-@@ -462,7 +483,8 @@
+@@ -462,7 +483,8 @@ double gettimexoffset()
adjtimex(&t);
offset = t.offset;
#endif
@@ -56,7 +56,7 @@
return (double) offset;
}
-@@ -655,13 +677,18 @@
+@@ -655,13 +677,18 @@ void adj_time(double d)
tv.tv_usec += 1000000;
}
@@ -75,7 +75,7 @@
{
printf("standard adjustment ");
-@@ -1267,7 +1294,7 @@
+@@ -1267,7 +1294,7 @@ char *parseArgs(int argc, char **argv)
return fname;
}
@@ -84,7 +84,7 @@
{
FILE *fp;
signed char buf[8192];
-@@ -1278,7 +1305,7 @@
+@@ -1278,7 +1305,7 @@ void main(int argc, char **argv)
fname = parseArgs(argc, argv);
if (fname == NULL)
@@ -93,7 +93,7 @@
/* Set priority to maximum -- just long enough for us
to open the audio device and timestamp it. This should
-@@ -1293,7 +1320,7 @@
+@@ -1293,7 +1320,7 @@ void main(int argc, char **argv)
if (fp == NULL)
{
printf("fopen(): Unable to open file: %s %s\n", fname, strerror(errno));
diff --git a/comms/chu/pkg-descr b/comms/chu/pkg-descr
index 0d5f81f06876..7d2f1ad2b0ac 100644
--- a/comms/chu/pkg-descr
+++ b/comms/chu/pkg-descr
@@ -3,4 +3,4 @@ Research Council Canada (NRC). This software uses signals from radio
station CHU to set and frequency discipline the system clock on a
Linux (FreeBSD) based system.
-WWW: http://www.rossi.com/chu/
+WWW: https://www.rossi.com/chu/
diff --git a/comms/chu/pkg-plist b/comms/chu/pkg-plist
index 1f4ef72a6d2e..331061c9726b 100644
--- a/comms/chu/pkg-plist
+++ b/comms/chu/pkg-plist
@@ -1,6 +1,5 @@
sbin/chu
%%DATADIR%%/testsignal
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/chu.html
%%PORTDOCS%%%%DOCSDIR%%/chuman.html
%%PORTDOCS%%%%DOCSDIR%%/ntp.html