aboutsummaryrefslogtreecommitdiff
path: root/comms/cubicsdr
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-01-13 02:37:22 +0000
committerDiane Bruce <db@FreeBSD.org>2020-01-13 02:37:22 +0000
commit570910e4ca24b2c0a9c47375d50e33f9e53001b4 (patch)
tree7cfc1420ac70deaba9031f8ef03113c58e05405b /comms/cubicsdr
parent29a472d2b35f33f2006c2a01c1e408cc9dda6c2a (diff)
downloadports-570910e4ca24b2c0a9c47375d50e33f9e53001b4.tar.gz
ports-570910e4ca24b2c0a9c47375d50e33f9e53001b4.zip
Notes
Diffstat (limited to 'comms/cubicsdr')
-rw-r--r--comms/cubicsdr/Makefile10
-rw-r--r--comms/cubicsdr/distinfo6
-rw-r--r--comms/cubicsdr/files/patch-src_AppFrame.cpp20
-rw-r--r--comms/cubicsdr/files/patch-src_CubicSDRDefs.h30
-rw-r--r--comms/cubicsdr/files/patch-src_DemodLabelDialog.cpp11
-rw-r--r--comms/cubicsdr/files/patch-src_FrequencyDialog.cpp11
-rw-r--r--comms/cubicsdr/files/patch-src_util_GLExt.cpp20
-rw-r--r--comms/cubicsdr/files/patch-src_util_MouseTracker.cpp11
8 files changed, 7 insertions, 112 deletions
diff --git a/comms/cubicsdr/Makefile b/comms/cubicsdr/Makefile
index 1af7bfc03491..bc0b04264776 100644
--- a/comms/cubicsdr/Makefile
+++ b/comms/cubicsdr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cubicsdr
DISTVERSION= 0.2.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org
@@ -11,8 +11,6 @@ COMMENT= SDR receiver using liquidsdr
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to build
-
RUN_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/lib/libEGL.so:graphics/mesa-libs \
${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri
@@ -38,11 +36,11 @@ CMAKE_ARGS+= -DUSE_HAMLIB=1
.endif
CMAKE_ARGS+= -DwxWidgets_CONFIG_EXECUTABLE=${LOCALBASE}/bin/wxgtk3u-3.1-config
-# if Only I could just do
-#USE_WX= 3.1
-#WX_COMPS= wx
+USE_WX= 3.1
+WX_COMPS= wx
USE_GITHUB= yes
GH_ACCOUNT= cjcliffe
GH_PROJECT= CubicSDR
+GH_TAGNAME= 9c32b97
.include <bsd.port.post.mk>
diff --git a/comms/cubicsdr/distinfo b/comms/cubicsdr/distinfo
index 7155e766dfa5..3211a9ed36ba 100644
--- a/comms/cubicsdr/distinfo
+++ b/comms/cubicsdr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551114984
-SHA256 (cjcliffe-CubicSDR-0.2.5_GH0.tar.gz) = 5cb44c110fcbbb70a468b7fa402cf35f84d8901b3dd42d471a90ac3f5db00f4d
-SIZE (cjcliffe-CubicSDR-0.2.5_GH0.tar.gz) = 36911106
+TIMESTAMP = 1578325251
+SHA256 (cjcliffe-CubicSDR-0.2.5-9c32b97_GH0.tar.gz) = 46eb12b942c7e38dbfe8a84448a3721b5d9c7c1fd8878f8cad7bd37806352dbf
+SIZE (cjcliffe-CubicSDR-0.2.5-9c32b97_GH0.tar.gz) = 35466535
diff --git a/comms/cubicsdr/files/patch-src_AppFrame.cpp b/comms/cubicsdr/files/patch-src_AppFrame.cpp
deleted file mode 100644
index d368a06deb61..000000000000
--- a/comms/cubicsdr/files/patch-src_AppFrame.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/AppFrame.cpp.orig 2019-02-25 02:52:05 UTC
-+++ src/AppFrame.cpp
-@@ -34,7 +34,7 @@
- #include <wx/numformatter.h>
- #include <stddef.h>
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- #include "CubicSDR.xpm"
- #endif
-
-@@ -79,7 +79,7 @@ std::vector<std::string> str_explode(const std::string
- AppFrame::AppFrame() :
- wxFrame(NULL, wxID_ANY, CUBICSDR_TITLE), activeDemodulator(nullptr) {
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- SetIcon(wxICON(cubicsdr));
- #endif
-
diff --git a/comms/cubicsdr/files/patch-src_CubicSDRDefs.h b/comms/cubicsdr/files/patch-src_CubicSDRDefs.h
deleted file mode 100644
index 62f415e50ca0..000000000000
--- a/comms/cubicsdr/files/patch-src_CubicSDRDefs.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/CubicSDRDefs.h.orig 2018-06-08 03:58:55 UTC
-+++ src/CubicSDRDefs.h
-@@ -2,6 +2,7 @@
- // SPDX-License-Identifier: GPL-2.0+
-
- #pragma once
-+#include <sys/param.h>
-
- #define CUBICSDR_TITLE "" CUBICSDR_BUILD_TITLE
-
-@@ -16,7 +17,11 @@
- #ifdef __APPLE__
- #include <machine/endian.h>
- #else
-- #include <endian.h>
-+ #ifdef __FreeBSD__
-+ #include <sys/endian.h>
-+ #else
-+ #include <endian.h>
-+ #endif
- #endif
- #endif
- #endif
-@@ -62,4 +67,4 @@ const char filePathSeparator =
-
- //The maximum number of listed sample rates for a device, to be able to handle
- //devices returning an insane amount because they have quasi-continuous ranges (UHD...)
--#define DEVICE_SAMPLE_RATES_MAX_NB 25
-\ No newline at end of file
-+#define DEVICE_SAMPLE_RATES_MAX_NB 25
diff --git a/comms/cubicsdr/files/patch-src_DemodLabelDialog.cpp b/comms/cubicsdr/files/patch-src_DemodLabelDialog.cpp
deleted file mode 100644
index 43737d176feb..000000000000
--- a/comms/cubicsdr/files/patch-src_DemodLabelDialog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/DemodLabelDialog.cpp.orig 2019-02-25 02:53:22 UTC
-+++ src/DemodLabelDialog.cpp
-@@ -83,7 +83,7 @@ void DemodLabelDialog::OnChar(wxKeyEvent& event) {
-
- }
- else {
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- dialogText->OnChar(event);
- event.Skip();
- #else
diff --git a/comms/cubicsdr/files/patch-src_FrequencyDialog.cpp b/comms/cubicsdr/files/patch-src_FrequencyDialog.cpp
deleted file mode 100644
index 7a2b3e56086e..000000000000
--- a/comms/cubicsdr/files/patch-src_FrequencyDialog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/FrequencyDialog.cpp.orig 2019-02-25 02:39:08 UTC
-+++ src/FrequencyDialog.cpp
-@@ -218,7 +218,7 @@ void FrequencyDialog::OnChar(wxKeyEvent& event) {
-
- if (allowed.find_first_of(c) != std::string::npos || c == WXK_DELETE || c == WXK_BACK || c == WXK_NUMPAD_DECIMAL
- || (c >= WXK_NUMPAD0 && c <= WXK_NUMPAD9)) {
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- dialogText->OnChar(event);
- event.Skip();
- #else
diff --git a/comms/cubicsdr/files/patch-src_util_GLExt.cpp b/comms/cubicsdr/files/patch-src_util_GLExt.cpp
deleted file mode 100644
index 465e2166a0ab..000000000000
--- a/comms/cubicsdr/files/patch-src_util_GLExt.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/util/GLExt.cpp.orig 2018-08-20 16:53:40 UTC
-+++ src/util/GLExt.cpp
-@@ -9,7 +9,7 @@
- #include <OpenGL/OpenGL.h>
- #endif
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- #include <dlfcn.h>
- #endif
-
-@@ -60,7 +60,7 @@ void initGLExtensions() {
- CGLSetParameter (CGLGetCurrentContext(), kCGLCPSwapInterval, &interval);
- #endif
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- dlopen("libglx.so",RTLD_LAZY);
-
- void (*glxSwapIntervalEXTFunc) (Display *dpy, GLXDrawable drawable, int interval) = 0;
diff --git a/comms/cubicsdr/files/patch-src_util_MouseTracker.cpp b/comms/cubicsdr/files/patch-src_util_MouseTracker.cpp
deleted file mode 100644
index 78697950894e..000000000000
--- a/comms/cubicsdr/files/patch-src_util_MouseTracker.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/util/MouseTracker.cpp.orig 2019-02-25 12:54:38 UTC
-+++ src/util/MouseTracker.cpp
-@@ -30,7 +30,7 @@ void MouseTracker::OnMouseMoved(wxMouseEvent& event) {
-
- if (isMouseDown || isMouseRightDown) {
- #ifndef __APPLE__
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__)
- if (horizDragLock && vertDragLock) {
- target->WarpPointer(originMouseX * ClientSize.x, (1.0 - originMouseY) * ClientSize.y);
- mouseX = originMouseX;