aboutsummaryrefslogtreecommitdiff
path: root/comms/cwdaemon
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-12-29 16:17:51 +0000
committerDiane Bruce <db@FreeBSD.org>2013-12-29 16:17:51 +0000
commitb6b117d865386fede39c705076d99009a84db691 (patch)
treeb0fbfd27bf154adf7394ce45a8259612b8902cb4 /comms/cwdaemon
parent3181f247ac1fad7e1b68384dad797a94af3dd8a3 (diff)
downloadports-b6b117d865386fede39c705076d99009a84db691.tar.gz
ports-b6b117d865386fede39c705076d99009a84db691.zip
- convert to stage
- add LICENSE - patch to use new libcw lib from unixcw
Notes
Notes: svn path=/head/; revision=338022
Diffstat (limited to 'comms/cwdaemon')
-rw-r--r--comms/cwdaemon/Makefile16
-rw-r--r--comms/cwdaemon/files/patch-cwdaemon.c29
-rw-r--r--comms/cwdaemon/pkg-plist1
3 files changed, 34 insertions, 12 deletions
diff --git a/comms/cwdaemon/Makefile b/comms/cwdaemon/Makefile
index b00ba8c89846..902acd695c62 100644
--- a/comms/cwdaemon/Makefile
+++ b/comms/cwdaemon/Makefile
@@ -5,26 +5,18 @@ PORTNAME= cwdaemon
PORTVERSION= 0.9.4
CATEGORIES= comms hamradio
MASTER_SITES= http://www.chronos.org.uk/download/ \
- ${MASTER_SITE_LOCAL}
+ ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio cw (Morse code) keyer daemon
+LICENSE= GPLv2
+
LIB_DEPENDS= libcw.so:${PORTSDIR}/comms/unixcw
+CONFIGURE_ARGS+= --datadir=${PREFIX}/share/doc
-INSTALL_TARGET= install-exec
GNU_CONFIGURE= yes
USES= pkgconfig
-CONFIGURE_ARGS+= --datadir=${PREFIX}/share/doc
-MAN8= cwdaemon.8
-
-NO_STAGE= yes
-post-install:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${MAKE} install-data
-.else
- cd ${WRKSRC}; ${MAKE} install-man
-.endif
.include <bsd.port.mk>
diff --git a/comms/cwdaemon/files/patch-cwdaemon.c b/comms/cwdaemon/files/patch-cwdaemon.c
new file mode 100644
index 000000000000..082acbf948ed
--- /dev/null
+++ b/comms/cwdaemon/files/patch-cwdaemon.c
@@ -0,0 +1,29 @@
+--- cwdaemon.c.orig 2006-11-09 04:23:11.000000000 -0500
++++ cwdaemon.c 2013-12-29 10:11:15.000000000 -0500
+@@ -89,7 +89,7 @@
+ #endif
+ #include <limits.h>
+
+-#include <cwlib.h>
++#include <libcw.h>
+ #include "cwdaemon.h"
+
+ /* network vars */
+@@ -305,8 +305,6 @@
+ {
+ cw_set_frequency (morse_tone);
+ cw_set_send_speed (morse_speed);
+- cw_set_soundcard_sound (soundcard_sound);
+- cw_set_console_sound (console_sound);
+ cw_set_volume (morse_volume);
+ cw_set_gap (0);
+ }
+@@ -559,8 +557,6 @@
+ if (valid_sdevice == 1)
+ {
+ debug ("Sound device: %s", message + 2);
+- cw_set_soundcard_sound (soundcard_sound);
+- cw_set_console_sound (console_sound);
+ }
+ break;
+ case 'g': /* volume */
diff --git a/comms/cwdaemon/pkg-plist b/comms/cwdaemon/pkg-plist
index b5971ab2a247..e61567b160e7 100644
--- a/comms/cwdaemon/pkg-plist
+++ b/comms/cwdaemon/pkg-plist
@@ -1,4 +1,5 @@
sbin/cwdaemon
+man/man8/cwdaemon.8.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/cwdaemon.png
%%PORTDOCS%%%%DOCSDIR%%/cwsetup.sh