aboutsummaryrefslogtreecommitdiff
path: root/comms/dcf77pi
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-09-18 11:56:52 +0000
committerRene Ladan <rene@FreeBSD.org>2014-09-18 11:56:52 +0000
commitdffe241cd2219d36d4bb178e5a5ec74d779c9ce1 (patch)
tree55d19d7f3b5f2b0f31bf8392853d1e4e1a949d61 /comms/dcf77pi
parent24180189d4842aa82168463e6d8e3bd704d22c9e (diff)
downloadports-dffe241cd2219d36d4bb178e5a5ec74d779c9ce1.tar.gz
ports-dffe241cd2219d36d4bb178e5a5ec74d779c9ce1.zip
- Update comms/dcf77pi to version 3.2.0
- Use USE_LDCONFIG Overall changes: - Compile with -fpic instead of -fPIC (potentially smaller code size) - Add a schematics file for the hardware receiver in FidoCadJ format - Language and typographical updates to README.md - Several signed/unsigned/size fixes Library changes: - Extract generic third-party code for bits 1..14 from decode_alarm.h into a new file bits1to14.h - Convert almost all calculations for decoding the live signal into integer operations, drop fields 'a', 'frac', and 'maxone' from struct bitinfo. - New function setclock_ok() in setclock.h - New functions get_acc_minlen(), add_acc_minlen(), reset_acc_minlen() in decode_time.h. The accumulated minute length is now a first-class entity. When decoding the live signal, increment it more precisely than just 1000 ms/s to prevent drift during bad radio reception. - New functions dcftime() and isotime() in decode_time.h. Use the latter in setclock.c - Check input values of etc/config.txt: - hw.active_high must be 0 or 1 - hw.freq must be even between 10 and 666666 - Reset the values of bit0 and bit20 if the latter becomes smaller than the former, show this in the log file using a '!' - Compact the signal buffer, it now stores 8 pulses per byte instead of just 1. Client changes: - Make dcf77pi and dcf77pi-analyze more agnostic of the contents of the third-party contents - Update display code of dcf77pi and readpin for the updates to the live signal decoding - Show in dcf77pi when the value of bit20 underflows - Update the code to display the signal buffer in readpin - Fix readpin to properly clean up when receiving a SIGINT
Notes
Notes: svn path=/head/; revision=368444
Diffstat (limited to 'comms/dcf77pi')
-rw-r--r--comms/dcf77pi/Makefile6
-rw-r--r--comms/dcf77pi/distinfo4
-rw-r--r--comms/dcf77pi/files/patch-d3ab07122
-rw-r--r--comms/dcf77pi/pkg-plist1
4 files changed, 6 insertions, 27 deletions
diff --git a/comms/dcf77pi/Makefile b/comms/dcf77pi/Makefile
index d297351c650a..cd117d14cbaa 100644
--- a/comms/dcf77pi/Makefile
+++ b/comms/dcf77pi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dcf77pi
-PORTVERSION= 3.1.0
-PORTREVISION= 1
+PORTVERSION= 3.2.0
CATEGORIES= comms
MAINTAINER= rene@FreeBSD.org
@@ -13,9 +12,10 @@ LICENSE= BSD2CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= rene0
-GH_COMMIT= d441662
+GH_COMMIT= 671961e
USES= ncurses
+USE_LDCONFIG= yes
PATCH_STRIP= -p1
PORTDOCS= README.md
diff --git a/comms/dcf77pi/distinfo b/comms/dcf77pi/distinfo
index 94fec4ba4bc2..90dc56e4e91f 100644
--- a/comms/dcf77pi/distinfo
+++ b/comms/dcf77pi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dcf77pi-3.1.0.tar.gz) = e47f31c2c1e9fee5185e71f0c4229a8be870caeae1e0f046b5259d0d4382a001
-SIZE (dcf77pi-3.1.0.tar.gz) = 20560
+SHA256 (dcf77pi-3.2.0.tar.gz) = 9d6754dd19e678e05c72d48fc2ee27fc7d84c7ec5c2fd7d1141638a00f2ee87c
+SIZE (dcf77pi-3.2.0.tar.gz) = 22307
diff --git a/comms/dcf77pi/files/patch-d3ab071 b/comms/dcf77pi/files/patch-d3ab071
deleted file mode 100644
index 87cd6b30d910..000000000000
--- a/comms/dcf77pi/files/patch-d3ab071
+++ /dev/null
@@ -1,22 +0,0 @@
-commit d3ab071432f052c799dc5c77035913423abd16c4
-Author: René Ladan <r.c.ladan@gmail.com>
-Date: Sun Jul 20 12:44:57 2014 +0200
-
- dcf77pi: fix display of freq_reset
-
-diff --git a/dcf77pi.c b/dcf77pi.c
-index 2e46911..ce61d51 100644
---- a/dcf77pi.c
-+++ b/dcf77pi.c
-@@ -218,9 +218,9 @@ display_bit_gui(uint16_t state, int bitpos)
- bitinf->realfreq, (int)bitinf->bit0, (int)bitinf->bit20,
- bitinf->maxone * 100, bitinf->a);
- if (bitinf->freq_reset)
-- mvwchgat(input_win, 3, 24, 8, A_BOLD, 3, NULL);
-+ mvwchgat(input_win, 3, 22, 8, A_BOLD, 3, NULL);
- else
-- mvwchgat(input_win, 3, 24, 8, A_NORMAL, 7, NULL);
-+ mvwchgat(input_win, 3, 22, 8, A_NORMAL, 7, NULL);
-
- mvwprintw(input_win, 3, 1, "%2u", bitpos);
-
diff --git a/comms/dcf77pi/pkg-plist b/comms/dcf77pi/pkg-plist
index 037a245a2c03..5cc91596f7ea 100644
--- a/comms/dcf77pi/pkg-plist
+++ b/comms/dcf77pi/pkg-plist
@@ -2,6 +2,7 @@ bin/dcf77pi
bin/dcf77pi-analyze
bin/readpin
@sample %%ETCDIR%%/config.txt.sample
+include/dcf77pi/bits1to14.h
include/dcf77pi/config.h
include/dcf77pi/decode_alarm.h
include/dcf77pi/decode_time.h