aboutsummaryrefslogtreecommitdiff
path: root/comms/dfu-util/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-14 11:33:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-14 11:33:19 +0000
commit1ce51726ccf29d7b26d9eebebbb6c66d16ced65c (patch)
tree79318f5df330d3f1a3101bc85dd8599dfe8e95e2 /comms/dfu-util/Makefile
parent15bc754dd862ad57fd15365840a7ee1f1f88a4bb (diff)
downloadports-1ce51726ccf29d7b26d9eebebbb6c66d16ced65c.tar.gz
ports-1ce51726ccf29d7b26d9eebebbb6c66d16ced65c.zip
Notes
Diffstat (limited to 'comms/dfu-util/Makefile')
-rw-r--r--comms/dfu-util/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/comms/dfu-util/Makefile b/comms/dfu-util/Makefile
index 3897587fda94..0299afda8dfc 100644
--- a/comms/dfu-util/Makefile
+++ b/comms/dfu-util/Makefile
@@ -1,26 +1,24 @@
-# New ports collection makefile for: dfu-util
-# Date created: 2008-02-04
-# Whom: Bruce Cran <bruce@cran.org.uk>
-#
+# Created by: Bruce Cran <bruce@cran.org.uk>
# $FreeBSD$
-#
PORTNAME= dfu-util
-DISTVERSION= 0.1.snap${SNAPDATE}
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= comms
-MASTER_SITES= http://www.cran.org.uk/~brucec/software/
+MASTER_SITES= http://dfu-util.gnumonks.org/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Device firmware update (DFU) USB programmer
-MAN1= dfu-util.1
-PLIST_FILES= bin/dfu-util
-USE_AUTOTOOLS= aclocal automake autoheader
-AUTOMAKE_ARGS= --add-missing --foreign --copy
+LICENSE= GPLv2
-SNAPDATE= 20090212
GNU_CONFIGURE= yes
+CONFIGURE_ENV= USE_LIBS="-lusb" \
+ ac_cv_lib_usbpath_usb_path2devnum=no
+CONFIGURE_ARGS= --disable-silent-rules
+MAKE_JOBS_SAFE= yes
+
+MAN1= dfu-util.1
+PLIST_FILES= bin/dfu-suffix bin/dfu-util
.include <bsd.port.pre.mk>
@@ -28,8 +26,4 @@ GNU_CONFIGURE= yes
IGNORE= requires new USB stack in FreeBSD 8
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/dfu-util ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/dfu-util.1 ${MAN1PREFIX}/man/man1
-
.include <bsd.port.post.mk>