aboutsummaryrefslogtreecommitdiff
path: root/comms/direwolf
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-03-11 08:26:04 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-03-11 08:26:04 +0000
commit6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1 (patch)
tree1cd4ecc9e4a792d7203d5289e52d93e4d4eb7735 /comms/direwolf
parent7544f5b40b76a74241e33c9a4df93a9bdf1a5441 (diff)
downloadports-6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1.tar.gz
ports-6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1.zip
astro/gpsd: Update to 3.20
- Update to 3.20 (welcome ubxtool and gpsrinex!) - Fix SConstruct per python3 [1] - Replace spaces by tabs (pet portlint) - Fixes astro/foxtrotgps, astro/gpxloggerd and comms/direwolf Changelog: - https://gitlab.com/gpsd/gpsd/-/blob/master/NEWS#L16 [1] scons is py27 only and check py27 packages for a py37 port. I commented these tests in SConstruct since we already do it in our Makefile. PR: 243980 Reviewed by: tcberner (mentor) Approved by: tcberner (mentor), maintainer timeout (z7dr6ut7gs@snkmail.com, > 2 weeks) Differential Revision: https://reviews.freebsd.org/D23920
Notes
Notes: svn path=/head/; revision=528219
Diffstat (limited to 'comms/direwolf')
-rw-r--r--comms/direwolf/Makefile1
-rw-r--r--comms/direwolf/files/patch-dwgpsd.c34
2 files changed, 35 insertions, 0 deletions
diff --git a/comms/direwolf/Makefile b/comms/direwolf/Makefile
index 1ce003005209..8e0a81ee1126 100644
--- a/comms/direwolf/Makefile
+++ b/comms/direwolf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= direwolf
DISTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org
diff --git a/comms/direwolf/files/patch-dwgpsd.c b/comms/direwolf/files/patch-dwgpsd.c
new file mode 100644
index 000000000000..cee4624cf59a
--- /dev/null
+++ b/comms/direwolf/files/patch-dwgpsd.c
@@ -0,0 +1,34 @@
+--- dwgpsd.c.orig 2020-03-05 16:59:08 UTC
++++ dwgpsd.c
+@@ -57,7 +57,10 @@
+ // Debian bug report: direwolf (1.2-1) FTBFS with libgps22 as part of the gpsd transition (#803605):
+ // dwgps.c claims to only support GPSD_API_MAJOR_VERSION 5, but also builds successfully with
+ // GPSD_API_MAJOR_VERSION 6 provided by libgps22 when the attached patch is applied.
+-#if GPSD_API_MAJOR_VERSION < 5 || GPSD_API_MAJOR_VERSION > 6
++
++// Also compatible with API 9 with conditional compilation later.
++
++#if GPSD_API_MAJOR_VERSION < 5 || GPSD_API_MAJOR_VERSION > 9
+ #error libgps API version might be incompatible.
+ #endif
+
+@@ -257,7 +260,19 @@ static void * read_gpsd_thread (void *arg)
+ /* Fall thru to read which should get error and bail out. */
+ }
+
++// https://github.com/wb2osz/direwolf/issues/196
++// https://bugzilla.redhat.com/show_bug.cgi?id=1674812
++
++// gps_read has two new parameters in API version 7.
++// It looks like this could be used to obtain the JSON message from the daemon.
++// Specify NULL, instead of message buffer space, if this is not desired.
++// Why couldn't they add a new function instead of introducing incompatibility?
++
++#if GPSD_API_MAJOR_VERSION >= 7
++ if (gps_read (&gpsdata, NULL, 0) == -1) {
++#else
+ if (gps_read (&gpsdata) == -1) {
++#endif
+ text_color_set(DW_COLOR_ERROR);
+
+ dw_printf ("------------------------------------------\n");