aboutsummaryrefslogtreecommitdiff
path: root/comms/dump1090
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2015-03-05 02:32:08 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2015-03-05 02:32:08 +0000
commitba3ec984e48455c5b3877540105b18ea73c21d40 (patch)
treedc8c602b9e1448bee1e70b5fa170d8607eed0944 /comms/dump1090
parentefa8f99738a2c5f16be2031122b256aa803f6300 (diff)
downloadports-ba3ec984e48455c5b3877540105b18ea73c21d40.tar.gz
ports-ba3ec984e48455c5b3877540105b18ea73c21d40.zip
Dump 1090 is a Mode S decoder specifically designed for RTLSDR devices.
The main features are: * Robust decoding of weak messages. * Network support: TCP30003 stream (MSG5...), Raw packets, HTTP. * Embedded HTTP server that displays the currently detected aircrafts on Google Map. * Single bit errors correction using the 24 bit CRC. * Ability to decode DF11, DF17 messages. * Ability to decode DF formats like DF0, DF4, DF5, DF16, DF20 and DF21 where the checksum is xored with the ICAO address by brute forcing the checksum field using recently seen ICAO addresses. * Decode raw IQ samples from file (using --ifile command line switch). * Interactive command-line-interfae mode where aircrafts currently detected are shown as a list refreshing as more data arrives. * CPR coordinates decoding and track calculation from velocity. * TCP server streaming and receiving raw data to/from connected clients. WWW: https://github.com/antirez/dump1090
Notes
Notes: svn path=/head/; revision=380470
Diffstat (limited to 'comms/dump1090')
-rw-r--r--comms/dump1090/Makefile36
-rw-r--r--comms/dump1090/distinfo2
-rw-r--r--comms/dump1090/files/patch-Makefile21
-rw-r--r--comms/dump1090/pkg-descr20
4 files changed, 79 insertions, 0 deletions
diff --git a/comms/dump1090/Makefile b/comms/dump1090/Makefile
new file mode 100644
index 000000000000..88b8123d6c7e
--- /dev/null
+++ b/comms/dump1090/Makefile
@@ -0,0 +1,36 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dump1090
+PORTVERSION= 20150225
+CATEGORIES= comms
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Simple Mode S decoder for RTLSDR devices
+
+USE_GITHUB= yes
+GH_ACCOUNT= antirez
+GH_COMMIT= 4c53e25
+GH_TAGNAME= 4c53e251439f42135fc80fe000174f7accdb048c
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= librtlsdr.so:${PORTSDIR}/comms/rtl-sdr
+
+USES= gmake
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lrtlsdr -lusb -lpthread -lm
+
+PLIST_FILES= bin/dump1090 \
+ ${DATADIR}/gmap.html
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|gmap.html|${DATADIR}/gmap.html|" ${WRKSRC}/dump1090.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gmap.html ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/comms/dump1090/distinfo b/comms/dump1090/distinfo
new file mode 100644
index 000000000000..3579dcc1addb
--- /dev/null
+++ b/comms/dump1090/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dump1090-20150225.tar.gz) = a9d7b9eaf439815f22f62e770a315114afdbb1301ca70cb59de11e06dbdd6e07
+SIZE (dump1090-20150225.tar.gz) = 484418
diff --git a/comms/dump1090/files/patch-Makefile b/comms/dump1090/files/patch-Makefile
new file mode 100644
index 000000000000..fdd8cbbc2276
--- /dev/null
+++ b/comms/dump1090/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2015-03-03 21:04:48 UTC
++++ Makefile
+@@ -1,6 +1,6 @@
+-CFLAGS=-O2 -g -Wall -W `pkg-config --cflags librtlsdr`
+-LIBS=`pkg-config --libs librtlsdr` -lpthread -lm
+-CC=gcc
++CFLAGS?=-O2 -g -Wall -W `pkg-config --cflags librtlsdr`
++LDFLAGS?=`pkg-config --libs librtlsdr` -lpthread -lm
++CC?=gcc
+ PROGNAME=dump1090
+
+ all: dump1090
+@@ -9,7 +9,7 @@ all: dump1090
+ $(CC) $(CFLAGS) -c $<
+
+ dump1090: dump1090.o anet.o
+- $(CC) -g -o dump1090 dump1090.o anet.o $(LIBS)
++ $(CC) -g -o dump1090 dump1090.o anet.o $(LDFLAGS)
+
+ clean:
+ rm -f *.o dump1090
diff --git a/comms/dump1090/pkg-descr b/comms/dump1090/pkg-descr
new file mode 100644
index 000000000000..ae8eefa666eb
--- /dev/null
+++ b/comms/dump1090/pkg-descr
@@ -0,0 +1,20 @@
+Dump 1090 is a Mode S decoder specifically designed for RTLSDR devices.
+
+The main features are:
+
+* Robust decoding of weak messages.
+* Network support: TCP30003 stream (MSG5...), Raw packets, HTTP.
+* Embedded HTTP server that displays the currently detected aircrafts on
+ Google Map.
+* Single bit errors correction using the 24 bit CRC.
+* Ability to decode DF11, DF17 messages.
+* Ability to decode DF formats like DF0, DF4, DF5, DF16, DF20 and DF21 where the
+ checksum is xored with the ICAO address by brute forcing the checksum field
+ using recently seen ICAO addresses.
+* Decode raw IQ samples from file (using --ifile command line switch).
+* Interactive command-line-interfae mode where aircrafts currently detected are
+ shown as a list refreshing as more data arrives.
+* CPR coordinates decoding and track calculation from velocity.
+* TCP server streaming and receiving raw data to/from connected clients.
+
+WWW: https://github.com/antirez/dump1090