aboutsummaryrefslogtreecommitdiff
path: root/comms/echolinux
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-27 15:54:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-27 15:54:32 +0000
commitd4dd694ee46a91f802bb9712d8c0bed33d136375 (patch)
tree388d0275402c2e9cd86368c422b4da3b10e833a9 /comms/echolinux
parent3aa096e6680cdbe90a797e99750af59f487d4ae1 (diff)
downloadports-d4dd694ee46a91f802bb9712d8c0bed33d136375.tar.gz
ports-d4dd694ee46a91f802bb9712d8c0bed33d136375.zip
Fix build on HEAD by adding USE_GCC=any (uses nested functions)
Notes
Notes: svn path=/head/; revision=319261
Diffstat (limited to 'comms/echolinux')
-rw-r--r--comms/echolinux/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/comms/echolinux/Makefile b/comms/echolinux/Makefile
index de6ffc5ed527..fb73cbb59136 100644
--- a/comms/echolinux/Makefile
+++ b/comms/echolinux/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: echolinux
-# Date created: 25 June 2004
-# Whom: db
-#
+# Created by: db
# $FreeBSD$
-#
PORTNAME= echolinux
PORTVERSION= 0.17a
@@ -18,6 +14,10 @@ COMMENT= Amateur Radio Echolink client for UNIX
LIB_DEPENDS= forms.2:${PORTSDIR}/x11-toolkits/xforms \
gsm.1:${PORTSDIR}/audio/gsm
+USE_GCC= any
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}|' -e 's|/usr/include/X11|$${LOCALBASE}/include|' \
-e 's|-o echogui -L/usr/X11R6/lib -lX11 -lXpm -lforms -lm -lpthread|$${CFLAGS} -o echogui -L$${LOCALBASE}/lib -lX11 -lXpm -lforms -lm ${PTHREAD_LIBS}|' \
@@ -35,7 +35,7 @@ post-patch:
${WRKSRC}/echolinux/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
@${INSTALL_DATA} ${WRKSRC}/Using_EchoLinux.txt ${DOCSDIR}/Using_EchoLinux.txt