aboutsummaryrefslogtreecommitdiff
path: root/comms/efax-gtk/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-16 22:54:19 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-16 22:54:19 +0000
commit6f833abd84331b66061cb1b4f4f2574bd06e03d0 (patch)
tree2aa6ff6304d16da6eec7eb0692170c8995d57d31 /comms/efax-gtk/Makefile
parent218b91b2d96c85064635b9d4031bb405a85f4393 (diff)
downloadports-6f833abd84331b66061cb1b4f4f2574bd06e03d0.tar.gz
ports-6f833abd84331b66061cb1b4f4f2574bd06e03d0.zip
Notes
Diffstat (limited to 'comms/efax-gtk/Makefile')
-rw-r--r--comms/efax-gtk/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
new file mode 100644
index 000000000000..731bdcc9e5fb
--- /dev/null
+++ b/comms/efax-gtk/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: efax-gtk
+# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
+# Date Created: 2004-02-29 10:33:43
+#
+# ex:ts=20:sw=20
+#
+# $FreeBSD$
+#
+
+PORTNAME= efax-gtk
+PORTVERSION= 2.2.5
+CATEGORIES= comms
+MASTER_SITES= http://www.cvine.freeserve.co.uk/efax-gtk/
+EXTRACT_SUFX= .src.tgz
+
+MAINTAINER= jb.quenot@caraldi.com
+COMMENT= GUI front end for the efax fax program
+
+LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
+LIB_DEPENDS+= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2
+RUN_DEPENDS= ${X11BASE}/bin/ggv:${PORTSDIR}/print/ggv2
+RUN_DEPENDS+= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu
+
+USE_X_PREFIX= YES
+GNU_CONFIGURE= YES
+MAN1= efax.1 efix.1 efax-gtk.1
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${ECHO}
+ @${ECHO_CMD} "********************************************************************************"
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} "********************************************************************************"
+ @${ECHO}
+
+.include <bsd.port.post.mk>