aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2011-08-19 02:39:06 +0000
committerDiane Bruce <db@FreeBSD.org>2011-08-19 02:39:06 +0000
commit0f6b205f831538b6230453fb66222d54f564d004 (patch)
treee5635e3834aa664028a183b12cc099f55a2cf161 /comms/fldigi
parent60f9f0361ea0fa346d02b62c32662e0b4042e3b5 (diff)
downloadports-0f6b205f831538b6230453fb66222d54f564d004.tar.gz
ports-0f6b205f831538b6230453fb66222d54f564d004.zip
Notes
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/Makefile100
-rw-r--r--comms/fldigi/distinfo4
-rw-r--r--comms/fldigi/files/patch-configure11
-rw-r--r--comms/fldigi/files/patch-doc-Makefile.in11
-rw-r--r--comms/fldigi/pkg-plist14
5 files changed, 121 insertions, 19 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 1f50ad0bca9f..59cead32d40b 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fldigi
-PORTVERSION= 3.21.10
+PORTVERSION= 3.21.12
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/downloads/fldigi/ \
${MASTER_SITE_LOCAL}
@@ -15,20 +15,29 @@ MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Digital decoder for psk, cw, psk31, olivia
-BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
-LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib \
- sndfile:${PORTSDIR}/audio/libsndfile \
- boost_wave:${PORTSDIR}/devel/boost-libs \
- pulse:${PORTSDIR}/audio/pulseaudio \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LICENSE= GPLv3
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ samplerate:${PORTSDIR}/audio/libsamplerate
+
+BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xsltproc:${PORTSDIR}/textproc/libxslt
GNU_CONFIGURE= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
-LICENSE= GPLv3
-MAN1= fldigi.1 flarq.1
+MAN1= fldigi.1
+
+OPTIONS= NATIVE_OPT "Enable Native Optimizations" off \
+ NLS "Use NLS" off \
+ FLARQ "Compile flarq" on \
+ XMLRPC "Support XMLrpc (fldigi-shell)" off \
+ OSS "Support OSS" on \
+ SNDFILE "Support for libsndfile" off \
+ PORTAUDIO "PortAudio support" off \
+ PULSEAUDIO "PulseAudio support" off \
+ HAMLIB "Support rig control via hamlib" on \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
@@ -37,6 +46,73 @@ USE_GCC= 4.2+
.if ${ARCH} == "sparc64"
BROKEN= Fails to install
.endif
+.if defined(WITH_NATIVE_OPT)
+CONFIGURE_ARGS+=--enable-optimizations=native
+.else
+CONFIGURE_ARGS+=--enable-optimizations=none
+.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.endif
+.if defined(WITHOUT_FLARQ)
+CONFIGURE_ARGS+=--disable-flarq
+PLIST_SUB+= FLARQ="@comment "
+.else
+CONFIGURE_ARGS+=--enable-flarq
+MAN1+= flarq.1
+PLIST_SUB+= FLARQ=""
+.endif
+.if defined(WITH_XMLRPC)
+CONFIGURE_ARGS+=--with-xmlrpc
+LIB_DEPENDS+= xmlrpc:${PORTSDIR}/net/xmlrpc-c
+PLIST_SUB+= XMLRPC=""
+MAN1+= fldigi-shell.1
+.else
+CONFIGURE_ARGS+=--without-xmlrpc
+PLIST_SUB+= XMLRPC="@comment "
+.endif
+.if defined(WITH_OSS)
+CONFIGURE_ARGS+=--enable-oss
+.else
+CONFIGURE_ARGS+=--disable-oss
+.endif
+.if defined(WITH_SNDFILE)
+CONFIGURE_ARGS+=--with-sndfile
+LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
+.else
+CONFIGURE_ARGS+=--without-sndfile
+.endif
+.if defined(WITH_PORTAUDIO)
+CONFIGURE_ARGS+=--with-portaudio
+BUILD_DEPENDS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
+RUN_DEPENDS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
+.else
+CONFIGURE_ARGS+=--without-portaudio
+.endif
+.if defined(WITH_PULSEAUDIO)
+CONFIGURE_ARGS+=--with-pulseaudio
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
+.else
+CONFIGURE_ARGS+=--without-pulseaudio
+.endif
+.if defined(WITH_HAMLIB)
+CONFIGURE_ARGS+=--with-hamlib
+LIB_DEPENDS+= hamlib:${PORTSDIR}/comms/hamlib
+.else
+CONFIGURE_ARGS+=--without-hamlib
+.endif
+.if !defined(NOPORTDOCS)
+CONFIGURE_ARGS+=--with-asciidoc
+PLIST_SUB +=ASCIIDOC=""
+.else
+CONFIGURE_ARGS+=--without-asciidoc
+PLIST_SUB+= ASCIIDOC="@comment "
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|' \
@@ -48,13 +124,15 @@ post-configure:
${WRKSRC}/src/Makefile
do-build:
- (cd ${WRKSRC}/src;gmake)
+# It will not build the man pages without the rm
+ (cd ${WRKSRC}/doc/;rm *.1;gmake;cd ${WRKSRC}/src;gmake)
post-install:
.if !defined(NOPORTDOCS)
@${ECHO} ""
${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/guide.html ${DOCSDIR}
@${ECHO} "fldigi docs installed in ${DOCSDIR}"
@${ECHO} ""
.endif
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index 133cd02aedd3..56506c141f78 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fldigi-3.21.10.tar.gz) = 3af9a2543bcd1a27c93a835fc655241f9793912310fefd64823ce78601152d4c
-SIZE (fldigi-3.21.10.tar.gz) = 1611144
+SHA256 (fldigi-3.21.12.tar.gz) = 6d54fbf776822c15b6ff8b38675be761972e767979091eaeae5e4ac34e4f9afc
+SIZE (fldigi-3.21.12.tar.gz) = 1608635
diff --git a/comms/fldigi/files/patch-configure b/comms/fldigi/files/patch-configure
new file mode 100644
index 000000000000..d60ce0251026
--- /dev/null
+++ b/comms/fldigi/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-07-20 20:07:57.000000000 -0700
++++ configure 2011-07-20 20:08:13.000000000 -0700
+@@ -11761,7 +11761,7 @@
+ if test "x$ASCIIDOC" != "x"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for asciidoc >= $asciidoc_min" >&5
+ $as_echo_n "checking for asciidoc >= $asciidoc_min... " >&6; }
+- asciidoc_ver=$($ASCIIDOC --version | sed -n '1 { s/.* //; p }')
++ asciidoc_ver=$($ASCIIDOC --version | sed -n '1 { s/.* //; p; }')
+
+
+
diff --git a/comms/fldigi/files/patch-doc-Makefile.in b/comms/fldigi/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..b13e6f2d9124
--- /dev/null
+++ b/comms/fldigi/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig 2011-07-20 20:20:26.000000000 -0700
++++ doc/Makefile.in 2011-07-20 20:21:37.000000000 -0700
+@@ -559,7 +559,7 @@
+
+ # The rest of the Makefile is enabled only if we have asciidoc
+
+-@HAVE_ASCIIDOC_TRUE@ASCIIDOC_ICONS_DIR ?= /usr/share/asciidoc/images/icons
++@HAVE_ASCIIDOC_TRUE@ASCIIDOC_ICONS_DIR ?= $(prefix)/etc/asciidoc/images/icons
+
+ @HAVE_ASCIIDOC_TRUE@%.html: $$*.txt $(ASCIIDOC_CONF)
+ @HAVE_ASCIIDOC_TRUE@ @if ! test -d $(ASCIIDOC_ICONS_DIR); then \
diff --git a/comms/fldigi/pkg-plist b/comms/fldigi/pkg-plist
index 9ed7e9239145..a9293bde6868 100644
--- a/comms/fldigi/pkg-plist
+++ b/comms/fldigi/pkg-plist
@@ -1,12 +1,14 @@
-bin/flarq
+%%FLARQ%%bin/flarq
bin/fldigi
-share/applications/flarq.desktop
+%%XMLRPC%%bin/fldigi-shell
+%%FLARQ%%share/applications/flarq.desktop
share/applications/fldigi.desktop
-share/locale/es/LC_MESSAGES/fldigi.mo
-share/locale/fr/LC_MESSAGES/fldigi.mo
-share/locale/it/LC_MESSAGES/fldigi.mo
-share/pixmaps/flarq.xpm
+%%NLS%%share/locale/es/LC_MESSAGES/fldigi.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/fldigi.mo
+%%NLS%%share/locale/it/LC_MESSAGES/fldigi.mo
+%%FLARQ%%share/pixmaps/flarq.xpm
share/pixmaps/fldigi.xpm
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%ASCIIDOC%%%%DOCSDIR%%/guide.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications