aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-05-11 09:31:38 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-05-11 09:31:38 +0000
commite2d1b6c116b918fa4e66e496de8902d15c5dfe2c (patch)
tree595a1ccbadbdce7bbff40a4aae21422fbfce4237 /comms/fldigi
parentc1c711dea606485fb32e88c8dad0d921e1dc2cc7 (diff)
Notes
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/Makefile66
-rw-r--r--comms/fldigi/files/patch-Makefile.in8
-rw-r--r--comms/fldigi/files/patch-misc_newinstall.cxx11
-rw-r--r--comms/fldigi/files/patch-src_dialogs_fl__digi.cxx10
-rw-r--r--comms/fldigi/files/patch-src_dialogs_fl_digi.cxx10
-rw-r--r--comms/fldigi/files/patch-src_dominoex_dominoex.cxx6
-rw-r--r--comms/fldigi/files/patch-src_include_data__io.h (renamed from comms/fldigi/files/patch-src_data_io.h)4
-rw-r--r--comms/fldigi/files/patch-src_include_qrunner.h4
-rw-r--r--comms/fldigi/files/patch-src_logbook_lookupcall.cxx6
-rw-r--r--comms/fldigi/files/patch-src_misc_newinstall.cxx11
-rw-r--r--comms/fldigi/files/patch-src_qrunner_qrunner.cxx6
-rw-r--r--comms/fldigi/files/patch-src_soundcard_sound.cxx20
-rw-r--r--comms/fldigi/files/patch-src_spot_pskrep.cxx4
-rw-r--r--comms/fldigi/files/patch-src_thor_thor.cxx6
-rw-r--r--comms/fldigi/files/patch-src_wefax_wefax.cxx6
-rw-r--r--comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcBase64.h10
-rw-r--r--comms/fldigi/files/patch-src_xmrpcpp_XmlRpcBase64.h10
17 files changed, 94 insertions, 104 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 6ffb00495dda..7f883b9270b0 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fldigi
PORTVERSION= 3.22.08
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/downloads/fldigi/\
${MASTER_SITE_LOCAL}
@@ -38,64 +39,33 @@ PULSEAUDIO_DESC= PulseAudio support
HAMLIB_DESC= Support rig control via hamlib
OPTIONS_DEFAULT= FLARQ OSS HAMLIB
+OPTIONS_SUB= yes
+
+NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
+NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
+FLARQ_CONFIGURE_ENABLE= flarq
+OSS_CONFIGURE_ENABLE= oss
+SNDFILE_CONFIGURE_WITH= sndfile
+SNDFILE_LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
+PORTAUDIO_CONFIGURE_WITH= portaudio
+PORTAUDIO_BUILD_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio2
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+HAMLIB_CONFIGURE_WITH= hamlib
+HAMLIB_LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= Fails to install
.endif
-.if ${PORT_OPTIONS:MNATIVE_OPT}
-CONFIGURE_ARGS+=--enable-optimizations=native
-.else
-CONFIGURE_ARGS+=--enable-optimizations=none
-.endif
.if ${PORT_OPTIONS:MFLARQ}
-CONFIGURE_ARGS+=--enable-flarq
MAN1+= flarq.1
-PLIST_SUB+= FLARQ=""
-.else
-CONFIGURE_ARGS+=--disable-flarq
-PLIST_SUB+= FLARQ="@comment "
.endif
PLIST_SUB+= XMLRPC=""
-.if ${PORT_OPTIONS:MOSS}
-CONFIGURE_ARGS+=--enable-oss
-.else
-CONFIGURE_ARGS+=--disable-oss
-.endif
-.if ${PORT_OPTIONS:MSNDFILE}
-CONFIGURE_ARGS+=--with-sndfile
-LIB_DEPENDS+= libsndfile.so:${PORTSDIR}/audio/libsndfile
-.else
-CONFIGURE_ARGS+=--without-sndfile
-.endif
-.if ${PORT_OPTIONS:MPORTAUDIO}
-CONFIGURE_ARGS+=--with-portaudio
-BUILD_DEPENDS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
-RUN_DEPENDS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
-.else
-CONFIGURE_ARGS+=--without-portaudio
-.endif
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-CONFIGURE_ARGS+=--with-pulseaudio
-LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
-.else
-CONFIGURE_ARGS+=--without-pulseaudio
-.endif
-.if ${PORT_OPTIONS:MHAMLIB}
-CONFIGURE_ARGS+=--with-hamlib
-LIB_DEPENDS+= libhamlib.so:${PORTSDIR}/comms/hamlib
-.else
-CONFIGURE_ARGS+=--without-hamlib
-.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
diff --git a/comms/fldigi/files/patch-Makefile.in b/comms/fldigi/files/patch-Makefile.in
index ff41f45c062e..5b771480a214 100644
--- a/comms/fldigi/files/patch-Makefile.in
+++ b/comms/fldigi/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2013-02-08 22:19:37.000000000 -0500
-+++ Makefile.in 2013-03-31 19:02:18.000000000 -0500
-@@ -145,7 +145,7 @@
+--- Makefile.in.orig 2015-04-24 12:55:28 UTC
++++ Makefile.in
+@@ -145,7 +145,7 @@ CC = @CC@
CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
CPP = @CPP@
-CPPFLAGS = @CPPFLAGS@
-+CPPFLAGS = "-I%%LOCALBASE%%/include/portaudio2 @CPPFLAGS@"
++CPPFLAGS = "-I/usr/local/include/portaudio2 @CPPFLAGS@"
CXX = @CXX@
CXXDEPMODE = @CXXDEPMODE@
CXXFLAGS = @CXXFLAGS@
diff --git a/comms/fldigi/files/patch-misc_newinstall.cxx b/comms/fldigi/files/patch-misc_newinstall.cxx
deleted file mode 100644
index 7e02aa1883c6..000000000000
--- a/comms/fldigi/files/patch-misc_newinstall.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/misc/newinstall.cxx.orig 2014-03-21 11:25:57.000000000 -0500
-+++ src/misc/newinstall.cxx 2014-03-21 18:19:24.000000000 -0500
-@@ -84,7 +84,7 @@
- Rig: \n\
- Pwr: \n\
- Ant: \n\
--OS: Linux\n\
-+OS: FreeBSD\n\
- Soft: <VER>\n\
- Web: \n\
- Email: ";
diff --git a/comms/fldigi/files/patch-src_dialogs_fl__digi.cxx b/comms/fldigi/files/patch-src_dialogs_fl__digi.cxx
new file mode 100644
index 000000000000..be5592545bc2
--- /dev/null
+++ b/comms/fldigi/files/patch-src_dialogs_fl__digi.cxx
@@ -0,0 +1,10 @@
+--- src/dialogs/fl_digi.cxx.orig 2015-04-23 11:39:24 UTC
++++ src/dialogs/fl_digi.cxx
+@@ -26,6 +26,7 @@
+ #include <config.h>
+
+ #include <sys/types.h>
++#include <time.h>
+
+ #ifdef __WOE32__
+ # ifdef __CYGWIN__
diff --git a/comms/fldigi/files/patch-src_dialogs_fl_digi.cxx b/comms/fldigi/files/patch-src_dialogs_fl_digi.cxx
deleted file mode 100644
index c54b67376ec0..000000000000
--- a/comms/fldigi/files/patch-src_dialogs_fl_digi.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dialogs/fl_digi.cxx.orig 2012-07-07 09:01:19.000000000 -0500
-+++ src/dialogs/fl_digi.cxx 2012-07-21 15:24:09.000000000 -0500
-@@ -26,6 +26,7 @@
- #include <config.h>
-
- #include <sys/types.h>
-+#include <time.h>
-
- #ifdef __WOE32__
- # ifdef __CYGWIN__
diff --git a/comms/fldigi/files/patch-src_dominoex_dominoex.cxx b/comms/fldigi/files/patch-src_dominoex_dominoex.cxx
index 5f7548ce643d..5cad1d215e31 100644
--- a/comms/fldigi/files/patch-src_dominoex_dominoex.cxx
+++ b/comms/fldigi/files/patch-src_dominoex_dominoex.cxx
@@ -1,6 +1,6 @@
---- src/dominoex/dominoex.cxx.orig 2014-03-21 11:25:57.000000000 -0500
-+++ src/dominoex/dominoex.cxx 2014-03-21 18:19:42.000000000 -0500
-@@ -63,7 +63,7 @@
+--- src/dominoex/dominoex.cxx.orig 2015-04-22 15:17:06 UTC
++++ src/dominoex/dominoex.cxx
+@@ -63,7 +63,7 @@ void dominoex::tx_init(SoundBase *sc)
strSecXmtText = progdefaults.secText;
if (strSecXmtText.length() == 0)
diff --git a/comms/fldigi/files/patch-src_data_io.h b/comms/fldigi/files/patch-src_include_data__io.h
index eb297598713c..f5506cdbfdd3 100644
--- a/comms/fldigi/files/patch-src_data_io.h
+++ b/comms/fldigi/files/patch-src_include_data__io.h
@@ -1,5 +1,5 @@
---- src/include/data_io.h.orig 2014-11-27 01:39:00.000000000 -0800
-+++ src/include/data_io.h 2014-11-27 01:39:29.000000000 -0800
+--- src/include/data_io.h.orig 2015-04-18 13:26:19 UTC
++++ src/include/data_io.h
@@ -27,6 +27,8 @@
#ifndef fldigi_data_io_h
#define fldigi_data_io_h
diff --git a/comms/fldigi/files/patch-src_include_qrunner.h b/comms/fldigi/files/patch-src_include_qrunner.h
index 12b4caad48d8..cdd350fedef1 100644
--- a/comms/fldigi/files/patch-src_include_qrunner.h
+++ b/comms/fldigi/files/patch-src_include_qrunner.h
@@ -1,5 +1,5 @@
---- src/include/qrunner.h.orig 2014-11-27 01:43:12.000000000 -0800
-+++ src/include/qrunner.h 2014-11-27 01:43:46.000000000 -0800
+--- src/include/qrunner.h.orig 2015-03-21 00:29:03 UTC
++++ src/include/qrunner.h
@@ -32,6 +32,7 @@
#include <cerrno>
#include <stdexcept>
diff --git a/comms/fldigi/files/patch-src_logbook_lookupcall.cxx b/comms/fldigi/files/patch-src_logbook_lookupcall.cxx
index f37bf5f0dc44..ee751ac03ab7 100644
--- a/comms/fldigi/files/patch-src_logbook_lookupcall.cxx
+++ b/comms/fldigi/files/patch-src_logbook_lookupcall.cxx
@@ -1,6 +1,6 @@
---- src/logbook/lookupcall.cxx.orig 2014-03-21 11:25:57.000000000 -0500
-+++ src/logbook/lookupcall.cxx 2014-03-21 18:19:53.000000000 -0500
-@@ -1188,7 +1188,7 @@
+--- src/logbook/lookupcall.cxx.orig 2015-04-23 11:39:24 UTC
++++ src/logbook/lookupcall.cxx
+@@ -1188,7 +1188,7 @@ static void *EQSL_loop(void *args)
return NULL;
size_t p;
diff --git a/comms/fldigi/files/patch-src_misc_newinstall.cxx b/comms/fldigi/files/patch-src_misc_newinstall.cxx
new file mode 100644
index 000000000000..4b639f827150
--- /dev/null
+++ b/comms/fldigi/files/patch-src_misc_newinstall.cxx
@@ -0,0 +1,11 @@
+--- src/misc/newinstall.cxx.orig 2015-03-21 00:29:03 UTC
++++ src/misc/newinstall.cxx
+@@ -84,7 +84,7 @@ Age: \n\
+ Rig: \n\
+ Pwr: \n\
+ Ant: \n\
+-OS: Linux\n\
++OS: FreeBSD\n\
+ Soft: <VER>\n\
+ Web: \n\
+ Email: ";
diff --git a/comms/fldigi/files/patch-src_qrunner_qrunner.cxx b/comms/fldigi/files/patch-src_qrunner_qrunner.cxx
index e519b41b0210..ede43e8cc5d0 100644
--- a/comms/fldigi/files/patch-src_qrunner_qrunner.cxx
+++ b/comms/fldigi/files/patch-src_qrunner_qrunner.cxx
@@ -1,6 +1,6 @@
---- src/qrunner/qrunner.cxx.orig 2014-10-14 21:19:37.000000000 -0400
-+++ src/qrunner/qrunner.cxx 2014-10-24 14:39:00.000000000 -0400
-@@ -103,7 +103,7 @@
+--- src/qrunner/qrunner.cxx.orig 2015-03-21 00:29:04 UTC
++++ src/qrunner/qrunner.cxx
+@@ -103,7 +103,7 @@ void qrunner::execute(int fd, void *arg)
return;
qr->inprog = true;
diff --git a/comms/fldigi/files/patch-src_soundcard_sound.cxx b/comms/fldigi/files/patch-src_soundcard_sound.cxx
new file mode 100644
index 000000000000..ad4024ee31d5
--- /dev/null
+++ b/comms/fldigi/files/patch-src_soundcard_sound.cxx
@@ -0,0 +1,20 @@
+--- src/soundcard/sound.cxx.orig 2015-05-11 09:19:59 UTC
++++ src/soundcard/sound.cxx
+@@ -689,7 +689,7 @@ size_t SoundOSS::Read(float *buffer, siz
+
+ for (size_t i = 0; i < buffersize; i++)
+ buffer[i] = src_buffer[2*i +
+- progdefaults.ReverseRxAudio ? 1 : 0];
++ (progdefaults.ReverseRxAudio ? 1 : 0)];
+
+ #if USE_SNDFILE
+ if (capture)
+@@ -724,7 +724,7 @@ size_t SoundOSS::Read(float *buffer, siz
+
+ for (int i = 0; i < numread; i++)
+ buffer[i] = snd_buffer[2*i +
+- progdefaults.sig_on_right_channel ? 1 : 0];
++ (progdefaults.sig_on_right_channel ? 1 : 0)];
+
+ return numread;
+
diff --git a/comms/fldigi/files/patch-src_spot_pskrep.cxx b/comms/fldigi/files/patch-src_spot_pskrep.cxx
index 72e1930282f4..3f3982dce4bc 100644
--- a/comms/fldigi/files/patch-src_spot_pskrep.cxx
+++ b/comms/fldigi/files/patch-src_spot_pskrep.cxx
@@ -1,5 +1,5 @@
---- src/spot/pskrep.cxx.orig 2014-07-04 15:11:14.000000000 -0700
-+++ src/spot/pskrep.cxx 2014-07-04 15:13:32.000000000 -0700
+--- src/spot/pskrep.cxx.orig 2015-03-21 00:29:04 UTC
++++ src/spot/pskrep.cxx
@@ -50,7 +50,7 @@
#include <algorithm>
#include <fstream>
diff --git a/comms/fldigi/files/patch-src_thor_thor.cxx b/comms/fldigi/files/patch-src_thor_thor.cxx
index 878c00c8fe3b..d304512b1c47 100644
--- a/comms/fldigi/files/patch-src_thor_thor.cxx
+++ b/comms/fldigi/files/patch-src_thor_thor.cxx
@@ -1,6 +1,6 @@
---- src/thor/thor.cxx.orig 2013-11-16 11:12:26.140977946 -0500
-+++ src/thor/thor.cxx 2013-11-16 11:13:27.127067530 -0500
-@@ -63,7 +63,7 @@
+--- src/thor/thor.cxx.orig 2015-04-22 15:17:06 UTC
++++ src/thor/thor.cxx
+@@ -63,7 +63,7 @@ void thor::tx_init(SoundBase *sc)
videoText();
strSecXmtText = progdefaults.THORsecText;
if (strSecXmtText.length() == 0)
diff --git a/comms/fldigi/files/patch-src_wefax_wefax.cxx b/comms/fldigi/files/patch-src_wefax_wefax.cxx
index fdfc7c600763..103802f2ee05 100644
--- a/comms/fldigi/files/patch-src_wefax_wefax.cxx
+++ b/comms/fldigi/files/patch-src_wefax_wefax.cxx
@@ -1,6 +1,6 @@
---- src/wefax/wefax.cxx.orig 2013-11-18 09:29:13.581496108 -0500
-+++ src/wefax/wefax.cxx 2013-11-18 09:38:30.354457373 -0500
-@@ -556,7 +556,7 @@
+--- src/wefax/wefax.cxx.orig 2015-04-22 15:17:06 UTC
++++ src/wefax/wefax.cxx
+@@ -556,7 +556,7 @@ private:
= wf->powerDensity(m_carrier - 2 * m_apt_start_freq, bandwidth_apt_start)
+ wf->powerDensity(m_carrier - m_apt_start_freq, bandwidth_apt_start)
+ wf->powerDensity(m_carrier , bandwidth_apt_start)
diff --git a/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcBase64.h b/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcBase64.h
new file mode 100644
index 000000000000..bea7597a2501
--- /dev/null
+++ b/comms/fldigi/files/patch-src_xmlrpcpp_XmlRpcBase64.h
@@ -0,0 +1,10 @@
+--- src/xmlrpcpp/XmlRpcBase64.h.orig 2015-04-23 11:39:24 UTC
++++ src/xmlrpcpp/XmlRpcBase64.h
+@@ -18,6 +18,7 @@
+ #if !defined(__BASE64_H_INCLUDED__)
+ #define __BASE64_H_INCLUDED__ 1
+
++#include <ios>
+ #include <iterator>
+
+ static
diff --git a/comms/fldigi/files/patch-src_xmrpcpp_XmlRpcBase64.h b/comms/fldigi/files/patch-src_xmrpcpp_XmlRpcBase64.h
deleted file mode 100644
index 65967a34206b..000000000000
--- a/comms/fldigi/files/patch-src_xmrpcpp_XmlRpcBase64.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/xmlrpcpp/XmlRpcBase64.h.orig 2015-04-27 22:16:11.000000000 -0700
-+++ src/xmlrpcpp/XmlRpcBase64.h 2015-04-27 22:16:22.000000000 -0700
-@@ -18,6 +18,7 @@
- #if !defined(__BASE64_H_INCLUDED__)
- #define __BASE64_H_INCLUDED__ 1
-
-+#include <ios>
- #include <iterator>
-
- static