aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2019-04-19 08:36:44 +0000
committerStephen Hurd <shurd@FreeBSD.org>2019-04-19 08:36:44 +0000
commite7e64a505eff4d5f4e0d5505e5704058a3683154 (patch)
treef585644ed86dec2de29d60df759ef6295c3a800f /comms/fldigi
parentf4f3b6d73e386c47666d75037edcfd67e41a863e (diff)
downloadports-e7e64a505eff4d5f4e0d5505e5704058a3683154.tar.gz
ports-e7e64a505eff4d5f4e0d5505e5704058a3683154.zip
Update to 4.1.02
Remove SNDFILE and PORTAUDIO options. These are required now. Show devices in the form of /dev/dspX not /dev/dspX.Y in config.
Notes
Notes: svn path=/head/; revision=499334
Diffstat (limited to 'comms/fldigi')
-rw-r--r--comms/fldigi/Makefile20
-rw-r--r--comms/fldigi/distinfo6
-rw-r--r--comms/fldigi/files/patch-src_soundcard_soundconf.cxx49
3 files changed, 58 insertions, 17 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 96ebf0991582..c9b16c24c070 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 4.1.01
-PORTREVISION= 1
+PORTVERSION= 4.1.02
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -30,13 +29,11 @@ USE_XORG= x11 xft xext xfixes xcursor xinerama xrender
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
-OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS DOCS
+OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS PULSEAUDIO HAMLIB NLS DOCS
NATIVE_OPT_DESC= Enable Native Optimizations
FLARQ_DESC= Compile flarq
OSS_DESC= Support OSS
-SNDFILE_DESC= Support for libsndfile
-PORTAUDIO_DESC= PortAudio support
PULSEAUDIO_DESC= PulseAudio support
HAMLIB_DESC= Support rig control via hamlib
@@ -47,22 +44,17 @@ NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
FLARQ_CONFIGURE_ENABLE= flarq
OSS_CONFIGURE_ENABLE= oss
-SNDFILE_CONFIGURE_ENABLE= sndfile
-SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-PORTAUDIO_CONFIGURE_ENABLE= portaudio
-PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
-PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-HAMLIB_CONFIGURE_ENABLE= hamlib
+HAMLIB_CONFIGURE_WITH= hamlib
HAMLIB_LIB_DEPENDS= libhamlib.so:comms/hamlib
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
-# Upstream as of 4.0.5 always uses portaudio and sndfile now
-# Which makes fldigi configure options portaudio & oss useless
-CONFIGURE_ARGS+=--with-portaudio --disable-oss
+# Always need soundfile
+CONFIGURE_ARGS+=--with-sndfile
post-configure:
# force rebuild of man pages
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index 824878381e61..47afb547b32c 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550613937
-SHA256 (fldigi-4.1.01.tar.gz) = be51ace44d01ca3fc7a5f21c15badf7063c7d7e6665a7ba9c307a39d51c0f6df
-SIZE (fldigi-4.1.01.tar.gz) = 3916445
+TIMESTAMP = 1555660048
+SHA256 (fldigi-4.1.02.tar.gz) = ed5320619594911e8b7a887a8a098ee2b08bd25a594cd0e7be8c5834ea99d224
+SIZE (fldigi-4.1.02.tar.gz) = 4681621
diff --git a/comms/fldigi/files/patch-src_soundcard_soundconf.cxx b/comms/fldigi/files/patch-src_soundcard_soundconf.cxx
new file mode 100644
index 000000000000..81c075014d63
--- /dev/null
+++ b/comms/fldigi/files/patch-src_soundcard_soundconf.cxx
@@ -0,0 +1,49 @@
+--- src/soundcard/soundconf.cxx.orig 2019-04-19 08:05:01 UTC
++++ src/soundcard/soundconf.cxx
+@@ -53,6 +53,11 @@ double std_sample_rates[] = { 8000.0, 96
+ static void init_oss(void)
+ {
+ #if USE_OSS
++#ifdef __FreeBSD__
++ char *last = NULL;
++ char *curr = NULL;
++ char *p;
++#endif
+ glob_t gbuf;
+ glob("/dev/dsp*", 0, NULL, &gbuf);
+ if (gbuf.gl_pathc == 0) {
+@@ -61,8 +66,33 @@ static void init_oss(void)
+ menuOSSDev->deactivate();
+ return;
+ }
+- for (size_t i = 0; i < gbuf.gl_pathc; i++)
++ for (size_t i = 0; i < gbuf.gl_pathc; i++) {
++#ifdef __FreeBSD__
++ if (curr)
++ free(curr);
++ curr = strdup(gbuf.gl_pathv[i]);
++ p = strrchr(curr, '.');
++ if (p)
++ *p = '\0';
++ if (last != NULL) {
++ if (strcmp(last, curr) == 0)
++ continue;
++ }
++ menuOSSDev->add(curr);
++ if (last)
++ free(last);
++ last = curr;
++ curr = NULL;
++#else
+ menuOSSDev->add(gbuf.gl_pathv[i]);
++#endif
++ }
++#ifdef __FreeBSD__
++ if (last)
++ free(last);
++ if (curr)
++ free(curr);
++#endif
+ if (progdefaults.OSSdevice.length() == 0 && gbuf.gl_pathc)
+ progdefaults.OSSdevice = gbuf.gl_pathv[0];
+ menuOSSDev->value(progdefaults.OSSdevice.c_str());