aboutsummaryrefslogtreecommitdiff
path: root/comms/fllog
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-04-12 15:32:01 +0000
committerDiane Bruce <db@FreeBSD.org>2014-04-12 15:32:01 +0000
commit2af2407e5fb1074be1972efb2d22a0d6236f26c1 (patch)
tree62e35ce819c7641d90d8881ccdb5bda500c5d309 /comms/fllog
parenteb452fa4876bc704b63fdcdf81efe46ab120347e (diff)
downloadports-2af2407e5fb1074be1972efb2d22a0d6236f26c1.tar.gz
ports-2af2407e5fb1074be1972efb2d22a0d6236f26c1.zip
Amateur radio logbook GUI and logbook server for use with fldigi and friends.
The logbook server maintains a large set of QSO logbook fields that will probably be sufficient for casual operating, contesting and some certificate logging. All of the fields that are captured in the logbook are maintained in an ADIF database. WWW: http://www.w1hkj.com/fllog-help/index.html PR: ports/188487 Submitted by: Stephen Hurd <shurd@sasktel.net>
Notes
Notes: svn path=/head/; revision=351105
Diffstat (limited to 'comms/fllog')
-rw-r--r--comms/fllog/Makefile38
-rw-r--r--comms/fllog/distinfo2
-rw-r--r--comms/fllog/files/patch-configure11
-rw-r--r--comms/fllog/files/patch-src_include_base64.h10
-rw-r--r--comms/fllog/files/patch-src_misc_re.cxx28
-rw-r--r--comms/fllog/pkg-descr7
6 files changed, 96 insertions, 0 deletions
diff --git a/comms/fllog/Makefile b/comms/fllog/Makefile
new file mode 100644
index 000000000000..2d7866853f6f
--- /dev/null
+++ b/comms/fllog/Makefile
@@ -0,0 +1,38 @@
+# Created by: Stephen Hurd <shurd@sasktel.net>
+# $FreeBSD$
+
+PORTNAME= fllog
+PORTVERSION= 1.1.8
+CATEGORIES= comms hamradio
+MASTER_SITES= http://www.w1hkj.com/downloads/fllog/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Ham Radio logging program
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
+
+OPTIONS_DEFINE= NATIVE_OPT
+
+NATIVE_OPT_DESC= Enable Native Optimizations
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES= bin/fllog \
+ share/applications/fllog.desktop \
+ share/pixmaps/fllog.xpm
+
+.if ${PORT_OPTIONS:MNATIVE_OPT}
+CONFIGURE_ARGS+=--enable-optimizations=native
+.else
+CONFIGURE_ARGS+=--enable-optimizations=none
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/fllog/distinfo b/comms/fllog/distinfo
new file mode 100644
index 000000000000..bd5696732f36
--- /dev/null
+++ b/comms/fllog/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fllog-1.1.8.tar.gz) = f4006f4f09317c94227d4c167065d92954cfc96e088830cc8c868170e0c87a35
+SIZE (fllog-1.1.8.tar.gz) = 426362
diff --git a/comms/fllog/files/patch-configure b/comms/fllog/files/patch-configure
new file mode 100644
index 000000000000..7fd653682658
--- /dev/null
+++ b/comms/fllog/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-04-11 13:36:43.000000000 -0700
++++ configure 2014-04-11 13:36:32.000000000 -0700
+@@ -6857,7 +6857,7 @@
+ FLTK_LIBS=`$FLTK_CONFIG --ldflags --use-images`
+ if test "x$target_mingw32" != "xyes"; then
+ if test "x$target_darwin" != "xyes"; then
+- if grep -q "lX11" <<< "$FLTK_LIBS"; then
++ if echo "$FLTK_LIBS" | grep -q "lX11"; then
+ FLTK_LIBS="$FLTK_LIBS";
+ else
+ FLTK_LIBS="$FLTK_LIBS -lm -lX11";
diff --git a/comms/fllog/files/patch-src_include_base64.h b/comms/fllog/files/patch-src_include_base64.h
new file mode 100644
index 000000000000..821847a9f992
--- /dev/null
+++ b/comms/fllog/files/patch-src_include_base64.h
@@ -0,0 +1,10 @@
+--- src/include/base64.h.orig 2014-04-11 13:41:47.000000000 -0700
++++ src/include/base64.h 2014-04-11 13:41:56.000000000 -0700
+@@ -10,6 +10,7 @@
+ #define __BASE64_H_INCLUDED__ 1
+
+ #include <iterator>
++#include <ios>
+
+ static
+ int _base64Chars[]= {'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z',
diff --git a/comms/fllog/files/patch-src_misc_re.cxx b/comms/fllog/files/patch-src_misc_re.cxx
new file mode 100644
index 000000000000..54b93fd9eb18
--- /dev/null
+++ b/comms/fllog/files/patch-src_misc_re.cxx
@@ -0,0 +1,28 @@
+--- src/misc/re.cxx.orig 2014-02-03 15:43:56.000000000 -0800
++++ src/misc/re.cxx 2014-04-11 16:24:42.000000000 -0700
+@@ -120,12 +120,25 @@
+ }
+ }
+
++#ifdef __clang__
++ #if __has_include(<functional>)
++ #include <functional>
++ #define HAS_STD_TR1
++ #endif
++#endif
++#ifndef HAS_STD_TR1
+ #include <tr1/functional>
++#endif
+
+ size_t re_t::hash(void) const
+ {
++#ifdef HAS_STD_TR1
++ size_t h = std::hash<string>()(pattern);
++ return h ^ (std::hash<int>()(cflags) + 0x9e3779b9 + (h << 6) + (h >> 2));
++#else
+ size_t h = tr1::hash<string>()(pattern);
+ return h ^ (tr1::hash<int>()(cflags) + 0x9e3779b9 + (h << 6) + (h >> 2));
++#endif
+ }
+
+ // ------------------------------------------------------------------------
diff --git a/comms/fllog/pkg-descr b/comms/fllog/pkg-descr
new file mode 100644
index 000000000000..2159bdd2809e
--- /dev/null
+++ b/comms/fllog/pkg-descr
@@ -0,0 +1,7 @@
+Amateur radio logbook GUI and logbook server for use with fldigi and friends.
+The logbook server maintains a large set of QSO logbook fields that will
+probably be sufficient for casual operating, contesting and some certificate
+logging. All of the fields that are captured in the logbook are maintained
+in an ADIF database.
+
+WWW: http://www.w1hkj.com/fllog-help/index.html