aboutsummaryrefslogtreecommitdiff
path: root/comms/flrig
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2023-10-12 12:39:29 +0000
committerDiane Bruce <db@FreeBSD.org>2023-10-12 12:39:29 +0000
commiteb08338528c3c4416a95baff9cc8332445b2c523 (patch)
treea76ff0010a9cd442fb0c2972523641c948f59a35 /comms/flrig
parentd948a7220610aa9275272322cdb079f59ebab6ed (diff)
downloadports-eb08338528c3c4416a95baff9cc8332445b2c523.tar.gz
ports-eb08338528c3c4416a95baff9cc8332445b2c523.zip
comms/flrig: Update to latest 2.0.04
In tree version was very out of date. Major change here is the addition of hid support using devel/libudev-devd Additional rigs are now supported few other highlights. 2023-02-04 Leif Sawyer <ak.hepcat+gio@gmail.com> c26976a8: Rescale dialogs b4c30d05: fltk 1.4 update 2023-02-02 dave-w1hkj <w1hkj@bellsouth.net> 7cf542ae: cwio timing d30e60ca: Warnings
Diffstat (limited to 'comms/flrig')
-rw-r--r--comms/flrig/Makefile11
-rw-r--r--comms/flrig/distinfo6
-rw-r--r--comms/flrig/files/patch-src_cmedia_cmedia.cxx13
-rw-r--r--comms/flrig/files/patch-src_cmedia_hid__lin.cxx26
-rw-r--r--comms/flrig/files/patch-src_cmedia_tmate2.cxx13
-rw-r--r--comms/flrig/files/patch-src_support_dialogs.cxx37
6 files changed, 98 insertions, 8 deletions
diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
index aff02a5d7393..86103810d550 100644
--- a/comms/flrig/Makefile
+++ b/comms/flrig/Makefile
@@ -1,8 +1,8 @@
PORTNAME= flrig
-PORTVERSION= 1.3.54
-PORTREVISION= 2
+PORTVERSION= 2.0.04
CATEGORIES= comms hamradio
-MASTER_SITES= SF/fldigi/${PORTNAME}
+MASTER_SITES= SF/fldigi/${PORTNAME} \
+ http://www.w1hkj.com/files/fldigi/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Ham Radio rig control program, cooperates with fldigi
@@ -12,9 +12,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig \
- libfltk.so:x11-toolkits/fltk
+ libfltk.so:x11-toolkits/fltk \
+ libudev.so:devel/libudev-devd
-USES= gmake jpeg xorg
+USES= gmake jpeg xorg desktop-file-utils
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes
diff --git a/comms/flrig/distinfo b/comms/flrig/distinfo
index 33953f36cd44..8e1960a5c115 100644
--- a/comms/flrig/distinfo
+++ b/comms/flrig/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612452402
-SHA256 (flrig-1.3.54.tar.gz) = cf0d318b80159e6f158bfa16921d770bd06369b38a52d65a5662cdfbecca1ae8
-SIZE (flrig-1.3.54.tar.gz) = 891644
+TIMESTAMP = 1697039885
+SHA256 (flrig-2.0.04.tar.gz) = f80710ee5d515c50d556b698c9205413ff990b208e3223362f82f245716ab947
+SIZE (flrig-2.0.04.tar.gz) = 1108760
diff --git a/comms/flrig/files/patch-src_cmedia_cmedia.cxx b/comms/flrig/files/patch-src_cmedia_cmedia.cxx
new file mode 100644
index 000000000000..4e2e1b9b8583
--- /dev/null
+++ b/comms/flrig/files/patch-src_cmedia_cmedia.cxx
@@ -0,0 +1,13 @@
+--- src/cmedia/cmedia.cxx.orig 2023-09-23 00:17:45 UTC
++++ src/cmedia/cmedia.cxx
+@@ -42,7 +42,9 @@
+ #include <termios.h>
+ #include <glob.h>
+ # ifndef __APPLE__
+-# include <error.h>
++# ifndef __FreeBSD__
++# include <error.h>
++# endif
+ # endif
+ #endif
+
diff --git a/comms/flrig/files/patch-src_cmedia_hid__lin.cxx b/comms/flrig/files/patch-src_cmedia_hid__lin.cxx
new file mode 100644
index 000000000000..20a1a5619c4e
--- /dev/null
+++ b/comms/flrig/files/patch-src_cmedia_hid__lin.cxx
@@ -0,0 +1,26 @@
+--- src/cmedia/hid_lin.cxx.orig 2023-10-05 17:27:21 UTC
++++ src/cmedia/hid_lin.cxx
+@@ -35,12 +35,22 @@
+ #include <fcntl.h>
+ #include <poll.h>
+
++#ifdef __FreeBSD__
++typedef unsigned short uint16_t;
++typedef unsigned char __u8;
++typedef unsigned long __u32;
++#include <dev/hid/hidraw.h>
++/* These are from linux */
++#define BUS_USB 0x03
++#define BUS_BLUETOOTH 0x05
++#include <libudev.h>
++#else
+ /* Linux */
+ #include <linux/hidraw.h>
+ #include <linux/version.h>
+ #include <linux/input.h>
+ #include <libudev.h>
+-
++#endif
+ #include "hidapi.h"
+
+ /* Definitions from linux/hidraw.h. Since these are new, some distros
diff --git a/comms/flrig/files/patch-src_cmedia_tmate2.cxx b/comms/flrig/files/patch-src_cmedia_tmate2.cxx
new file mode 100644
index 000000000000..f9526c9d4643
--- /dev/null
+++ b/comms/flrig/files/patch-src_cmedia_tmate2.cxx
@@ -0,0 +1,13 @@
+--- src/cmedia/tmate2.cxx.orig 2022-03-21 23:27:19 UTC
++++ src/cmedia/tmate2.cxx
+@@ -45,7 +45,9 @@
+ #include <termios.h>
+ #include <glob.h>
+ # ifndef __APPLE__
+-# include <error.h>
++# ifndef __FreeBSD__
++# include <error.h>
++# endif
+ # endif
+ #endif
+
diff --git a/comms/flrig/files/patch-src_support_dialogs.cxx b/comms/flrig/files/patch-src_support_dialogs.cxx
new file mode 100644
index 000000000000..ee0be91120f6
--- /dev/null
+++ b/comms/flrig/files/patch-src_support_dialogs.cxx
@@ -0,0 +1,37 @@
+--- src/support/dialogs.cxx.orig 2023-10-11 20:05:33 UTC
++++ src/support/dialogs.cxx
+@@ -179,7 +179,7 @@ void init_port_combos()
+ add_combos(gbuf.gl_pathv[j]);
+ }
+ globfree(&gbuf);
+-
++#ifndef __FreeBSD__
+ glob("/dev/serial/by-id/*", 0, NULL, &gbuf);
+ for (size_t j = 0; j < gbuf.gl_pathc; j++) {
+ if ( !(stat(gbuf.gl_pathv[j], &st) == 0 && S_ISCHR(st.st_mode)) ||
+@@ -189,7 +189,7 @@ void init_port_combos()
+ add_combos(gbuf.gl_pathv[j]);
+ }
+ globfree(&gbuf);
+-
++#endif
+ glob("/dev/tty*", 0, NULL, &gbuf);
+ for (size_t j = 0; j < gbuf.gl_pathc; j++) {
+ if ( !(stat(gbuf.gl_pathv[j], &st) == 0 && S_ISCHR(st.st_mode)) ||
+@@ -296,9 +296,15 @@ out:
+ }
+
+ const char* tty_fmt[] = {
+- "/dev/ttyS%u",
++#ifndef __FreeBSD__
+ "/dev/ttyUSB%u",
++ "/dev/ttyS%u",
+ "/dev/usb/ttyUSB%u"
++#endif
++#ifdef __FreeBSD__
++ "/dev/cuau%u",
++ "/dev/cuaU%u",
++#endif
+ };
+ LOG_QUIET("%s", "Serial port discovery via 'stat'");
+ for (size_t i = 0; i < sizeof(tty_fmt)/sizeof(*tty_fmt); i++) {