aboutsummaryrefslogtreecommitdiff
path: root/comms/flwrap
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2011-02-03 01:58:21 +0000
committerDiane Bruce <db@FreeBSD.org>2011-02-03 01:58:21 +0000
commitdf101763be5b05f92d0ae6f660f8015835cdda40 (patch)
tree6d669bcdebcb4fa0428c29bb2d8cddfe89b20a07 /comms/flwrap
parent0972d2bdd2c7ba2e0ecfddcfb75a67ec743299c9 (diff)
downloadports-df101763be5b05f92d0ae6f660f8015835cdda40.tar.gz
ports-df101763be5b05f92d0ae6f660f8015835cdda40.zip
- new port companion to fldigi
Submitted by: self Reviewed by: rneese a gmail.com Feature safe: yes
Notes
Notes: svn path=/head/; revision=268567
Diffstat (limited to 'comms/flwrap')
-rw-r--r--comms/flwrap/Makefile37
-rw-r--r--comms/flwrap/distinfo2
-rw-r--r--comms/flwrap/pkg-descr6
-rw-r--r--comms/flwrap/pkg-plist6
4 files changed, 51 insertions, 0 deletions
diff --git a/comms/flwrap/Makefile b/comms/flwrap/Makefile
new file mode 100644
index 000000000000..5ca04229bd14
--- /dev/null
+++ b/comms/flwrap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: flwrap
+# Date created: January 23 2011
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flwrap
+PORTVERSION= 1.1.1
+CATEGORIES= comms hamradio
+MASTER_SITES= http://www.w1hkj.com/fldigi-distro/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Flwrap is a companion utility for fldigi
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
+ -e 's|^CPPFLAGS|#CPPFLAGS|' \
+ ${WRKSRC}/src/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO} ""
+ @${MKDIR} ${DOCSDIR}
+ @@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${ECHO} "flwrap docs installed in ${DOCSDIR}"
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/flwrap/distinfo b/comms/flwrap/distinfo
new file mode 100644
index 000000000000..71263ca673b4
--- /dev/null
+++ b/comms/flwrap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flwrap-1.1.1.tar.gz) = c81a32ab61fcd67e1c6526c24695c2635e271acf18e1cba6d784247a6cb75ab6
+SIZE (flwrap-1.1.1.tar.gz) = 186323
diff --git a/comms/flwrap/pkg-descr b/comms/flwrap/pkg-descr
new file mode 100644
index 000000000000..69ab7aa0d044
--- /dev/null
+++ b/comms/flwrap/pkg-descr
@@ -0,0 +1,6 @@
+The flwrap executable is a small desktop application that encapsulates
+a text file, an image file, or a binary file within a set of identifier
+blocks. These blocks include a 16 bit checksum that is used to test
+the encapsulated file for integrity.
+
+WWW: http://www.w1hkj.com/Flwrap/
diff --git a/comms/flwrap/pkg-plist b/comms/flwrap/pkg-plist
new file mode 100644
index 000000000000..b914f20ae64d
--- /dev/null
+++ b/comms/flwrap/pkg-plist
@@ -0,0 +1,6 @@
+bin/flwrap
+share/applications/flwrap.desktop
+share/pixmaps/flwrap.xpm
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications